Jump to content
  • 0
ahmbor

"Issues with Nvidia Graphics Cards" - Fixed?

Question

Recommended Posts

  • 1

Patch 5.0 is out just in time for the game's 1 year anniversary and there's still no fix for this (I just tested it a few moments ago). You can't be serious, Obsidian.

Share this post


Link to post
Share on other sites
  • 1

Hi everyone,

We are still looking into the Nvidia issue, but we haven't been able to reproduce it on our end with a wide variety of hardware. Today, I ran through some tests on a 1070 and I was getting around 40-50fps in the Neketaka Docks. It's not an ideal framerate, but it's fairly stable while moving the party and camera around. Occasionally the frame rate drops or stutters briefly, but it doesn't seem as frequent or severe as what is reported. Our profiling investigation shows that the game is heavily CPU bound. Most of the frame time is taken up by the ability, AI, and status effect systems. This means that the CPU is the bottleneck and not the GPU.

As a second test, our IT department swapped a 2080 into my rig (nice! 😀😀😀), and I ran through the docks and got similar framerate and performance. This lines up because we are CPU bound. As a side note, lowering the resolution is also a good test to see if the game is GPU or CPU bound. If a lower resolution gives more frames then the GPU is the bottleneck. The 2080 confirms we are CPU bound on the upper end of hardware, and unfortunately, even with the 2080 I'm still unable to reproduce the massive stutter/locks that some are experiencing.

A few things moving forward:

  • I would like to continue to look at CPU performance and see if we can get any gains by optimizing some of the above systems (abilities). I have a few ideas in mind that may work, but optimizations to key systems are risky because they can introduce bugs. We will see what we can do, and I'll keep everyone updated on if we made progress in this area. The big problem is that we just have too much stuff. In the city, we can have hundreds of active abilities and status effects, each unique with custom scripting. Many of these need to be updated each frame. It's a problem, and one that can be solved.
  • As an ask to the community: can anyone please record a video on the NVidia stuttering or find one that's already been made? It will be immensely helpful to take a look at it. Thank you!
  • Also, can anyone supply a new save game with this issue happening? Does this issue happen if you jump straight into a low performance area? (iroll20s on the main menu console. F-11 to jump to a map). 
  • There's also a reported performance problem that could be save game or achievement related. I would also be interested in getting save games from people experiencing that issue to see if we can see what's causing the freeze.
  • We are aware of the Special K mod and fix. (You can view the thread here on Steam). A few programmers here looked into this last year when it was first reported, and we were unable to do anything on our end because it would require us to modify the Unity source code (which we aren't doing for Deadfire). Another unfortunate circumstance is we are running on a old version of Unity (5.6) and upgrading the engine to get the potential fix would be a significant undertaking. We are well aware this is still a problem, I'm discussing solutions with everyone to see if we can find a resolution.

Hopefully we can tackle some of these issues and make the game as best as it can be.

 

  • Like 2
  • Thanks 1
  • Hmmm 1

Follow me on twitter - @adam_brennecke

Share this post


Link to post
Share on other sites
  • 0

I asked about it week ago and no update still or any info whatsoever.

Edited by Sidushi

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

This is still unfortunately a problem that we have continued to work on and purchase more hardware in an attempt at reproducing the issue so that we can fix it.  We will absolutely make a big mention of this in future patch notes when this gets fixed as this is the toughest issue we have had to fix so far for Deadfire and will be ridiculously glad to not have to worry about it anymore.  We sincerely do apologize for the problems, frustrations, and length of time this fix is taking and will continue to do what we can to resolve it.  If you ever find any more information about this bug, please let us know so that we can look into your findings and get this fixed up.

 

Thank you, and sorry for the inconvenience this has been causing.

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

This is still unfortunately a problem that we have continued to work on and purchase more hardware in an attempt at reproducing the issue so that we can fix it.  We will absolutely make a big mention of this in future patch notes when this gets fixed as this is the toughest issue we have had to fix so far for Deadfire and will be ridiculously glad to not have to worry about it anymore.  We sincerely do apologize for the problems, frustrations, and length of time this fix is taking and will continue to do what we can to resolve it.  If you ever find any more information about this bug, please let us know so that we can look into your findings and get this fixed up.

 

Thank you, and sorry for the inconvenience this has been causing.

 

I read some NVIDIA threads and supposedly some people who have 10XX with Micron DDR5 memory are having such issues maybe you could look into it, here is my card info:

 

tj4.png

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

 

Hey everyone,

 

This is still unfortunately a problem that we have continued to work on and purchase more hardware in an attempt at reproducing the issue so that we can fix it.  We will absolutely make a big mention of this in future patch notes when this gets fixed as this is the toughest issue we have had to fix so far for Deadfire and will be ridiculously glad to not have to worry about it anymore.  We sincerely do apologize for the problems, frustrations, and length of time this fix is taking and will continue to do what we can to resolve it.  If you ever find any more information about this bug, please let us know so that we can look into your findings and get this fixed up.

 

Thank you, and sorry for the inconvenience this has been causing.

 

I read some NVIDIA threads and supposedly some people who have 10XX with Micron DDR5 memory are having such issues maybe you could look into it, here is my card info:

 

tj4.png

 

 

Thx for your post, i have a GTX1070 from the first wave with Samsung DDR5 VRAM. I will check it out later if i got memory leaks/fps drops too. Maybe it is 'Micron' problem.

Share this post


Link to post
Share on other sites
  • 0

Stuttering (on a GTX 1070) frankly killed my enjoyment of this game, which I gladly backed. I was really looking forward to the DLCs, only to realise that the issue has yet to be fixed. I'm not about to purchase a new, potentially crummier GPU to replace a perfectly functional one, at least if we go by every other game in my library. Something needs to be done, and fast.

  • Like 4

Share this post


Link to post
Share on other sites
  • 0

 I have an Nvidia GeForce GTX 980 Ti & AMD FX 9590 Eight Core Processor with 16gigs ram.  Task manager show the GPU pegged at 100% playing Pillars of Eternity 2.  Really frustrating as I do love this game.  I stop playing it because of the issues.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

This is still unfortunately a problem that we have continued to work on and purchase more hardware in an attempt at reproducing the issue so that we can fix it.  We will absolutely make a big mention of this in future patch notes when this gets fixed as this is the toughest issue we have had to fix so far for Deadfire and will be ridiculously glad to not have to worry about it anymore.  We sincerely do apologize for the problems, frustrations, and length of time this fix is taking and will continue to do what we can to resolve it.  If you ever find any more information about this bug, please let us know so that we can look into your findings and get this fixed up.

 

Thank you, and sorry for the inconvenience this has been causing.

 

Thanks for letting us know.

 

If you want, PM me and I am happy to test / send more info / whatnot on my system.


Nescire autem quid ante quam natus sis acciderit, id est semper esse puerum. Quid enim est aetas hominis, nisi ea memoria rerum veterum kum superiorum aetate contexitur? Marcus Tillius Cicero

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

I'm sorry that this is still an issue for all or most of you.  This is still our number one concern and programmers are still looking for ways to improve the performance issues on these Nvidia cards while we wait for help from Nvidia.  I know there have been a few tweaks between the last few patches, but no "cure-all" fix yet.  I am truly sorry that this is still an active issue for you and hope that we can get everyone running Deadfire the way it is intended.

 

Sorry again for all the frustration this has been causing and thank you for your tremendous patience.

  • Like 4

Share this post


Link to post
Share on other sites
  • 0

Well, for me the problem is apparently related to dynamic lighting, because turning that option off makes the game look flat, but the fps is stable, and nothing stutters. And it's actually really sad, this game is almost done with new patches, so I guess we shouldn't expect a proper solution, BUT... *fingers crossed* 

Share this post


Link to post
Share on other sites
  • 0

Can we get an update on this? … It is depressing not being able to play the game.


Nescire autem quid ante quam natus sis acciderit, id est semper esse puerum. Quid enim est aetas hominis, nisi ea memoria rerum veterum kum superiorum aetate contexitur? Marcus Tillius Cicero

Share this post


Link to post
Share on other sites
  • 0
On 1/24/2019 at 2:56 AM, SChin said:

Hey everyone,

 

I'm sorry that this is still an issue for all or most of you.  This is still our number one concern and programmers are still looking for ways to improve the performance issues on these Nvidia cards while we wait for help from Nvidia.  I know there have been a few tweaks between the last few patches, but no "cure-all" fix yet.  I am truly sorry that this is still an active issue for you and hope that we can get everyone running Deadfire the way it is intended.

 

Sorry again for all the frustration this has been causing and thank you for your tremendous patience.

Any update?

 


Nescire autem quid ante quam natus sis acciderit, id est semper esse puerum. Quid enim est aetas hominis, nisi ea memoria rerum veterum kum superiorum aetate contexitur? Marcus Tillius Cicero

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...