Jump to content

Patch Hotfix incoming!

Recommended Posts

Hey everyone!


Later today we will be patching the game to! We have submitted the build and are currently in review. Thank you everyone for being so patient with us. Please keep in mind that the upload will take some time to reach across all regions. If you see that the game is asking for an update, but doesn't update right away, please give it an hour or two.


Top Community Issues

These are issues you have all helped to bring to our attention. We can't thank you enough for your feedback on the game! These issues have been the most discussed here on the forum and these, along with many more, will be fixed when goes live!


Android users unable to load the game

  • Android users on certain devices were  unable to load the game after the patch.  This has been resolved.

Encountering the ally Morgiv results in cards being lost from character decks

  • Issue has been resolved.  We cannot fix this retroactively in-game, but are working on a CS method to rebuild affected character decks.

Progression break when acquiring Roles

  • There was a progression break when more than 1 character acquired roles.  The main issue has been resolved.  There is a smaller edge case that can still break progression - if you go to the Rules before selecting your roles progression can break.  You can work around this by restarting the game and proceeding without interacting with the Rules button.

Cards staying on top of the deck when defeated

  • Haunts, Zombie Horde and Zombie nest would remain at the top of the location deck even when they should otherwise be defeated. This has been fixed.

Seoni & Lem losing powers

  • There was an issue where Seoni and Lem would have their Role switched to a different one, and you couldn't see the power feats that had been acquired from the role.  While these should have continued to function as normal, the issue as been resolved and fixes the characters affected.  Any instances of Lem or Seoni who acquired roles since 1.1.6 will have this issue again, and need to be manually corrected.
Other Fixes

Here's the list of other fixes we've addressed in this patch, broken down by type!


Progression Breaks

  • Into the Runeforge: Resolved a progression break on Heroic+ when encountering the henchman and Revenge of the Wrathful wildcard is active
  • Assault on the Pinnacle: Resolved a progression break that would occur when defeating The Thing From Beyond Time.


  • Lini: Animal Empathy now properly recharges played allies with the animal trait again


  • Power Feat Loss with Alts: It was possible to lose a power feat by selecting a power you already owned, but wasn't displayed on a version of the character you didn't acquire it on.  This issue has been resolved.
  • Roles skipped: If there was a character that gained their maximum number of power feats, they would skip role acquisition.  (This also skipped roles for other characters in party that were not maxed out).  This has been resolved.


  • Into the Eye: You can no longer close the location when defeating a henchman.


  • Special Offer: Rolling All The Way: Offer was not granting the correct items.  This has been resolved.  Anyone who purchased the offer and didn't get the correct items should contact support@obsidian.net to get the proper items granted to their account.


  • New Boosters Not Dropping: Resolved an issue where the new boosters weren't dropping at the desired rate.


As always we'll be checking the technical support forums on release of the patch for any and all feedback you all provide. Thank you all for making the launch of Pathfinder Adventures be an awesome one and we look forward to bringing you more content as soon as we can!



  • Like 2
Link to comment
Share on other sites

What about the quest mode card feats bug? I'm not saying you shouldn't patch the other things straight away (particularly Morgiv) if they're fixed, but quest mode is completely unplayable until that gets fixed, I'd have thought it was a fairly high priority. Is there an ETA on the next patch?

  • Like 2
Link to comment
Share on other sites

I hate to say it, but the 'Can't log into the game' and the 'Banishing entire hands worth of cards' were higher priority items that needed to get out _now_. The progression break on Quest mode is likely to be in the next update. It's likely a more difficult fix, and would have delayed the other fixes getting pushed.

  • Like 3
Link to comment
Share on other sites

Since this patch, I can no longer complete the daily "The gift that keeps on giving" (Give 15 cards to another character). Also, since I completed 2 dailies and there is only 2 days left, that means because of this bug, I cannot complete the weekly either.


Would there be something to counter the fact I may not be able to acquire my daily and weekly reward?

Link to comment
Share on other sites

Given the other post about being closed over break, I assume that means that the recharges will be broken to the new year. Unfortunate, since it basically makes it unplayable for me. Is there any way to rollback to an earlier version instead of pushing forward?

Which recharges are you still having issues with?  From what I've seen so far, seems to be more-or-less back to the AD5 way of doing things.

Link to comment
Share on other sites

The big problem I encountered from Morgiv banishing most of my characters' decks is that I have no way of getting some of the items back ever again, such as the Emerald Codex; it isn't in the inventory page, and I've never encountered it outside of it being a reward. My sorcerer used to have two disintergrate and teleport spells, my wizard an array of useful and powerful spells, too; but it seems like along with having banished my cards, the inventory page simply lacks most of my spells I have acquired throughout the game.

Is there any way for me to get them back, or do I need to restart the entire game yet again?

Link to comment
Share on other sites

Too bad the Quest mode still remains unfixed. I had to delete 5 characters because of these issues.


Also, is it only me or anyone else is also bothered by needless dice rolling?

Imagine, you are required to roll 8 while you have two dice and +6 modifier. There is no way you roll less than 8! Why would you need to roll in the first place (animations waste a lot of time in this game).

Wouldn't it be better to just show "Succeed" button and get this over with? (like it is done in Talisman, Chainsaw Warrior and lots of other games).


Anyway, Happy Holidays to everyone!

  • Like 1
Link to comment
Share on other sites

The last information about quest mode can be found from here



It is possible that quest mode is removed, it is Also possible that They make the quest mode ready later after/before PC version and so on has been done, or it will change to something completely new... But in short time line the quest mode is on the hold.

Edited by Hannibal_PJV
Link to comment
Share on other sites

Since this patch, I can no longer complete the daily "The gift that keeps on giving" (Give 15 cards to another character).

I noticed that too, along with the game allowing me to gift multiple cards per turn (isn't that supposed to be just 1)?


Would there be something to counter the fact I may not be able to acquire my daily and weekly reward?

You mean like free gold and getting the Festive Wool Hide anyway?


we will also be gifting everyone 2,500 gold AND the Festive Wool Vest as compensation. 


Link to comment
Share on other sites

I have discovered this crazy bug in 6.2 "The Road through Xin-Shalast".


It is hard for me to describe what happened so I have prepared a screencast of my gameplay and uploaded it to Dropbox, the following is the link:




The video lasts about 20mins so please bear with me (please mute the video as well).


Basically after I defeated a Wardens of Runes and attempt to close a location, Ghlorofaex would appear and uses his power. Before I attempt the Dexterity or Arcobatics 14 Check, I choose to forfeit the game. Ghlorofaex would then be stuck on the screen forever.


After that, I tried to select any scenario to play (it could be 1.2 or 2.1 or whatever), the first card that I draw would always be Ghlorofaex!!! I tried to kill and relaunch the game and select any scenario again many times, the result is the same i.e. the first card that I draw would be Ghlorofaex!!!


Right now my save is a total mess and I do not know how to proceed. Grateful if someone could fix my save and the bug.


It seems numerous bugs have been introduced since AD5. I have encountered many lingering bugs which I couldn't be bothered to describe here. I think the developers should spend some time to quash the bugs and have a serious play test before introducing more features to the game.


I am running version on Android 7.1.1 on Nexus 6P.

Edited by cheungie
Link to comment
Share on other sites

Odd question but what was in the offer "Rolling All The Way" as it disappeared once I bought it so hard to check if I received everything.


Why odd? Here you go:


 - One set of Jingle Dice (looks nice)

 - Spell "Song of Hawkmoon" (rather useless, if you ask me)

 - Ally "Pathfinder Chronicler" (a good one, I'd leave it in my deck if I fond it)

 - 15 Treasure chests (nuff said)

Link to comment
Share on other sites

I am having the exact same problem as Cheungie right now. The game is completely unplayable.

This problem is bloody annoying! There are times when I could somehow get rid of that damn dragon but nothing is working at the moment.


Since Christmas is approaching I don't expect this problem going away any time soon.


It pains me to say this, but it appears to me that Obsidian is staying true to its reputation for being a "buggy" company.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...