Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Jerky mouse fix


  • Please log in to reply
29 replies to this topic

#1
acrh2

acrh2

    (1) Prestidigitator

  • Members
  • 14 posts
(The mouse handling is still pretty broken in the game. As soon as the framerate in game drops below MaxSmoothedFrameRate, mouse becomes very jerky.)

This fix addresses the issues for people who already improved their jerky mouse issue by lowering
MaxSmoothedFrameRate.

Asset (textures and other things) streaming makes the game drop the framerate severely in certain spots on the map. This fix works by minimizing the streaming, so the framerate and consequently the mouse are much more stable and smooth.

In APEngine.ini (C:\Users\username\Documents\Alpha Protocol\APGame\Config), change the following settings:

UseBackgroundLevelStreaming=false
OnlyStreamInTextures=true



This made the game almost entirely jerky free for me at MaxSmoothedFrameRate=62, but I do have a very high end system.
(I also changed some cache size values in the same file, but I'm not sure that they are needed.)

#2
acrh2

acrh2

    (1) Prestidigitator

  • Members
  • 14 posts
And the final fix:

OneFrameThreadLag=False in the same file.

This should fix all mouse issues, it seems.

Edited by acrh2, 31 May 2010 - 06:54 AM.


#3
PwNinat0r2000

PwNinat0r2000

    (1) Prestidigitator

  • Members
  • 16 posts
Excellent work, this seems to have completely fixed the mouse stuttering issue.

Thanks!

#4
DaniDE

DaniDE

    (1) Prestidigitator

  • Members
  • 13 posts
Ohh...I gonna try this asap. Thanks alot in advance!



Edit: I confirm this has fixed all stuttering for me. I can even snipe now. I use smoothing min=20, max=62 and finally have a fluent gameplay :D
Edit 2: I have not changed any cache settings, just fyi.

-Dani

PS: You should get a medal or something.

Edited by DaniDE, 31 May 2010 - 07:19 AM.


#5
Lexx

Lexx

    Adventurer of the Obsidian Order

  • Members
  • 3737 posts
  • Location:Germany
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
"OneFrameThreadLag=False" worked for me. Thanks for the tip.

#6
Oner

Oner

    Loner of the Obsidian Order

  • Members
  • 7444 posts
  • Pillars of Eternity Backer
  • Deadfire Backer
  • Fig Backer
It's..it's beautiful.. :p

#7
blackwolfe

blackwolfe

    (2) Evoker

  • Members
  • 78 posts
Thanks, I'll give this a try

#8
cesko

cesko

    (3) Conjurer

  • Members
  • 149 posts
  • Location:Holland
  • Xbox Gamertag:Cesko
Is this also a sort of fix for those framedrops?

#9
Tigranes

Tigranes

    Obsidian VIP

  • Members
  • 10419 posts
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer
Sounds great, adding to known issues thread (which will be up soon) now. Thanks for working it out! :)

#10
blackwolfe

blackwolfe

    (2) Evoker

  • Members
  • 78 posts
Still experiencing jerky mouse issues after the fix.

#11
PwNinat0r2000

PwNinat0r2000

    (1) Prestidigitator

  • Members
  • 16 posts

Still experiencing jerky mouse issues after the fix.


They've crept back for me too. Managed that first "Bug the Airbase" mission fine but the next one where you go underground and upload some data has been really sketchy. Time for another thread about that mission though, it's got completely different problems as well as the stuttering.

#12
acrh2

acrh2

    (1) Prestidigitator

  • Members
  • 14 posts

Still experiencing jerky mouse issues after the fix.


They've crept back for me too. Managed that first "Bug the Airbase" mission fine but the next one where you go underground and upload some data has been really sketchy. Time for another thread about that mission though, it's got completely different problems as well as the stuttering.


I noticed this too. In the last few missions (last Rome and the final mission), there's momentary mouse lag. I'm guessing that the map designers didn't optimize their "streaming materials" for the last few missions. The mouse jerkiness was fixed, but excessive load of textures was still there, resulting in some general framerate drop.

Nevertheless, I've reloaded some older missions, and they were mostly smooth as butter.

I'm pretty much done investigating the quirks of the Unreal Engine. At this point, Obsidian needs to step up to the plate...

#13
Tokie

Tokie

    (1) Prestidigitator

  • Members
  • 6 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
The fix made the game MUCH better. Thanks for posting it!

Though it still stutters at some places, at least it's less frequent now.

#14
PwNinat0r2000

PwNinat0r2000

    (1) Prestidigitator

  • Members
  • 16 posts

I'm pretty much done investigating the quirks of the Unreal Engine. At this point, Obsidian needs to step up to the plate...


Agreed.

#15
poolofpoo

poolofpoo

    (4) Theurgist

  • Members
  • 373 posts
still stutters for me but maybe not as much, now the menus are slow instead and i've made a complete mess of my .ini-files

great fun

#16
blackwolfe

blackwolfe

    (2) Evoker

  • Members
  • 78 posts
I cant even remember what I did to my ini files, but there are tons and tons of changes in search of a fix. The stuttering aint there, but the mouse jerkiness is. So... they are a complete mess at the moment.

Edited by blackwolfe, 01 June 2010 - 04:50 AM.


#17
player1

player1

    (4) Theurgist

  • Members
  • 363 posts
  • Deadfire Backer
  • Fig Backer
It should be noted that bUseBackgroundLevelStreaming=False increases memory load (level segments are preloaded, instead streamed during play), so while it helps with short lag that happens from time to time (when game loads stuff), it can actually be bad for configurations with small amount of RAM (1-2GB).

On the other hand, OneFrameThreadLag=False addresses constant mouse shuttering, if frame rate is not perfect 60. Without it, when I tested with FRAPS, with perfect 60fps, there was no shuttering, but when it dropped to 55 or less, it would shutter when moving mouse. With fix, it doesn't happen anymore.


My preliminary testing shows that OnlyStreamInTextures=True is not needed.

.

Anyway, for now, I use these two only:
bUseBackgroundLevelStreaming=False
OneFrameThreadLag=False

Edited by player1, 01 June 2010 - 09:39 AM.


#18
Calax

Calax

    Former Superman

  • Members
  • 8293 posts
  • Location:The Fortress of Solitude
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
Oddly enough, the stuff is in different places with XP I can't find anything like this in the "DefaultEngine" ini, or "DefaultGame", "DefaultUI"

Edit:Whoops, was looking in the program files directory rather than my docs.

Edited by Calax, 01 June 2010 - 12:07 PM.


#19
DaniDE

DaniDE

    (1) Prestidigitator

  • Members
  • 13 posts
Yeah sadly the jerkyness came back on later levels, it was especially bad in moscow / braykos villa. But the settings above made it much better most of the time.

-Dani

Edited by DaniDE, 02 June 2010 - 02:51 AM.


#20
Reg1.1

Reg1.1

    (2) Evoker

  • Members
  • 79 posts
And the sniper spazz has still not been fixed, and Obsidian aren't breathing a word to the community about anything.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users