Jump to content
  • 0
anathanielh

[Level Scaling] [Difficulty] [POTD]Compilation Thread

Question

I'm not playing on expert mode and the difficulty indicators are not showing even though I have them set to be enabled. Is there a fix for this?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

 

Heya everyone,

 

This is actually working as designed. Using the Level Scale feature disables the difficulty skulls. I asked our design team about it, and it's because the skull system relies on quests and monsters having a "difficulty" level set manually for the skulls to pull from. With the level scaling feature enabled these manual entries don't adjust, making the skulls inaccurate.

 

Hope that clears things up.

 

I don't understand why it doesn't still function with the only scale up option. If the zone is using its manually set level because its 8 levels higher than me and not scaling up, then shouldn't the game still be able to tell me that the fight is higher level than me? If I'm level 6 and the area is level 14 without scaling, the only scale up option has had 0 impact on it at that point and only would impact it if I'm higher level than the manually set level, at which point the skulls wouldn't be showing anyways because it'd be scaled up to be equal. 

 

 

Agreed man, there's been more than a few instances where I've had my butt handed to me because an obviously harder encounter did not have the skulls to show the difficulty of it :(

Share this post


Link to post
Share on other sites
  • 0

Adding my voice to the chorus. That explanation makes sense for scaling everything, but not for the "only scale up" option. The game doesn't differentiate what's below your level, only what's above it - and that remains the same if you're only scaling up.

 

Is there a value to mod or a console command to execute which would allow us to turn this back on manually?

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'm going to write up a suggestion to keep the skulls active when "only scale up" is selected. Maybe we can get this implemented for a future patch =)

  • Like 11

I try my very best.

Share this post


Link to post
Share on other sites
  • 0

I initially started the game with level scaling set to All, Scale Up only. 

During the game I needed to change briefly from Veteran -> Casual due to getting stuck in the Old City at a very low level.

 

Afterwards I changed my difficult back to Veteran. Unfortunately this locked my level scaling to None. I tried changing the difficulty again but I cannot change the scaling back and it is locked at None. I am not sure if this is a UI bug or actual change, but I did notice the quests started displaying the scull icons afterwards, which after reading the forum is only set is level scaling is None.

 

Is there a file or command I can edit/run to set level scaling back until this issue is fixed?

Thank you for the help!

 

Steps To Reproduce:

Have level scaling enabled, Veteran Difficulty.
1. Change difficulty to Casual

2. Hit "Save" to confirm changes to maps that have not been visited. (Note that scaling is still working)

3. Change difficult back to Veteran 

4. Hit "Save" to confirm changes to maps that have not been visited. (Now scaling is set to None, and quests have skulls on them)

PS - I have save files you can use to test this but the file uploader will not permit me to upload them.

Edited by mbellis111

Share this post


Link to post
Share on other sites
  • 0

I'm going to write up a suggestion to keep the skulls active when "only scale up" is selected. Maybe we can get this implemented for a future patch =)

That would be very helpful. Also if you're gonna be looking into this anyway, perhaps it is an idea to still show skulls for everything else besides the critical path if the level scaling is specified for only the critical path. 

Edited by Vastus

Share this post


Link to post
Share on other sites
  • 0

I'm going to write up a suggestion to keep the skulls active when "only scale up" is selected. Maybe we can get this implemented for a future patch =)

This would be really useful because at this point, sometimes,I get screwed without understanding anything at all (I play POTD with upsacling up only).


★ ★ ★ ★ ★ ★ ★ ★ ★ I ' M ★  ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ B L A C K S T A R   ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ 

Share this post


Link to post
Share on other sites
  • 0

Ah understood, This is not a bug and is how the game is intended to be played. Skull indicators have been removed, though I will get in that this is difficult for players to assess. Sincere apologies all! 

 

This makes absolutely no sense, as others have pointed out already.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

As a stopgap measure here's a table of quest info I extracted from the game files. Good enough for checking the level of a specific quest or deciding on a new direction. (Spoilers, obviously.)

Google Drive link (searchable).

 

G6tYAGR.png

Edited by Aravane
  • Like 7

Share this post


Link to post
Share on other sites
  • 0

I would like to note that this is really very welcome for those of us who want to try Ironman playthroughs. Knowing how to plan the path to victory helps a great deal.

Share this post


Link to post
Share on other sites
  • 0

I'll ensure this post is linked when it is bugged so the devs can see your guys' suggestions.

 

Thank you for taking the time to respond!

 

Best,

 

-Caleb


I like big bugs and I cannot lie...

Share this post


Link to post
Share on other sites
  • 0

I am confused as well, I have this option activated and on one playthrough it shows, the other it doesn't, now you say it shouldn't show ever at all ?

Please clarify what the intended behavior atm is and how the ingame option alters it (or should)

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

Difficulty indicators do not display when level scaling is enabled. Basically, every quest/creature/area has a predetermined level and this level is used to determine what the difficulty indicators display. When level scaling is enabled, the levels of these quests/creatures/areas are changed, but the difficulty indicator system is not set up to account for changes in difficulty scaling. Because of this, we opt to not display difficulty indicators when level scaling is enabled, rather than displaying inaccurate information. That being said, we are still tracking this issue internally and reviewing our systems. Thanks a lot for the feedback, everyone!

 

- JL

Share this post


Link to post
Share on other sites
  • 0

Heya mbellis111,

 

Nice find! I think what's happening here is that by changing difficulties it's changing the level scaling state to the "default" of that difficulty level. So changing to "casual" or "story time" will force it on, while changing to "veteran or PotD" will force it off, which is not ideal. 

 

I'll add this issue to our database to see if we can get it addressed =)

 

 

Unfortunately the only way to reset it is to load a save prior to when the issue occurred.

 

Thanks again!


I try my very best.

Share this post


Link to post
Share on other sites
  • 0

But if "only scale up" is enabled and I'm level 6 and a quest has a predetermined level of 10, then nothing has been changed, no? The whole point is that if only scale up is enabled, the only time things are scaling is if it is below us, and then there would be no difficulty indicator present. If the content is higher level than us, there is no scaling taking place and the predetermined levels are all in force. At which point, why can't the system still utilize these predetermined levels, as literally nothing has changed.

Share this post


Link to post
Share on other sites
  • 0

I had the same thing happen, critical path only upscaling  enabled but no difficulty ratings so I was sometimes running into stuff way too high level for me.  Not sure if this is what fixed it for me but they're showing now.

 

I went into the difficulty options unchecked the show difficulty rating option saved and exited the options. Then I went in turned it back  on. They still didn't show up. However the next time I booted the game and started playing I noticed immediately that those skull indicators were there.

Share this post


Link to post
Share on other sites
  • 0

Great resource Aravane, thank you.

... frustrating to need so many external reference sheets to have a smooth playing experience, though.

Share this post


Link to post
Share on other sites
  • 0

Heya everyone,

 

This is actually working as designed. Using the Level Scale feature disables the difficulty skulls. I asked our design team about it, and it's because the skull system relies on quests and monsters having a "difficulty" level set manually for the skulls to pull from. With the level scaling feature enabled these manual entries don't adjust, making the skulls inaccurate.

 

Hope that clears things up.

 

It make sens when you scale both up & down, but when choosing to scale only up, having the skulls would give people an indication on the overall difficulty of the quest. The problem is you don't have anyindication on high difficult zone.

Share this post


Link to post
Share on other sites
  • 0

Is there any way to disable level scaling via console commands (I remember doing it in the original PoE)?

Share this post


Link to post
Share on other sites
  • 0

I would also like to know if there's a way to do this. I'd rather not have to restart my playthrough considering I'm 16 hours in but I really wanted the feature. 

Share this post


Link to post
Share on other sites
  • 0

Hi guys, new issue appeared in my game and I'm unsure how to avoid it currently.

I'm playing on Path of the Damned difficulty and I've reached Neketaka.

After explorer the first map and getting the quest to save Oswald, I figured I'd like to sail out and fight.

 

Leaving Neketaka gives me the following however:

post-25438-0-31714800-1526159445_thumb.gif

 

To speed things along, here's a savegame:

potd_issue.zip

Load it up, check stats, leave Neketaka by sea, check stats again.

(feel free to remove it to save forum space)

 

-edit

Now that I've loaded an earlier save, it seems to be at sea in general.

Unsure if it's intended behavior.

 

2 other minor things I've noticed (but not really breaking) are:

 

1. Creating a new character shows incorrect sheet information while talking to Berath (sheet could state 60~ health, you'd get around 50).

The 50 seems correct though and perhaps the 60 is for the next level?

 

2. Sometimes after leveling, your character will already obtain the HP of the next level without actually leveling up.

So in the previous example, I'd have the folloiwing health: 60/50 instead of 50/50 and getting 60/60 after leveling up.

 

Still loving the game, great work!

Edited by Maf

Share this post


Link to post
Share on other sites
  • 0

Really looking for updates on this issue, it is extremely frustrating right now. I really don’t want to restart my game because of a bad design decision. The indicator should work when the “only scale up” option is enabled.

Share this post


Link to post
Share on other sites
  • 0

Disabling difficulty indicators just encourages save scumming. The game provides the information either way (via indicators or loading an encounter and witnessing the enemies' power level for yourself), but I prefer the convenience of indicators.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...