Jump to content
  • 0
hamskii

[Framerate] General Framerate Problems.

Question

Recommended Posts

  • 0

Hello all!

 

Sorry to hear the game has frame drop issues for you, thank you to all for your suggestions on improvements. If you are still experiencing problems, if you would be so kind as to attach a .log file or your saves, your computer specifications, anything that would aid us in finding the source of the issue.

 

Thanks,

 

-Caleb


I like big bugs and I cannot lie...

Share this post


Link to post
Share on other sites
  • 0

Hello all!

 

Sorry to hear the game has frame drop issues for you, thank you to all for your suggestions on improvements. If you are still experiencing problems, if you would be so kind as to attach a .log file or your saves, your computer specifications, anything that would aid us in finding the source of the issue.

 

Thanks,

 

-Caleb

 

Specs:

Windows 10 - Version 1709 - Build 16299.402

i5 4690k @ 4.4ghz

16gb 2400 ram

Radeon 390 - drivers 18.4.1

 

I tried playing around with various settings in-game : graphic settings, telemetry, camera settings. Nothing seemed to make a difference.

The stutter depends on the area as far as I can tell. On the beach at the beginning the stutter was far more likely to occur while standing on the ship and including as much water as I could in the camera. Standing away from the ship seeing almost exclusively sand made the stutter less likely to occur. Framerate was very high in both cases (over 100). Verifying steam files made no difference, reinstalling the redists that came with the game made no difference.

 

I can't upload a save ("you aren't permitted") but any character at the very beginning of the game, at Vilario's Rest, simply standing on the broken ship will work.

Share this post


Link to post
Share on other sites
  • 0

I'm on the lower end of the tech spectrum, but I get the same issues: 30fps runs well with other graphics settings maxed, but after an hour or two, the fps drops considerably and panning the camera results in frequent micro stutters that look like tearing. Changing stuff like lighting or shadows makes very little difference.

Windows 7 Ultimate
i5-3300 @ 3.00 ghz

8 GB RAM
AM Radeon HD 7800

Share this post


Link to post
Share on other sites
  • 0

The game freezes up for 0.5-3 seconds every minute or so.

 

Started the game on max settings and ended up on the lowest but with no change. I've tried eliminating all possibilities, window mode, AA, vsync (a must for me otherwise the screen-tearing is massive) but non make any difference.

 

I'm running a GTX 1070 unclocked with 16GB ram and a 6700(non k) processor. I haven't had any issues like this with any other of my games.

 

Any help or advice would be appreciated because the game is unplayable at the moment, other than that I've had a few mouse input issues but can't tell if it's due to the stutter or what others have mentioned on other posts.

 

Thanks.

output_log.txt

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Yea exactly the same issue here. No matter what graphics options I tweak it's still the same. 
I had the same issue in PoE1 and it was a bit more severe there, but still really annoying to still have this stutter crap in Deadfire...

 

And just like you, all my other games work fine. 

Share this post


Link to post
Share on other sites
  • 0

Try turning off telemetry, and see if that helps. I noticed some minor hitching like you described, but then I turned off telemetry and it seemed to fix the problem.

 

Additionally, if you are using any kind of overlay (Steam, GeForce Experience, or Windows 10 Gamebar) try running the game with the overlay disabled and see if that helps.

Share this post


Link to post
Share on other sites
  • 0

Try turning off telemetry, and see if that helps. I noticed some minor hitching like you described, but then I turned off telemetry and it seemed to fix the problem.

 

Additionally, if you are using any kind of overlay (Steam, GeForce Experience, or Windows 10 Gamebar) try running the game with the overlay disabled and see if that helps.

 

Thank you. Turning off the Steam overlay and  telemetry in the options fixed the problem.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

For Nvidia users, they just released a driver update I believe yesterday. I've yet to install it, but perhaps this could help?

Edited by Jayngo

Share this post


Link to post
Share on other sites
  • 0

with the latest nvidia driver i'm still stuck at 40 ish fps with a decrease after 30 min on my GTX 1080 (only using 30% usage https://imgur.com/a/FZnVY1x - 100% is from the windows screenshot win+shift+s ) 

 

i've tried every option high/mid/low, all stuck at 40 fps

 

@update output_log, 

 

 

output_log.txt

Edited by Deshke

Share this post


Link to post
Share on other sites
  • 0

So I have this issue with framerate. It's so frequent that it turns this awesome game into unenjoyable experience. Any crowded area, like some part of Port Maje, Neketaka, Fort Deadlight make my fps drop to 10-15 or even below 10. It even worse during nights, when the torches and other lights source pop up. It occures both in outdoors and indoors, like Berath's Temple in Neketaka, The Kraken's Eye inn. It's strange because I have smooth 60 fps in dungeons, starting beach, caves, digsite near Port Maje. Even dungeon with Oswald runs smooth until the encounter with Woedica's cultist. It's hard to issue command with 5 fps slideshow.

 

It so strange that I have 60 fps near the water "sculpture" beautifuly animated at the roof of the palance i Neketaka, while few steps further closer to the throne, the queen and her tigers it drops instantly to 10.

 

I tried different graphical options, different GPU drivers, I turned off steam overlay, nvidia ansel. I tried OC GPU with MSI afterburner but it didn't affect the performance.

 

My spec:

I5 7600k OC to 4,5 GHz, GTX 1060 6GB, 16GB of RAM Win 10. I play on 1080p res.

 

Steam forum has few similar topics, there are people with gtx 1060, 1070, 1080 even 1080TI with framedrops below 15.I know that Deadfire may not be demanding in terms of GPU, but CPU isn't old to make such terrible performance. Turning game off and start up again makes little improvement to performance but for very short time.

 

I still have similar issue in Tyranny in areas like Scarler Chorus Camp in Act 1 or Disfavoured Camp in Act 2.

Edited by Silvaren

giphy.gif

Share this post


Link to post
Share on other sites
  • 0

I've heard of various users having issue with the Nvidia drivers, including the newly released ones. Some of them said they got better results after using the developer drivers: https://forums.guru3d.com/threads/nvidia-397-54-vulkan-developer-beta-driver.420843/

 

With that said, it's a separate issue from the stutter. That nvidia issue is more about permanent low FPS rather than stuttering.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'm getting absolutely terrible FPS on my PC and I'm not sure what the problem is. This problem doesn't seem to mess with any other games i play. I'm talking 15 FPS on LOW settings on ship deck battles, 30~ FPS in town on low and 25-30 FPS inside small indoor areas. To compare it with DOS2, I get around 125 on Ultra on DOS2.

 

Current set up is:

Geforce GTX 1080 TI AORUS Xtreme,

16 GB G.Skill DDR4 Ram at 3.198 MHZ,

Intel Core i7 6700K Processor

MSI Z170A GAMING PRO CARBON motherboard

Installed on a 512 GB INTEL SSD

 

I'm running it at 2560*1440 on a ASUS PG278Q 27 inch Monitor.

 

I've talked with the guys on the Nvidia Discord and compared my benchmark settings for my setup with people with similar cards and it's getting the expected results so I'm convinced it's not a hardware issue. Something must be conflicting with the game.

 

I've currently tried the below:

- Used DDU to do a full uninstall and reinstall of the latest nvidia drivers.

- Checked for Malware, Viruses and any applications that might be crypto mining on my PC

- Confirmed all Geforce experience, the Microsoft DVR thing is turned off.

- Tried taking the cord out of my 2nd monitor (144 hz BENQ monitor) and running with single monitor, then swapping to only the 2nd monitor at 60 HZ on 1920*1080 and still no change.
- Switching between Full screen and windowed mode.

- Alt tabbing and opening back up the game.

- Turning Gsync on/off, alternating between Vsync on and off also.

 

One thing I'm noticing is the GPU is showing 100% load, however the temp of the GPU does not rise. It's almost as if it's not actually doing anything but showing up as active. It's essentially a soccer player in a game but sitting on the bench.

post-146074-0-88817200-1525993101_thumb.jpg

post-146074-0-52573100-1525993108_thumb.jpg

post-146074-0-98154100-1525993116_thumb.jpg

Edited by Timboslice

Share this post


Link to post
Share on other sites
  • 0

There was a driver update from Nvidia that had increased support for PoE2. Did you try it yet?

Share this post


Link to post
Share on other sites
  • 0

There was a driver update from Nvidia that had increased support for PoE2. Did you try it yet?

Yes, I did full uninstall and installed latest drivers from about 9 hours ago.

Share this post


Link to post
Share on other sites
  • 0

I know the first game had an issue that was fixed by adding -force-d3d11 for the launch parameters, though i don't think that works with this version, hopefully a patch fixes this soon for you or something.

 

The specs you have are similar to those that have this issue but it seems lower end specs work out fine so its really weird, running a 980 i have no real issues at all :\

Share this post


Link to post
Share on other sites
  • 0

I've heard of various users having issue with the Nvidia drivers, including the newly released ones. Some of them said they got better results after using the developer drivers: https://forums.guru3d.com/threads/nvidia-397-54-vulkan-developer-beta-driver.420843/

 

With that said, it's a separate issue from the stutter. That nvidia issue is more about permanent low FPS rather than stuttering.

Thanks. It sure make a difference for me. Previously using either the 'old' 391.35 or the latest '397.64' I had this constant micro freezes.

With that dev. '397.54' they appear to be gone. It was mainly in inventory screen or during gameplay.

 

The latest should provide 'optimal experience' but they don't even added a profile for PoE II so much for the experience Nvidia :D

Share this post


Link to post
Share on other sites
  • 0

Hello Timboslice,

 

Thanks for messaging us, and thanks for sending your specs for your machine, Ill get this bugged up and looked into.

 

Best,

 

-Caleb


I like big bugs and I cannot lie...

Share this post


Link to post
Share on other sites
  • 0

I have the same problem with my setup. 12fps on ship fights, 20-30fps in town, etc. I found that disabling "miscellaneous" in the graphics options helps, but it's still far from ideal.

 

Intel i7-2600K @ 4.0GHz (OC) or 3.4GHz (stock)

16GB RAM

GeForce GTX 1070

Installed on 256GB SSD

 

I already reported this to tech support, but I wanted to add my voice here as well.

Edited by mwinding
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'm getting 50 - 60 FPS in ship battles with my i5 4690K and GTX 1070 at 1440P resolution on high settings. Got the same FPS both before and after the Nvidia driver update.

 

Try checking your GPU clock rate while playing the game. I remember having an FPS issue on POE1 with my laptop where I was only getting 10 - 15 FPS and even though the GPU was showing 100% usage, the clock rate wasn't running full speed. I opened the Nvidia Control Panel and changed the settings to "Prefer Maximum Performance" and my FPS shot up to 40 - 45 FPS.

Share this post


Link to post
Share on other sites
  • 0

I have about 30 fps most of the time without global illumination and 5-20 with all those dynamic lights. I just landed on Tikiwara and hit stable 20 fps.

 

My rig: i5-7600k 4,5 GHz (OC), GTX 1060 6GB, 16 GB RAM, Win 10. MB Asrock Z270 Extreme 4. Game is installed on SSD Goodram Iridium Pro.

 

Something is very wrong. I looked at HaasGaming channel on youtube and he is playing on gtx 980, i7-3770k 4,4 GHz, 10 GB RAM and the game runs smooth.


giphy.gif

Share this post


Link to post
Share on other sites
  • 0

I've heard of various users having issue with the Nvidia drivers, including the newly released ones. Some of them said they got better results after using the developer drivers: https://forums.guru3d.com/threads/nvidia-397-54-vulkan-developer-beta-driver.420843/

 

With that said, it's a separate issue from the stutter. That nvidia issue is more about permanent low FPS rather than stuttering.

This driver is even worse for me than the newest game ready dedicated for Deadfire. It's unplayable.

 

I'm running with benchmark and with 397.54 I have about 30 FPS without global illumination and 5-20 with dynamic lights on. I play on i5-7600k 4,5GHz, GTX 1060 6GB, 16 GB RAM, Win 10 64 bit. All temperatures are normal. CPU, GPU usage normal. No idea what the hell is going on. I had similar issue playing Tyranny, but only in crowded places or lots of FX/background fires.


giphy.gif

Share this post


Link to post
Share on other sites
  • 0

extreme stuttering laggy in fort deadlight. anyway to remove MSAA? i saw the lowest option is just 1x. Also please provide more visual customizations. This is not console port right? the amount of options are laughable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...