Jump to content
  • 0
hamskii

[Framerate] General Framerate Problems.

Question

Recommended Posts

  • 0

I have exactly the same issue on my GTX 1070 low fps most of the time and the GPU usage is low as well, but temp goes high. Playing on a laptop:

- Intel Core i7-6700HQ
- GeForce GTX 1070
- 16GB
- Drivers are up to date
 
 
Also take a look ah the screenshots and GPU usage along with FPS
 
a7DsjV8.jpg
 
taILoLb.jpg
 
iNb4wnz.jpg
 
bwWe8zJ.jpg
Edited by Sidushi
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I have the same problem on a GTX1080. For example Map, Old City Overlook: I have between 25 and 50 FPS after the game ran for some time. Then i restarted the game and suddelny I have 120 fps. There seems some serios problem that needs fixing.

Share this post


Link to post
Share on other sites
  • 0

I am getting frame rate drops as well, but oddly enough, entirely within combat... the framerate will stutter or hang during combat often enough to be annoying. I have a GeForce 960M. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I am getting frame rate drops as well, but oddly enough, entirely within combat... the framerate will stutter or hang during combat often enough to be annoying. I have a GeForce 960M. 

same here, everything crashes

Share this post


Link to post
Share on other sites
  • 0

The game somehow locks the framerate to 20-30 fps ( never above 30 ) after the most recent update randomly.

If I open and close the inventory a couple times it jumps back up to 100+ and stays there for a few moments, then I'll be browsing my inventory again at some point and the framerate locks back to sub 30.

 

Is there any way I can roll back this horrible patch and play with the last one because it actually worked?

 

Literally unplayable like this.

Share this post


Link to post
Share on other sites
  • 0

Went from having 100+ fps constantly to now being stuck at 24-30 with the newest patch..

No matter how much I tinker with the settings the framerate stays ay 24-30 but never drops below 24 so that seems to be capped somehow.

 

Is there any way to roll back to the last patch?

Share this post


Link to post
Share on other sites
  • 0

Happened to me the game for me wasn't doing great in fps because isn't the best but in close areas and fights was over 50 fps now all battles are Bellow 20 fps even crash happened and even in close areas with few enemy's the game slow really bad. I was hopping the patch makes the game run better but now is unplayable.

Share this post


Link to post
Share on other sites
  • 0

Same, I had ok performance before the latest patch and now it's REALLY bad, especially outdoors. There are long lags of hundreds of milliseconds between frames and it seems to average about 10-15fps in Neketaka. I would like to uninstall the latest patch as it's made the game unplayable :(

 

Intel 7700K

NVidia 1080ti

32GB RAM

Share this post


Link to post
Share on other sites
  • 0

The workaround for the performance issue is to set "-window-mode exclusive" in your launch settings in Steam. It appears that full screen mode is actually running as windowed mode! :/ That restores full framerate for me.

Share this post


Link to post
Share on other sites
  • 0

solution -

 

The solution for this issue is simple. All you have to do is start the game and then open “Task Manager” and click on “More Details”. Now select the “Details” tab and find the game’s exe. Right-click on the exe and change the priority any option above “Normal”. This will resolve the frame rate drop issue and the constant stutter in the game.

Share this post


Link to post
Share on other sites
  • 0

Same here. The game is stuttering and currently unplayable. The Intro (Character Import and Battle on the Ship) is running at very low FPS.

 

I tried:

"-window-mode exclusive" in Steam

Update GPU Drivers

Reducing all Graphic Options to Low

Testing Fullscreen and Windowed Mode

Changing Priority of the PoEII exe in the task manager to high

 

But no improvement.

 

My System: Win 10, GTX 970, i5 2500k, 8GB Ram, SSD

 

Any ideas how to fix this? Do i have to wait for the next patch? Is Obsidian working on this?

 

I bought the game on the first day, but until now i wasn´t been able to play a single minute.

Share this post


Link to post
Share on other sites
  • 0

solution -

 

The solution for this issue is simple. All you have to do is start the game and then open “Task Manager” and click on “More Details”. Now select the “Details” tab and find the game’s exe. Right-click on the exe and change the priority any option above “Normal”. This will resolve the frame rate drop issue and the constant stutter in the game.

This didn't do anything for me unfortunately.

 

The same thing goes for the windowed performance issue. I think that's a separate problem some are having.

Edited by mwinding

Share this post


Link to post
Share on other sites
  • 0

Ok i solved it for my. Although its a little bit awkward, i would like to share my "solution". Maybe there is someone else who did the same mistake.

 

The solution is quite simple, it had nothing to do with PoE2 oder the unity engine. It was just my GPU, which was in the wrong PCI-E slot. After switching the GPU in the other slot, now everything runs smoothly.

 

If you want to test this, simply download GPU-Z and check in the "Bus Interface" field, if your GPU runs right.  If you point your mouse some time over the field you get some aditional information.

 

Wrong would be "PCIe x 16 x 2.0 @ x 1 1.1"

Right could be "PCIe x 16 x 2.0 @ x16 2.0"

 

Good luck!

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Ok i solved it for my. Although its a little bit awkward, i would like to share my "solution". Maybe there is someone else who did the same mistake.

 

The solution is quite simple, it had nothing to do with PoE2 oder the unity engine. It was just my GPU, which was in the wrong PCI-E slot. After switching the GPU in the other slot, now everything runs smoothly.

 

If you want to test this, simply download GPU-Z and check in the "Bus Interface" field, if your GPU runs right.  If you point your mouse some time over the field you get some aditional information.

 

Wrong would be "PCIe x 16 x 2.0 @ x 1 1.1"

Right could be "PCIe x 16 x 2.0 @ x16 2.0"

 

Good luck!

 

Oops, it looks like I did this too.

 

My motherboard has three slots: PCIe x4, x8, and x16. I had my GTX 1070 in the x4 slot and was getting 20-30 fps. I moved it to the PCIe x8 slot and now I get 40-60 fps with the "miscellaneous" setting on and 60fps with "miscellaneous" off.

 

Do you max out your fps with "miscellaneous" on in the PCIe x16 slot? I ask because my GPU is blocked from using the x16 slot because it's so big and hits my CPU heatsink. I might have to tinker a bit or get a new heatsink...

 

 

Side note:

It's very funny that the GPU in the wrong slot only affected Pillars I, Tyranny, Torment, and Pillars II. I've played many very graphically intensively games and other unity games over the last 2 years in this configuration with zero problems.

Share this post


Link to post
Share on other sites
  • 0

With "miscellaneous" on and the GPU in the PCIe x16 slot i get constant 60 fps. I had to take out my soundcard, to switch the GPU in the other slot.

 

Side note:

Same here. I played Witcher 3 with maxed graphics - No problems!

Share this post


Link to post
Share on other sites
  • 0

Thanks to Washfire I solved my problem with framerate! It seams that I put my GPU into PCIe x1 slot year ago and I didn't notice any huge performance issue in other games so far, but now I switched GPU to x16 slot and Deadfire runs smooth :D

 

Edit:

And it solved the same issue in Tyranny. Awesome.

Edited by Silvaren

giphy.gif

Share this post


Link to post
Share on other sites
  • 0

With "miscellaneous" on and the GPU in the PCIe x16 slot i get constant 60 fps. I had to take out my soundcard, to switch the GPU in the other slot.

 

Side note:

Same here. I played Witcher 3 with maxed graphics - No problems!

 

Thanks for this. I just spent 3 hours rearranging everything (I had to reposition my CPU heatsink, remove the heatsinks from my RAM, and remove my WiFi card to fit my GPU in the 16x slot), but it worked! I now have constant 60fps even with "miscellaneous" on. Definitely worth it.

 

You're a life-saver, Washfire! 

 

 

TLDR: It's always the user's fault.

 

Haha very true in this case. 

Share this post


Link to post
Share on other sites
  • 0

Interesting. I have a similar setup (R9 270X, i5 3470, 8GB DDR3) and I'm also getting extremely bad fps. Only 1-5 fps everywhere, even on LOW. It didn't seem like I could disable AA in the game completely, though? Minimum setting is 1.

Meanwhile I can play the game on my laptop with a geforce GTX 960M with only minor slowdowns in busy areas...

 

 

The patch seems to have solved my issue. FPS problems gone!! Hope something will work for the rest of you.

Share this post


Link to post
Share on other sites
  • 0

Ok i solved it for my. Although its a little bit awkward, i would like to share my "solution". Maybe there is someone else who did the same mistake.

 

The solution is quite simple, it had nothing to do with PoE2 oder the unity engine. It was just my GPU, which was in the wrong PCI-E slot. After switching the GPU in the other slot, now everything runs smoothly.

 

If you want to test this, simply download GPU-Z and check in the "Bus Interface" field, if your GPU runs right.  If you point your mouse some time over the field you get some aditional information.

 

Wrong would be "PCIe x 16 x 2.0 @ x 1 1.1"

Right could be "PCIe x 16 x 2.0 @ x16 2.0"

 

Good luck!

 

This turned out to be my issue. Although my GPU was in the right slot, it was running at "PCIe x 16 x 2.0 @ x 1 3.0". Swapping graphics cards yielded the same result which made me think that the motherboard was bad. I swapped the motherboard today and now PoE2 is running silky smooth.

 

Strange that PoE2 is the first game to chug because of this!

Share this post


Link to post
Share on other sites
  • 0

Hi everyone,

 

i am a little disapointed about the performance of the game. But im not sure if its a problem of the game engine or my computer. I have read that a lot of peaple complain about there fps which have similar hardware components like me. But also some people with an older rig say that they got stable 60 fps.

 

Most indoor areas and dungeons are stable 60 fps for me too but in higher crowded areas like the first town, fort deadlight or Neketaka i get something around 40 to 50 fps. I got random fps drops during exploring to something like 30 fps for 1 second, them the fps go up again. This happens very 10 seconds. Fps during combat go down to 40 to 50.

 

 

Here are my system speccs:

 

-Windows 10 64 bit
-11GB ZOTAC GeForce GTX 1080 Ti AMP Aktiv PCIe 3.0 x16 (Retail)
-AMD Ryzen 1700X (eight cores)
-16GB G.Skill Aegis DDR4-3000 DIMM CL16 Dual Kit
 

 

Is my CPU bottlenecking the game? I heard that unity engine games are really CPU dependand. But i really think i got a good system that should handle the game with 60 fps. Can someone help me?

 

thanks

Share this post


Link to post
Share on other sites
  • 0

The workaround for the performance issue is to set "-window-mode exclusive" in your launch settings in Steam. It appears that full screen mode is actually running as windowed mode! :/ That restores full framerate for me.

This worked for me (Nvidia GTX1080). Thank you!

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

So I am hoping you guys can help a dummy out. I am trying to see if my card is in the right PCI slot. As I am looking at Washfire's solutions to help my micro stutter, GPU-Z is telling me:


The Graphics Card Reports that it Supports:


PCI-Express x16 v3.0


It is currently runing at:


PCI-Express x16 1.1  

 

I am assuming that is wrong.  The Bus Field reads 

PCI-Express x16 3.0 @16x1.1  
 

 

Update: The above result is when I am not running a game...When I run a game it changes to PCI-Express x16 3.0 @3.0 So I think my card is in the right slot.

Edited by Torm51

Have gun will travel.

Share this post


Link to post
Share on other sites
  • 0

I was having FPS drops (from ~100-120 to 20-30) every few minutes, using a 1080 Ti. I changed the nvidia program settings to have GPU always at max (meaning fans will be louder), which resolved the issue. Updating the drivers and changing the in-game settings did not resolve the issue previously. Hope this helps for some people.

Share this post


Link to post
Share on other sites
  • 0

Nothing helped for me so far...

 

I tried:

 

- updating drivers

- change setting ingame

- change settings in nvidia control panal

- turn off steam overlay and telemetry

- force window mode and dx11 on steam gamelaunch

- raise priority of the pillars.exe in the task manager

- checked correct slot of my graphic card

 

Most indoor areas and dungeons are stable 60 fps for me  but in higher crowded areas like port maje, fort deadlight or Neketaka i get something around 40 to 50 fps. I got random fps drops during exploring to something like 30 fps for 1 second, them the fps go up again. This happens very 10 seconds. Fps during combat go down to 40 to 50.

 

speccs are:

 

Windows 10 64 bit
11GB ZOTAC GeForce GTX 1080 Ti AMP Aktiv PCIe 3.0 x16 (Retail)
AMD Ryzen 1700X (eight cores)
16GB G.Skill Aegis DDR4-3000 DIMM CL16 Dual Kit

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...