Jump to content
  • 0
hippofant

[Bug]Blade of the Endless Paths fragments not spawning

Question

I'm not entirely sure this is a bug, so I'm wondering if other people had the same experience.

 

I created a manual history, in which I did forge the Blade of the Endless Paths (I'm pretty certain). Then in the prologue, I let the deckhand drown and instead saved the crate. Fast-forward 10 hours, I visit my cabin, and the fragments for the blade aren't there! But I know about the Blade, because I watched Cohh's stream, in which he saved the deckhand and got the fragments.

 

Has anybody else experienced this too? Is the deckhand event flag flipped and that's why I didn't get the fragments? Or did I bork my history when I created it?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Save Builder does not give players Blade of Endless paths even if they chose that they did crafted it.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

It looks like the flags are swapped.  I just tested this; I created a new custom history and chose that I had NOT reforged the Blade of the Endless Paths.  Once I fixed The Defiant and went into my cabin, the pieces of both Endless Paths and Whispers of Yenwood were waiting for me.

Share this post


Link to post
Share on other sites
  • 0

It looks like the flags are swapped.  I just tested this; I created a new custom history and chose that I had NOT reforged the Blade of the Endless Paths.  Once I fixed The Defiant and went into my cabin, the pieces of both Endless Paths and Whispers of Yenwood were waiting for me.

Can confirm that. But it's logical. When you have reforged the blade in PoE 1, how should you be able to reforge it again in Deadfire? You just need the parts.

Share this post


Link to post
Share on other sites
  • 0

^ it makes sense if Eothas stomped on it and shattered it to pieces, like he apparently did with Whispers of Yenwood (which was always whole in the first place.)


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

I just started a new character with Patch 3.01, and discovered that the fragments of the BotEP do not appear in my cabin after the first conversation with the gods. I'm using the same save import as I always do, which means the fragments should be there. I know they appeared as normal after patch 3.0. I have a few mods installed, but only ones that give subclasses to Eder, Pallegina and Aloth and one that reduces XP gain. Played with those the last time as well (under 3.0) and the fragments appeared.

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

That's strange that the fragments would disappear.  I went ahead and created a bug report for this so the QA and Area Design teams can investigate this and get a fix in.  Keep an eye on the patch notes to see when any fixes are implemented.

 

Thanks and sorry for the inconvenience this has caused.

Share this post


Link to post
Share on other sites
  • 0

This seems to be a recurring problem, because I had this same issue back when Deadfire first came out, and now I'm having it again.

Since I don't play on Trials, I just add a mod to add the fragments directly to my inventory, but obviously that shouldn't be necessary.

Share this post


Link to post
Share on other sites
  • 0

And here it is again. I always use the same hand-made history. Had the fragments ever before. Just started a new game, and don't have them.


Hey, you wanna hear a good joke?

Nobody speak, nobody get choked

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

We haven't been able to reproduce this in house so we were wondering if a couple of you would be able to provide a save file where this is occurring.  If you have a save file from before obtaining you ship and one after, that would be even better, but understandable if you do not.  If needed you can find instructions on where to obtain the save files here.  If the forums say the file is too big, you can send them to me at support@obsidian.net with your forum name and a link to this thread as a reference.

 

Thanks for the help! :)

Share this post


Link to post
Share on other sites
  • 0

I've emailed Schin two save game files (both post recovering ship), both with manual histories, one where blade had been recreated, and one where it had not (neither had blade fragments in cabin).

 

Hope it helps.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Can confirm.  Started a new game yesterday using the same PoE1 file I had used in a previous Deadfire playthrough months ago.  In the first playthrough I had both fragments from my PoE1 save but did not receive the Blade of Endless Paths fragments in this playthrough.  Is there a retroactive fix possible, or do I have to console command my sword in?  My barbarian really wants to sweep the leg.

Share this post


Link to post
Share on other sites
  • 0

It probably has to do with the PoE1 Path. When I choose the benevolent path I have one weapon (shards) in the cabin drawer. When I play Fair & Balanced I have both.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

It probably has to do with the PoE1 Path. When I choose the benevolent path I have one weapon (shards) in the cabin drawer. When I play Fair & Balanced I have both.

Is that on 3.01?

Share this post


Link to post
Share on other sites
  • 0
Guest Psychovampiric Shield

This seems to be a recurring problem, because I had this same issue back when Deadfire first came out, and now I'm having it again.

 

Since I don't play on Trials, I just add a mod to add the fragments directly to my inventory, but obviously that shouldn't be necessary.

 

I also think that issue was present around launch, because initially I only got fragments of Whispers of Yenwood and thought okay, perhaps Blade will be somewhere further in the game, then after some patches restarted and was suprised I got both fragment sets. Needless to say I use the same history every time.

 

Anyway, as of 3.0.2, I only get fragments of Yenwood sword. Save. Quite annoying, I would like to have that estoc. Especially because I do not recall seeing that many estocs in my previous playthrough.

 

EDIT: in 2.1.0, with the same history, both fragment sets are on Defiant.

Edited by Psychovampiric Shield

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

 

We haven't been able to reproduce this in house so we were wondering if a couple of you would be able to provide a save file where this is occurring.  If you have a save file from before obtaining you ship and one after, that would be even better, but understandable if you do not.  If needed you can find instructions on where to obtain the save files here.  If the forums say the file is too big, you can send them to me at support@obsidian.net with your forum name and a link to this thread as a reference.

 

Thanks for the help! :)

 

Schin - any possibility you'd be able to update the thread when the devs have had a chance to poke at this? Would be nice to know if they're able to duplicate or not after they've had some time with the save files. Thank you!

Share this post


Link to post
Share on other sites
  • 0

Any update on this? I was unaware of this issue when I started a playthrough built around this weapon. I have yenwood frags, but not blade frags. If a fix cannot be found, can you just add the blade frags into the game for all users?

Share this post


Link to post
Share on other sites
  • 0

I have had this problem as well on two different playthroughs since the patch.  Not only were fragments of the blade of the endless paths missing, the devil of caroc breastplate was also not available for purchase from Marihi.  The first one used the Fair and Balanced backstory, and the other one used the Keeper of Secrets backstory.   

Share this post


Link to post
Share on other sites
  • 0

I have the same issue after patch 3.0 with the sword missing. I am usibng the same import fike from poe1 and the sword is missing in 4 different playthroughs so far. I am going to send the save files bwefore and after the ship I kept them. I hope the devs can update us on this issue soon.

Edited by brotherpaul1911

Share this post


Link to post
Share on other sites
  • 0

Yea it is 100% a bug. I started to play 2 weeks ago with imported savegame and i have all the pieces spawned in my chest. Then with the latest patch i did all the same - started a new game with the import of my poe 1 save and there was only 1 sword spawned. Please fix this i want to play :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...