Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Update #101: Update 2.02 is Live

update bugs fixes

  • Please log in to reply
94 replies to this topic

#21
srlapo

srlapo

    (3) Conjurer

  • Members
  • 143 posts

Installing only WM 2.01 gog patch broke it for me. From what I understood you do need both patches.

 

What I did though is update it using Galaxy after I broke it.

 

This time I'll probably just let Galaxy sort out the patches for me.

 

You should, for some reason Galaxy will ignore any manual patching done to the game. It just patches over it again, so once you go Galaxy with a game you need to stay with Galaxy or reinstall.



#22
rheingold

rheingold

    (8) Warlock

  • Members
  • 1085 posts
  • Location:Cape Town
  • Pillars of Eternity Silver Backer
  • Deadfire Backer
  • Fig Backer
  • Black Isle Bastard!

Any idea how long it takes for gog to upload the patches? Still waiting for them :)



#23
srlapo

srlapo

    (3) Conjurer

  • Members
  • 143 posts

GOG 2.02 became available 5 minutes ago.

Also, now POE gets the option of turning on "Beta Channels" in Galaxy. It is currently off and grayed out but maybe? for the next beta patches?


Edited by srlapo, 30 September 2015 - 04:38 AM.


#24
rheingold

rheingold

    (8) Warlock

  • Members
  • 1085 posts
  • Location:Cape Town
  • Pillars of Eternity Silver Backer
  • Deadfire Backer
  • Fig Backer
  • Black Isle Bastard!

Awesome thanks - hopefully it's not that complicated and we can download only that file as opposed the previous patch where there where 2 versions.



#25
Skie Nightfall

Skie Nightfall

    (4) Theurgist

  • Members
  • 324 posts
  • Location:Israel
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

 

Installing only WM 2.01 gog patch broke it for me. From what I understood you do need both patches.

 

What I did though is update it using Galaxy after I broke it.

 

This time I'll probably just let Galaxy sort out the patches for me.

 

You should, for some reason Galaxy will ignore any manual patching done to the game. It just patches over it again, so once you go Galaxy with a game you need to stay with Galaxy or reinstall.

 

 

Yea, nothing like downloading 5GB again via Galaxy.

Manual installations register, so that's a difference.



#26
srlapo

srlapo

    (3) Conjurer

  • Members
  • 143 posts

Yea, nothing like downloading 5GB again via Galaxy.

 

Yeah, their patch sizes need some work.



#27
Kefky

Kefky

    (2) Evoker

  • Members
  • 81 posts
  • Deadfire Backer
  • Fig Backer

Is Gog having server issues? I've been getting terrible download speeds all day.



#28
Skie Nightfall

Skie Nightfall

    (4) Theurgist

  • Members
  • 324 posts
  • Location:Israel
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Is Gog having server issues? I've been getting terrible download speeds all day.

 

The download itself was pretty quick here.



#29
BAdler

BAdler

    Game Director

  • Developers+
  • -9926 posts
  • Location:Irvine, CA
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Lords of the Eastern Reach Backer

GOG player here.

 

If there are two separate patches for WM and no-WM games will it be necessary to install both in order to patch the game properly?

 

That was the case with 2.01

Yup. From here on out, if you have WM content, you will need to install both patches to get completely patched up.


  • AndreaColombo, Messier-31 and Lukmar like this

#30
wanderon

wanderon

    Nomadic Wayfarer of the Obsidian Order

  • Members
  • 1274 posts
  • Location:Upstate NY
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

 

GOG player here.

 

If there are two separate patches for WM and no-WM games will it be necessary to install both in order to patch the game properly?

 

That was the case with 2.01

Yup. From here on out, if you have WM content, you will need to install both patches to get completely patched up.

 

Will it matter what order you install them? I assumed I would only need the WM version and have already installed it....:(



#31
BAdler

BAdler

    Game Director

  • Developers+
  • -9926 posts
  • Location:Irvine, CA
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Lords of the Eastern Reach Backer

Hey, everyone. Looks like there was a little bit of miscommunication on our part which caused confusion in the update notes.

 

The note that mentioned "Draining Item Mod should only drain 15% attack speed now" was incorrect, but it requires a longer explanation.

 

In The White March a new Item Mod was created that was intended to drain a small amount of attack speed from an opponent and grant it to the weapon's user. Erroneously, this mod was initially named "Draining." Because we already had an Item Mod named Draining in the base game it was causing the old Item Mod to get removed from older weapons when it shouldn't have. To fix this issue the new Item Mod was renamed to Ambushing. This meant that weapons that use the attack speed draining effect used the Item Mod named Ambushing and the older weapons that used the Endurance draining effect used the Item Mod named Draining.

 

The update notes incorrectly referenced the older name (Draining) when mentioning that a bug with the Item Mod had been fixed. This is the cause of the confusion.

 

Unfortunately, Ambushing doesn't properly describe the Item Mod effect, so it is being changed to the name "Time Siphon."

 

In conclusion, Draining is remaining the same (Endurance draining) and Ambushing is now named Time Siphon (and has had its attack speed siphoning reduced to 15%). The name change for Time Siphon will take place in the 2.03 update.

 

I apologize for the confusion that this caused.


  • AndreaColombo likes this

#32
AndreaColombo

AndreaColombo

    Arch-Mage

  • Members
  • 5384 posts
  • Location:Budapest (HUN)
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Would someone be so kind as to send me their "draining.unity3d" file from a 2.02 Windows install?

 

It looks like I don't have that file, which means I'm still experiencing the bug whereby loading a game removes that ability from my weapons. I don't really feel like reinstalling the whole thing just for that.


Edited by AndreaColombo, 30 September 2015 - 10:39 AM.


#33
wanderon

wanderon

    Nomadic Wayfarer of the Obsidian Order

  • Members
  • 1274 posts
  • Location:Upstate NY
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Would someone be so kind as to send me their "draining.unity3d" file from a 2.02 Windows install?

 

It looks like I don't have that file, which means I'm still experiencing the bug whereby loading a game removes that ability from my weapons. I don't really feel like reinstalling the whole thing just for that.

 

I got a message of an error when I patched re: that file....

 

Pillars of Eternity patch log
File not found (for patching): C:\GOG Games\Pillars of Eternity\PillarsOfEternity_Data\assetbundles\prefabs\objectbundle\draining.unity3d
 
Not sure what to do - re-download & reinstall the patch? Not even sure the game will let me do that as my game currently shows as 2.02.0749 PX1


#34
AndreaColombo

AndreaColombo

    Arch-Mage

  • Members
  • 5384 posts
  • Location:Budapest (HUN)
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Yeah, got the same error message.

 

Really need that file if we want the draining weapon enchantment to work :(



#35
wanderon

wanderon

    Nomadic Wayfarer of the Obsidian Order

  • Members
  • 1274 posts
  • Location:Upstate NY
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

Yeah, got the same error message.

 

Really need that file if we want the draining weapon enchantment to work :(

 

I wonder if we do? Could it be that it's the new file that was originally called draining that is showing as missing because it was renamed? I don't have a current save with any draining weapons to check...



#36
Messier-31

Messier-31

    Arch-Mage

  • Members
  • 2243 posts
  • Location:Łódź, Poland
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Will it matter what order you install them? I assumed I would only need the WM version and have already installed it.... :(

 

Doesn't matter.

 

Last time (2.01) I did the WM patch first, and the standard patch second. Did the trick.

 

Now (2.02) I did the opposite and everything seems to be in order.

The version is 2.02.0749 PX1 and Hiravias finally casts "storm" spells when I ask him to!


Edited by Messier-31, 30 September 2015 - 11:51 AM.


#37
AndreaColombo

AndreaColombo

    Arch-Mage

  • Members
  • 5384 posts
  • Location:Budapest (HUN)
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

I wonder if we do? Could it be that it's the new file that was originally called draining that is showing as missing because it was renamed? I don't have a current save with any draining weapons to check...

 

I've consolled in Tidefall and when I save/reload, it loses the Draining enchantment.



#38
Oralaina

Oralaina

    (4) Theurgist

  • Members
  • 303 posts
  • Location:"the planet that it's farthest from...."

Yeah, got the same error message.

 

Really need that file if we want the draining weapon enchantment to work :(

 

https://www.dropbox....ng.unity3d?dl=0


  • Ymarsakar and AndreaColombo like this

#39
BAdler

BAdler

    Game Director

  • Developers+
  • -9926 posts
  • Location:Irvine, CA
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Lords of the Eastern Reach Backer

 

 

GOG player here.

 

If there are two separate patches for WM and no-WM games will it be necessary to install both in order to patch the game properly?

 

That was the case with 2.01

Yup. From here on out, if you have WM content, you will need to install both patches to get completely patched up.

 

Will it matter what order you install them? I assumed I would only need the WM version and have already installed it.... :(

 

It shouldn't matter.



#40
BAdler

BAdler

    Game Director

  • Developers+
  • -9926 posts
  • Location:Irvine, CA
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Lords of the Eastern Reach Backer

 

I wonder if we do? Could it be that it's the new file that was originally called draining that is showing as missing because it was renamed? I don't have a current save with any draining weapons to check...

 

I've consolled in Tidefall and when I save/reload, it loses the Draining enchantment.

 

 

Is this only a problem on GOG? I am not missing the file when I check the latest Steam build and I just checked the build we submitted to GOG and it has the file in it.







Also tagged with one or more of these keywords: update, bugs, fixes

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users