Jump to content
BAdler

Update #101: Update 2.02 is Live

Recommended Posts

I will be perfectly happy to provide any files anyone needs, through dropbox.  Everything works fine for me; anything y'all need, just say so.

  • Like 2

Share this post


Link to post
Share on other sites

I already got the file you provided. Thanks a lot, Oralaina!

 

Also noticed loading time improvements! Great job, obsidian!

 

Glad to hear it.  Hope you have unlimited fun in future!

Share this post


Link to post
Share on other sites

So I got the GOG patches and got the missing file error, but also the save games of my last two characters aren't appearing in the game (they are still in the saved game folder though), both those characters were from after White March was released.  Could the missing file error prevent the saves from transferring?

Share this post


Link to post
Share on other sites

 

Did not find an objectbundle folder - dropped it in asset bundle folder but didn't work??

 

 

 

 

 

This is the path in my install:

 

 

C:\Pillars of Eternity\PillarsOfEternity_Data\assetbundles\prefabs\objectbundle

 

 

Got it! Fixed now Thanks!  :thumbsup:

  • Like 1

Nomadic Wayfarer of the Obsidian Order


 

Not all those that wander are lost...

Share this post


Link to post
Share on other sites

The download from gog the normal one without whitemarch getsa microsft visual runtime error when i start it same as the game when i patched it with 2.02

Share this post


Link to post
Share on other sites

I installed both patches from GOG and everything's fine. Only issue was the missing file I got from Oralaina.


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites

No type of issues with Draining on steam.


Have gun will travel.

Share this post


Link to post
Share on other sites

BAdler, it is a GOG manual patch issue, since it won't patch old files that don't match certain specifications. They don't overwrite the file. Galaxy just overwrites everything it seems.

 

Generally the manual patching is a GOG side issue, Obsidian can't do much about it.

 

I suggest contacting GOG about this issue or use GOG Galaxy to patch games like Pillars, that have continuous patching in progress vs old games that are already patch complete.

Edited by Ymarsakar

Share this post


Link to post
Share on other sites

I manually patch my GOG version of Pillars and I haven't seen any missing file errors - at least for now...

 

Am I doing something wrong? :)


It would be of small avail to talk of magic in the air...

Share this post


Link to post
Share on other sites

@BAdler

 

Is it likely that you will upgrade to unity5 someday or

improve the rendering system of the characters?

I think they are the reason that the performance is

tanking sometimes or am I wrong?

 

Patch 2.02 is great in every other aspect thank you for that !

Share this post


Link to post
Share on other sites

I manually patch my GOG version of Pillars and I haven't seen any missing file errors - at least for now...

 

Am I doing something wrong? :)

I guess you won’t have any problem as long as you don’t install mods on your game.

 

I wouldn’t be surprised if all the people having problem with "manual" patches have modded their game at some point prior to trying to install the patches.

Share this post


Link to post
Share on other sites

 

I manually patch my GOG version of Pillars and I haven't seen any missing file errors - at least for now...

 

Am I doing something wrong? :)

I guess you won’t have any problem as long as you don’t install mods on your game.

 

I wouldn’t be surprised if all the people having problem with "manual" patches have modded their game at some point prior to trying to install the patches.

 

Wrong. No mods or console use or anything and my patch installation had missing files problem.

Share this post


Link to post
Share on other sites

 

(…) 

I wouldn’t be surprised if all the people having problem with "manual" patches have modded their game at some point prior to trying to install the patches.

Wrong. No mods or console use or anything and my patch installation had missing files problem.

 

If you’re using the Linux version, please open a thread about this in the "Technical Support" subforum and I’ll try to help you find what got wrong.

If you’re on Windows or Mac OS I won’t be able to help, I know nothing about these.

Share this post


Link to post
Share on other sites

 

 

(…) 

I wouldn’t be surprised if all the people having problem with "manual" patches have modded their game at some point prior to trying to install the patches.

Wrong. No mods or console use or anything and my patch installation had missing files problem.

 

If you’re using the Linux version, please open a thread about this in the "Technical Support" subforum and I’ll try to help you find what got wrong.

If you’re on Windows or Mac OS I won’t be able to help, I know nothing about these.

 

 

Windows.

Share this post


Link to post
Share on other sites

 

 

I wouldn’t be surprised if all the people having problem with "manual" patches have modded their game at some point prior to trying to install the patches.

 

 

Nope, I've never modded it and the manual patch made my game unplayable for a while, even after I fixed the initial problem with the missing file.  I was also on Windows. Ending up uninstalling everything and reinstalling with Galaxy which seemed to fix everything.  Given how often the game is updating and the amount of problems that seem to be related to the manual patching, I'd recommend Galaxy at least for this game, even if I don't plan on using it for any of my other GOG games.

 

Something weird I noticed is that even with the manual patch the game seemed to be looking for Galaxy files even though at that point I had never installed Galaxy.

Edited by MunoValente

Share this post


Link to post
Share on other sites

 

I manually patch my GOG version of Pillars and I haven't seen any missing file errors - at least for now...

 

Am I doing something wrong? :)

I guess you won’t have any problem as long as you don’t install mods on your game.

 

I wouldn’t be surprised if all the people having problem with "manual" patches have modded their game at some point prior to trying to install the patches.

 

 

I didn't have any mods and I got the draining file error.


Nomadic Wayfarer of the Obsidian Order


 

Not all those that wander are lost...

Share this post


Link to post
Share on other sites

I can use White March patch 2 with no problem.

But the manual install of patch 2.02 for the main game causes all kinds of errors and then I can not boot the game and it crashes with a player error.

 

It appears based on the log it is looking to patch from version 2.4.0.9 (GoG) which was just version 2.0 not 2.01.

I was not able to play White March until I installed 2.4.1.10 (GoG) which is version 2.01

So I can not use now 2.5.0.11 (GoG) which is version 2.02 because it wants to patch from 2.4.0.9 (GoG)

 

The issue with Galaxy is that it basically installs about 6gb which is half the game and on restrictive bandwidth and slower net speed this can take a while.

And there is very little dialog in GoG forums officially about these manual install issues so I am not sure what to do except wait it out.

 

As it is I can not update to 2.02.  At least manually that is.

 

On a side note the installation manually is still extraordinarily slow.  I have to install from safe mode for it to install at a normal speed.

Edited by sapientNode

Share this post


Link to post
Share on other sites

It seemed to me that the main thing with GOG installs is you can't skip any - you have to install each patch (in order) or the next one will not work - they are labeled fairly well to see which one does what but I still find this very different than the IE games for instance where all you had to do was install the latest patch (which already included those that came before).

 

It's been stated (by a dev) in this thread that when it comes to the 2 current patches (if you have WM installed) it should not matter which order you install those.

 

I'm still wondering when the latest patch will be up for DVD users - going on Vacation Monday and that's what's installed on my laptop. :(


Nomadic Wayfarer of the Obsidian Order


 

Not all those that wander are lost...

Share this post


Link to post
Share on other sites

At least my problem it is most likely a mistake on gogs side since ive had a similar problem with the witcher 3 after i manually patched it

and like Poe it fixed itself when i used galaxy

So it is safe to say that gog users should probably use galaxy until gog sorts that stuff out

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...