Jump to content
  • Sign Up
  • 0
Ebolaids

Why does this game run poorly?

Question

This game runs at literally 23fps average.

 

Even GrindWars 2 runs at a steady 40fps on low settings on my laptop.

Even skyrim on medium runs at 30fps.

Even runescape WHICH IS MADE IN JAVA runs fine.

 

 

Intel core i5 3317u

Intel HD 4000

4gb DDR3

120GB SSD

 

 

What happened to real programmers? When games used to be optimized?

 

It almost feels like someone paid Obsidian to make the game run like crap to force people to buy new hardware. Im not even joking.

 

Cant EDIT: Title edited.

  • Like 1

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

It's because of the 3D characters I think (which smash the renderer), I also have some performance issues on my i7 870. Try turning off anti-aliasing in the console

 

`

 

msaa 0

Edited by Sensuki
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

You are running an intel HD 4000...it looks like a mid-range to low end laptop. You cannot expect a developer to program for old hardware.

Edited by zachalmighty
  • Like 4

Share this post


Link to post
Share on other sites
  • 0

You're running a ultra-low-voltage processor and while I cannot remember off the top of my head if Unity is CPU or GPU bound that could be a fairly major issue if it is the former of the two (and, honestly, your GPU isn't great either).


"A little inaccuracy sometimes saves a ton of explanation."
-H. H. Munro

 

"Geez. It's like we lost some sort of bet and ended up saddled with a bunch of terrible new posters on this forum."

-Hurlshot

 

 

Share this post


Link to post
Share on other sites
  • 0

Yes, i did follow those intructions on the sticky and it helped considerably.

 

Stil. That is no excuse for a game with this calibre of graphics and animations to run this bad.

 

Its not about developing for older hardware. Its about developing bad habbits. If you simply let things like this happen, they will continue on that path of making slower software.

Software will get slower than hardware gets faster. Thats the problem.

 

If you think this is about consumerism and making people buy new hardware. Making your game run like crap isnt the best way to do it. Trust me.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Are you a programmer?

 

Actually Yes, I have a decent grasp of D and C#. But of course im no game developer.

Share this post


Link to post
Share on other sites
  • 0

It's because of the 3D characters I think (which smash the renderer), I also have some performance issues on my i7 870. Try turning off anti-aliasing in the console

 

`

 

msaa 0

Had to register on the forum just to thank you. My pc barely meets the minimum requirements and with this the game runs smoothly. Now I can neglect my responsibilities at a proper framerate.

  • Like 7

Share this post


Link to post
Share on other sites
  • 0

My rig does meet minimum requirements (HD4870, Core2Dueo 3Ghz, 4GB RAM), but the low framerate when there are more than 2 chars around makes it nigh unplayable. Turning off anti aliasing barely helps. I am running the game in admin.

Now, before people start about 'Unity': Wasteland 2 and especially Shadowrun Returns run very smoothly, and those are both Unity games... So does anyone have any ideas?

 

Share this post


Link to post
Share on other sites
  • 0

I already said why, it's the 3D characters. I'm not sure if it's just because they're poorly optimized or whatever but they're made up of lots of different 3D pieces rather than just a single piece. Unity's renderer gets hammered trying to render them and uses up all the CPU time.

Share this post


Link to post
Share on other sites
  • 0

Sure. But how do I remedy it? I do not care much about having the fireworks and sparkles, I already run it at lowest resolution. but it needs to remain playable. Right now, it is way too choppy

I understand that minimum specs are minimum specs, but my machine does meet them; the only part that is absolute minimum is the RAM (can't help it, that in turn is bottlenecked by the mobo). When I go into the task manager, the game takes up about 20% processor capacity and a little over a gig of memory; there is still room to spare there (I only run bare minimum in the background).

Share this post


Link to post
Share on other sites
  • 0

Are there any other console commands for graphic settings? My framerate stutters when there are lights? Sorry not familiar with terminologies but the very start of the game, by the campfire, my framerate drops, but when I move on other areas away from the camp fire, it runs smooth. I know my PC from 2010 is old but meets minimum requirements. (Win 7 Home premium x64, i7 860, radeon 5850, 4 GB ram)

Share this post


Link to post
Share on other sites
  • 0

The performance issues are probably a bit idiosyncratic. I'm running PoE on a very modest i5-4590, Radeon 285, 8 GB RAM + Win7 x64 system, and I never drop below 60 fps. I know many people refuse to play anything below 120 fps, but the game feels smooth enough for me.

Share this post


Link to post
Share on other sites
  • 0

This game is optimized very well. I know every case can be different, but on my 6 yeal old, 32-bit system, with "4GB" RAM and Radeon 4870HD its running smoothly and perfectly so far. Might want to check some stuff on your system if its lagging.

 

Also OP like others said, it looks like your GPU is very much under powered and too old for this. There is a limit to how low a bar they can set and still retain some quality. Same as with newer games not working on older OS's

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Sure. But how do I remedy it? I do not care much about having the fireworks and sparkles, I already run it at lowest resolution. but it needs to remain playable. Right now, it is way too choppy

 

You can't. My game lags in some areas too and I have an Intel i7 870, 16GB of RAM and a 3GB HD7970.

 

Obsidian probably need to optimize the characters a bit better, but I am also upgrading because I hate bad frame rates.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

the anti-aliasing trick hugely increased my game's performance, but i have to set it to 0 in the console every time i enter a new area. is there a way to make the setting permanent across all areas? is there a file i need to track down and edit (like the config file for the baldur's gate games)? it's massively annoying to have the game slow down every time i enter or exit an inn.

Share this post


Link to post
Share on other sites
  • 0

Well, just found out that a very banal workaround is just to, ehm, zoom in in crowded areas (ie the starting fireplace)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I sub this, trying to play the game on a Macbook Pro Retina 2013 with Intel Iris 5100 and what's happening on screen doesn't nearly justify how choppy it runs.

Backgrounds are 100% 2D renders...i can run Star Craft 2  at Mediumd settings with 50 fps... same resolution....come on Obsidian...

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Well, just measured: I get a whole 8 to 10 fps on the opening camp fire scene at the start, goes in higher 20's when I move away, but drops to 8 again when I return...

Share this post


Link to post
Share on other sites
  • 0

I am surprised there are no options to lower the graphics any where in the game. That would probably help performance for a lot of people. hopefully it will be added in a patch if they can. 

  • Like 1

Break beneath the endless tide - monk

Share this post


Link to post
Share on other sites
  • 0

Yeah, it would probably help. Also, it is surprising considering the graphics and models are ok, but not spectacular. I really do hope there is something to be done and/or there will be a patch of some sort.

Share this post


Link to post
Share on other sites
  • 0

I'm using a Core 2 Duo 2.13 Ghz and a Radeon 6400; the game is running just fine with no problems for me. Not choppy at all.

Share this post


Link to post
Share on other sites
  • 0

Well, just measured: I get a whole 8 to 10 fps on the opening camp fire scene at the start, goes in higher 20's when I move away, but drops to 8 again when I return...

Yes, it seems something is off...

 

i5 3,5 GHz, HD4600

Resolution: 1280x1024

 

Next to the campfire:

MSAA enabled

21 fps

 

MSAA 0

29FPS

 

Even if the frame rate is low, my game is generally smooth...

Edited by Suen

I've come to burn your kingdom down

Share this post


Link to post
Share on other sites
  • 0

This is really unacceptable. Why didn't they add graphics options to the game menu? I don't think it's that hard to disable some of the Unity effects. And having to disable antialiasing through the console every time you enter a location is really a joke. Adding this antialiasng option to the menu would be very easy for them, yet they didn't bother. I'm seriosly quite disappointed.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...