Jump to content
  • 0

OSX graphics problem


Question

I installed the game via Steam.  I started the game and it began in window mode.  I changed the resolution to 3440x1440 and fullscreen saved it and restarted the game.  Now when I start the game, I see my cursor, hear the audio, and am faced with a black screen.  Maybe if I am able to change my resolution or go back to window mode that will help.

 

What is the path to the OSX ini file where I can fix/reset my resolution and other graphics options?

 

Please help.  Thanks

  • Like 1
Link to post
Share on other sites

Recommended Posts

  • 0

I'm having a similar problem. Also on Mac OSX. Character creation is smooth as a whistle, then I click Done/ Accept and it takes me to a black screen with only ambient noise, music and the hand cursor. I've tried in a different resolution and in windowed mode.

  • Like 1
Link to post
Share on other sites
  • 0

I have the same problem on 10.9.5 Mavericks. The game starts, I see the cursor & hear the sounds but the screen is black. Hitting Cmd-F to try and get the game in to windowed mode allows me to see the game for brief moments, but it does not want to get out of full screen mode.

 

I tried to disable the Steam overlay while in-game, this had no effect (it solved a similar problem on Shadowrun: Dragonfall)

  • Like 2
Link to post
Share on other sites
  • 0

Disconnecting my second display did not help. As I suspected, Unity is a broken POS on Mac, again. Why does anyone use them for a Mac game?! Why!? From ~/Library/Logs/Unity/Player.log:

--->InitializeDisplay()...
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

-->SortedResolutions[ 0 ] 1920x1080
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

-->SortedResolutions[ 1 ] 1280x720
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

-->SortedResolutions[ 2 ] 960x540
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

-->SortedResolutions[ 3 ] 2560x1600
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

-->SortedResolutions[ 4 ] 2048x1280

...

(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->MatchResolutionToIndex(2560x1600) returning 3
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(3, Fullscreen)...
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(3, Fullscreen) _currentResolutionIndex is 3, _currentDisplayMode is Unknown
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(3, Fullscreen) returning false.  Not initialized.
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeDisplayModeRoutine( Fullscreen, True )...
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeDisplayModeRoutine( Fullscreen, True ) _currentDisplayMode is Unknown
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeDisplayModeRoutine( Fullscreen, True ) calling Screen.fullscreen(true).
 
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/MacStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Switching to 2560x1600 fullscreen
Could not find requested mode.

 
(Filename:  Line: 104)

Switching to 2560 x1600 failed! Trying second best guess.
Switching to 1920x1440 fullscreen
Could not find requested mode.

...

Link to post
Share on other sites
  • 0

Ok, got rid of my black screen.  I have 3 monitors hooked up and the primary monitor (the one with the menu bar in display preferences) was 2560x1600.  It apparently can't handle that.  I made the monitor that is 1080p the primary and it started up just fine.  Went into options->graphics and it was still set at 2560x1600 so I manually changed the rez to 1920x1080.  Tried to set it to windowed mode and back to the black screen after I saved the changes.  Cmd F made it visible again.  Windowed mode apparently doesn't work.  We're talking about the gog version by the way.

 

 

Good luck, looks like a really nice game.

 

Link to post
Share on other sites
  • 0

One more player checking in with a black screen on Mac. The game started in windowed mode for me (I'm running an external 2560x1440 monitor on a Retina MBP), but when I put it into full screen, it goes black and I can only see the cursor. I'm mostly just posting to add one more person onto the list of Mac graphics issues. If any of my troubleshooting works, I'll append this post. 

 

Good luck my fellow Mac Eternity-goers!

Link to post
Share on other sites
  • 0

Same problem. Black screen with a cursor and music. Cmd-f makes the Obsidian logo flicker up for a moment and then it goes back to black.

 

Just the one monitor, and it's actually a video monitor, not apple, so I can't easily test just resetting the display to try to fix it.

Edited by stupei
Link to post
Share on other sites
  • 0

I also have problems with multi monitor support.

I am playing on MacBook Air 11" (Early 2014) with external monitor set as primary screen (because it's bigger and World of Warcraft like it that way).

The game is always in full screen mode, means it blacks out my second screen, I can't make it work in windowed mode.

Also the cursor cage is not working. At least I was not able to make it work…

Edited by Pobe
Link to post
Share on other sites
  • 0

Another with the same issue here. Mac Pro (tower), single 2560x1440 monitor. 

 

Can't use CMD+F to get out of fullscreen - it does flicker when I use that command and I can see the game when it flickers, but then goes black again.

 

I had a similar issue with Cities: Skylines, another Unity game, last week. I was able to get around it there by using the CMD+F shortcut > setting my screen resolution in the game options while in windowed mode (which then would cause the black screen) > quitting the game with CMD + Q > when I relaunched it would load at the correct resolution I set within the game options. If I want to play in windowed mode I basically have to go through all of that in reverse.

 

console.log output - The repeating capture/release is probably me hitting CMD+F.

3/26/15 6:25:19.823 PM PillarsOfEternity[11615]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.2 instead of 10.10.2. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
3/26/15 6:25:19.823 PM PillarsOfEternity[11615]: 0   CarbonCore                          0x00007fff97969d9b ___Gestalt_SystemVersion_block_invoke + 113
3/26/15 6:25:19.823 PM PillarsOfEternity[11615]: 1   libdispatch.dylib                   0x00007fff890f9c13 _dispatch_client_callout + 8
3/26/15 6:25:19.823 PM PillarsOfEternity[11615]: 2   libdispatch.dylib                   0x00007fff890f9b26 dispatch_once_f + 117
3/26/15 6:25:19.823 PM PillarsOfEternity[11615]: 3   CarbonCore                          0x00007fff979123ca _Gestalt_SystemVersion + 987
3/26/15 6:25:19.823 PM PillarsOfEternity[11615]: 4   CarbonCore                          0x00007fff97911fb7 Gestalt + 144
3/26/15 6:25:19.823 PM PillarsOfEternity[11615]: 5   PillarsOfEternity                   0x000000010072c4ad _ZN14AnimationEvent8TransferI17RemapPPtrTransferEEvRT_ + 952925
3/26/15 6:25:19.823 PM PillarsOfEternity[11615]: 6   PillarsOfEternity                   0x0000000100722a1b _ZN14AnimationEvent8TransferI17RemapPPtrTransferEEvRT_ + 913355
3/26/15 6:25:23.441 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:28.134 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23
3/26/15 6:25:28.153 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:35.655 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23
3/26/15 6:25:35.677 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:35.968 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23
3/26/15 6:25:35.981 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:36.347 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23
3/26/15 6:25:36.360 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:36.649 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23
3/26/15 6:25:36.661 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:36.950 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23
3/26/15 6:25:36.962 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:37.253 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23
3/26/15 6:25:37.264 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:37.555 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23
3/26/15 6:25:37.569 PM WindowServer[240]: Display 0x1a49c438 captured by conn 0x29f23
3/26/15 6:25:38.824 PM WindowServer[240]: Display 0x1a49c438 released by conn 0x29f23

Unity > Player.log has a lot of this sort of thing in it:

Switching to 2560x1440 fullscreen
Could not find requested mode.

 
(Filename:  Line: 104)

Switching to 2560 x1440 failed! Trying second best guess.
Switching to 2048x1152 fullscreen
Could not find requested mode.

 
(Filename:  Line: 104)

Switching to 2560 x1440 failed! Trying second best guess.
Switching to 1920x1080 fullscreen
Could not find requested mode.

 
(Filename:  Line: 104)

Switching to 2560 x1440 failed! Trying second best guess.
Switching to 1600x1200 fullscreen
Could not find requested mode.

Link to post
Share on other sites
  • 0

Back again! For what it's worth, I was able to get back to playing by unplugging my external monitor. When I started PoE up on just the laptop, it was running exactly as intended, fullscreen at 2560x1440 resolution. From there, I just put it into windowed mode again via the in-game controls and plugged my external monitor back in. I still can't get it to be fullscreen, but now at least I can play the game again in windowed mode!

Link to post
Share on other sites
  • 0

Hi guys,

 

I have the same (or a very similar) issue but have managed to work around it. When the game starts and the screen goes black, hitting cmd+F repeatedly occassionally makes the menu appear for a very short moment before it disappears again. It seems you can still click the buttons by repeatedly alternating between cmd+F and clicking the button area. If you can make it into Options through the flickering menu, click the Resolution drop-down, select a lower resolution, and untick Fullscreen (if it's ticked). Then press escape. A prompt should appear the apply the change, and doing so will create a fully working display window.

Edited by One of Many
  • Like 1
Link to post
Share on other sites
  • 0

I have the same issue, only my screen is black at the outset, I cannot use the menu.

 

System note:  I have an external monitor that I use with the laptop (Retina Macbook pro late 2013, also has discrete graphics card) closed.  The resolution is 2160x4096 (not a typo, it's a 4K LG monitor that I use rotated vertically).

 

The path I took was: Run the game, it launched in window mode - however the sides of the game were cut off, with large black bars at top and bottom of the screen.  I could not change the window size by dragging the edges.

 

Thinking it would fix things, I switched to fullscreen mode.  Oops!  As soon as that happened, I have a totally black screen.

 

Now I cannot exit fullscreen mode, ever.  Cmd-F briefly flickers the screen, during which time sometimes I get get mouse presses through to the main menu, but not the top screen menu bar (so I cannot ask the game to change resolutions).  Re-running the game automatically starts in fullscreen now, not windowed.

 

So basically I cannot play at all. :-(

 

The music is nice...

 

Edit:  Did not play beta (missed out on backing through KickStarter, just pre-ordered on Steam a day ago)

Edited by SirBill
Link to post
Share on other sites
  • 0

Hey, SirBill. When my secondary monitor fullscreen problem started, I disconnected the monitor and ran the game on my laptop. It started up fine there, and then I went in and modified the graphics options and unticked the fullscreen option. That lets me play the game at least !

 

So, am running it on my laptop now (15" retina mbp). Looks amazing on the retina display.

 

Now that I switched back to windowed mode, it runs on my external monitor (but in a window only) - going to keep running just on the laptop until this is fixed, but hopefully if you try this you will be able to run the game. It's awesome!  :biggrin:

Link to post
Share on other sites
  • 0

Hi, I have a similar problem. I ahve a Macbook air 13" and the character creation went fine. But after the first conversation in the game , the game crashed and take me to the desktop saying that i have a problem with my videocard. 

Link to post
Share on other sites
  • 0

Just chiming in to say I have the same problem. It works fine on my native Macbook pro retina display, but when I connect it to my external Dell display all I get is music, mouse pointer and a black screen.

 

I managed to trick it by using my native screen first, and then inserting the display port cable to the Dell while still running the game. It switched over, but then it was windowed and I couldn't get it to full screen.

 

To make matters even more confusing I tried to connect it at work this morning, and it works here for some reason! I have a Dell here too, but it's bigger. Will try again tonight.

Link to post
Share on other sites
  • 0

Could anyone who has made it work identify where the full screen check box is located on the screen? I can get to the options menu by hammering cmd-f over and over until the screen flickers up long enough to hit the button but I can't seem to read all the things in the menu quickly enough to figure out where to uncheck from full screen.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...