Jump to content
  • 0

Question

I installed the game via Steam.  I started the game and it began in window mode.  I changed the resolution to 3440x1440 and fullscreen saved it and restarted the game.  Now when I start the game, I see my cursor, hear the audio, and am faced with a black screen.  Maybe if I am able to change my resolution or go back to window mode that will help.

 

What is the path to the OSX ini file where I can fix/reset my resolution and other graphics options?

 

Please help.  Thanks

  • Like 1

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Could anyone who has made it work identify where the full screen check box is located on the screen? I can get to the options menu by hammering cmd-f over and over until the screen flickers up long enough to hit the button but I can't seem to read all the things in the menu quickly enough to figure out where to uncheck from full screen.

Roughtly 1/3 down from the top and 1/10 left from the center. From the two colums with the checkboxes it’s the top right checkbox.

 

Eventually it now works for me after switching to 1080p and using the two screen trick. ;)

Share this post


Link to post
Share on other sites
  • 0

Just bumping this for visibility. People on reddit have this problem too. I also posted in the support thread there, but didn't get a response.

 

I played the windowed version on my big screen yesterday, but only after starting it in window mode on my MacBook and then plugging in the second screen.

Share this post


Link to post
Share on other sites
  • 0

Kickstarter backer and Black Screener here.

 

2012 15" rMBP connected to Dell U2713HM monitor via CalDigit Thunderbolt Station.

 

Game is unplayable for me.

Share this post


Link to post
Share on other sites
  • 0

Kickstarter backer and Black Screener here.

 

2012 15" rMBP connected to Dell U2713HM monitor via CalDigit Thunderbolt Station.

 

Game is unplayable for me.

Just to be clear, does the game work if you disconnect the Dell?

Share this post


Link to post
Share on other sites
  • 0

Same issue here on a Mac Pro with a LG Ultrawide screen (3440x144) and an Asus 1080p. I tried to unplug one screen, the game now keeps being in full screen and it refuses to change its resolution whatever I can manage to set by keeping to hit cmd-F to make my screen flicker long enough to see where I'm clicking. This is so disappointing in so many ways… :(

Share this post


Link to post
Share on other sites
  • 0

 

Kickstarter backer and Black Screener here.

 

2012 15" rMBP connected to Dell U2713HM monitor via CalDigit Thunderbolt Station.

 

Game is unplayable for me.

Just to be clear, does the game work if you disconnect the Dell?

 

Haven't had an opportunity to try that yet. But ideally, they'd fix it so that it works with external monitors.

Share this post


Link to post
Share on other sites
  • 0

My guess is :

- the issue is related to the unity / mono combo : I got the same issue with Dungeon of the endless & Endless legend (was fixed in the first one a few weeks after launch, the second is still affected). Wasteland 2 (no mono AFAIK) was never affected.

- its not multiple monitors alone that triggers this bug. I have only one monitor, but it's wired with HDMI, and if I toggle fullscreen I got the same issue (black screen, audio and cursor, and unity/player.log spammed with unable to find monitor / switching res.

 

Really hope they'll fix this quick, playing windowed is such a pain...

Share this post


Link to post
Share on other sites
  • 0

Same problem here. I can't even get in the game. The game launches, i hear the music and see the game cursor, but the screen stays black. 

 

I'm using an external screen plugged by display port on a GTX970. 

 

I had to install the game in windows to play which i hate having to do. 

Share this post


Link to post
Share on other sites
  • 0

An update from my previous report  (I was having issues running the application on an external monitor in portrait orientation).

 

I tried launching the application just on my laptop, with the external monitor disconnected.  That worked, but when I went into graphics options and tried to turn off full-screen mode, it has no effect (it would only run full-screen on the laptop).

 

I switched back to the external monitor, and now it is back to running windowed there.  But it does not help, because my monitor is portrait and the game tries to use the full height of the screen in a window that cannot be resized - so most of the sides of the screen are not visible.  The resolution does not effect this, I have the game set to the lowest resolution with the same effect - the game runs expanded to fill the entire height of the screen, window edges lost.

 

I'll continue to play somewhat on the laptop itself, but I really would prefer to be using my much larger external monitor to play on.

 

Share this post


Link to post
Share on other sites
  • 0

I have the same problem. It works fine on my native Macbook pro retina display, but when I connect it to my external Dell display all I get is music, mouse pointer and a black screen.

 
2013 15" rMBP connected to Dell U2713HM monitor.
 
(Yes, I basically copy-pasted those lines from earlier posts because I have the EXACT same problem!!)

Share this post


Link to post
Share on other sites
  • 0

I'm having the same problem as everyone here. on a mac tower using an insignia television. Interestingly enough if you change the res settings in game you can play in a windowed mode but I keep getting a black screen after I start character creation.

Share this post


Link to post
Share on other sites
  • 0

I have a standard iMac system / monitor and am not externally connected to any monitor or screen.  Is the OS X issue only cropping up when external monitors are connected?

Share this post


Link to post
Share on other sites
  • 0

I have a standard iMac system / monitor and am not externally connected to any monitor or screen.  Is the OS X issue only cropping up when external monitors are connected?

This appears to be the case. I've run the game successfully on my macbook but the thing is a potato so I cant really play. 

Share this post


Link to post
Share on other sites
  • 0

Are you guys all running Yosemite ?

 

Zero problem on my end (15" rMBP mid-2014, on Yosemite)...

Share this post


Link to post
Share on other sites
  • 0

I have an external Apple 27" attached via Thunderbolt to my Retina MBP.   Other than the known dual-dsiplay issue with the mouse, it works O.K. I can also run it on my MBP fine.  My issue is in neither configuration can I change the full screen option; I click it off, save, go back in, and it's back to full-screen.  So I'm not having the issue many others are, but, it needs work.

Share this post


Link to post
Share on other sites
  • 0

I have the same problem. Had to reinstall on another machine, and still buggy as hell. Been trying to get it to work on my main 2560 X 1440 for 2 hours now... 

Still playing with a grey bar above game. Pillars is so awesome I deal with it. Oh Obsidian, why you so good and so bad to me?

Share this post


Link to post
Share on other sites
  • 0

Are you guys all running Yosemite ?

 

Zero problem on my end (15" rMBP mid-2014, on Yosemite)...

Yes, latest version. Works on laptop screen but not external (except in windowed mode.)

 

Are you running an external monitor?

Share this post


Link to post
Share on other sites
  • 0

I have to report a similar issue. I'm running 10.8.5 on my Mac Pro w/ dual monitors.

 

Full Screen won't work so I had to hit Command-F several times to get a flickering Options screen. I was eventually able to get to the Graphics options, lower my resolution to 1280x720 and play fine within a window.  To test, I quit the game, restarted, and it still comes up within a window.

 

I wasn't in the beta but have heard nothing but great things about this game. Decided to give it a try and almost regretted it when this graphics issue came up.  Hopefully a fix/patch will be forthcoming.

Share this post


Link to post
Share on other sites
  • 0

Having the same problem on MBP using external display over thunderbolt. Game loads into "full screen" every time. I can get into options using the CMD+F flicker rapid click, select "full screen" and get it to temporarily window. When I try to start a game it goes right back to full screen with a black screen. Game is unplayable. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Heres the truly bizarre part for me. After I get to the graphics portion of option I need to check "run full screen" in order the game to be run in windowed mode. Furthermore no matter what I change the res to it doesn't have an impact on the game

Share this post


Link to post
Share on other sites
  • 0

I am having the same issue with an external monitor connected by mini-Displayport to Displayport running Mavericks on a rMBP. Full screen on the internal display works fine, on the external one there is just music and a black screen.

 

My procedure is:

- set the external display as primary

- start pillars of eternity

- set the internal display as primary

- play in windowed mode with a small grey bar on the external display

 

I noticed that starting the game with internal or external display set as primary results in different graphic settings. As an exaqmple, I am unable to change the resolution when starting the game if the internal display is set as primary while an external screen is connected. By the way, I deactivated the automatic switching of primary displays (when the dock appears on the screen where your cursor is) as this screwed up the graphics settings of software I need for my work (Xserver and so on) - maybe this also affects pillars of eternity.

 

The procedure is a bit annoying but at least it works and I can play :no:

 

Best wishes

Edited by None

Share this post


Link to post
Share on other sites
  • 0

For those having the issue, is your monitor hooked on HDMI ? 

thanks...

No. I use a Displayport cable connected to a Thunderbolt port.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...