Jump to content

Recommended Posts

Firstly, no-one using Steam should be using a standalone patch. Ever.

 

Secondly, I had issues with the DRM from day one, constantly requiring reactivation 10 hours after the previous activation. I'm reinstalling now and hoping this helps.

 

[edit] Insta-crash.

 

Problem signature:
 Problem Event Name:	APPCRASH
 Application Name:	APGame.exe
 Application Version:	1.1.0.0
 Application Timestamp:	4c6983e2
 Fault Module Name:	APGame.exe
 Fault Module Version:	1.1.0.0
 Fault Module Timestamp:	4c6983e2
 Exception Code:	c0000005
 Exception Offset:	000052cd
 OS Version:	6.1.7600.2.0.0.768.3
 Locale ID:	3081
 Additional Information 1:	36bb
 Additional Information 2:	36bb79423ee81666a50b715f3bf39181
 Additional Information 3:	011b
 Additional Information 4:	011bbea8187afcfeb541e96958ff846a

Read our privacy statement online:
 http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
 C:\Windows\system32\en-US\erofflps.txt

 

 

I don't know where this came from but it somehow ended up on my clipboard while trying to copy the info above ...

 

Fatal error!

Address = 0x4052cd   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0x428402   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0x457d7a   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0x457e28   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0x457759   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0x42bc24   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0xd73f14   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0xd74059   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0xd7631a   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0xd770e7   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0xd771f4   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
Address = 0xc6579c   (filename not found) [in G:\Games\SEGA\Alpha Protocol\Binaries\APGame.exe]
BaseThreadInitThunk() Address = 0x76643677 (filename not found) [in C:\Windows\syswow64\kernel32.dll]
RtlInitializeExceptionChain() Address = 0x77309d42 (filename not found) [in C:\Windows\SysWOW64\ntdll.dll]
RtlInitializeExceptionChain() Address = 0x77309d15 (filename not found) [in C:\Windows\SysWOW64\ntdll.dll]
RtlInitializeExceptionChain() Address = 0x77309d15 (filename not found) [in C:\Windows\SysWOW64\ntdll.dll]

 

 

All the files exist in those locations.

Edited by Jigoku

Share this post


Link to post
Share on other sites

Jigoku, do you have the US or EU version of the game?


This post is not to be enjoyed, discussed, or referenced on company time.

Share this post


Link to post
Share on other sites

It wouldn

Edited by kirottu

This post is not to be enjoyed, discussed, or referenced on company time.

Share this post


Link to post
Share on other sites

i recently installed AP on Win7 x64 and everytime I try to load a save (auto or quicksave or safehouse) the game crashes. So I can't play it. with that patch it does not even start.......if that is only working on US, maybe it is searching for the "en-us" folder, because in the EU the gamefolder is only called "en" afaik.....there have been problems with such minor differences in games before.

Share this post


Link to post
Share on other sites

With some other problems, creating an en-us folder & copying en files onto it helped. But yes, definitely seems like this is a quick internal in-progress thing for US only..

Share this post


Link to post
Share on other sites
With some other problems, creating an en-us folder & copying en files onto it helped. But yes, definitely seems like this is a quick internal in-progress thing for US only..

Well, this didn't help me. I hope they release a working patch.


J_C from Codexia

Share this post


Link to post
Share on other sites

Does anyone want to guess how long it will take for them to patch the patch?


This post is not to be enjoyed, discussed, or referenced on company time.

Share this post


Link to post
Share on other sites

I personally hope for a real patch instead of a non-US .exe file only and calling it a day.

 

False hope I suppose though :p.


^

 

 

I agree that that is such a stupid idiotic pathetic garbage hateful retarded scumbag evil satanic nazi like term ever created. At least top 5.

 

TSLRCM Official Forum || TSLRCM Moddb || My other KOTOR2 mods || TSLRCM (English version) on Steam || [M4-78EP on Steam

Formerly known as BattleWookiee/BattleCookiee

Share this post


Link to post
Share on other sites
I personally hope for a real patch instead of a non-US .exe file only and calling it a day.

 

What? It is "real" patch if it fixes things and works.


This post is not to be enjoyed, discussed, or referenced on company time.

Share this post


Link to post
Share on other sites
Does anyone want to guess how long it will take for them to patch the patch?

 

I bet they will want to get some more feedback on the patch and not just do a quick fix :)


Hate the living, love the dead.

Share this post


Link to post
Share on other sites

Hi

 

I've purchased the French ver of AP a while ago. The game looks really interesting but...I was hoping sega would release a patch for some MAJOR technical issues, such as an enormous graphical bug which completly annihilate gaming experience. I'm speaking about regular glitches and abnormal lags, which IMO aren't related to some performance issues. I've tried to configure game graphics to the minimum, but the same lags and glitches occur at the same rate, which is every 20 seconds.

 

Here some details about my config :

- CPU : 3Ghz

- RAM : 4Go

- GPU : ATI RADEON HD 4870 1Go

- Windows 7

 

This shouldn't be a performance problem, as the game automatically sets the performance to the maximum and despite this bug I'm experiencing, the game appear to run smoothly. I'm also intrigued by this patch they've released, as it makes me think about a cracked exe, some "pirate" team would have released.

 

I'm sure I'm not the only one having this kind of bug. What's the point to support game companies if they're not able to release a WORKING game, or at least a decent patch? This is too much for a 60€ game...

Share this post


Link to post
Share on other sites
People, let's illegally download this game and other further sega/obsidian games, so they begin to understand how upset their players/customers are. To the admins, censor me or ban me if you like, I don't care. This won't make your game more playable.

 

No offense, but you are a massive idiot if you think pirating games will suddenly make companies such as Sega treat their customers better. It will only stop them from making genre games. We will be riddled with more and more generic shooters with bad stories.

As for developers most of the time their hands are tied by the publisher.


Hate the living, love the dead.

Share this post


Link to post
Share on other sites

I have Alpha Protocol PC - Retail Version (DVD) from USA.

Patch 1.1 works also fine for me.

 

Just thought I'd let y'all know, so you all can hopefully figure out why the heck it ain't working for some of y'all around the globe.

 

Hopefully, Sega and Obsidian can straighten some things out here and let us know the deal w/ this matter and can give us some log notes and help out or something...

Share this post


Link to post
Share on other sites
I have Alpha Protocol PC - Retail Version (DVD) from USA.

Patch 1.1 works also fine for me.

 

Just thought I'd let y'all know, so you all can hopefully figure out why the heck it ain't working for some of y'all around the globe.

 

Hopefully, Sega and Obsidian can straighten some things out here and let us know the deal w/ this matter and can give us some log notes and help out or something...

 

One problem is of course, that its only for US retail. Im sure we will get a proper patch in.. oh.. hopefully sometime.. next year.

Share this post


Link to post
Share on other sites
As for developers most of the time their hands are tied by the publisher.

 

 

Chained to giant blocks of concrete would probably be more accurate.


Notice how I can belittle your beliefs without calling you names. It's a useful skill to have particularly where you aren't allowed to call people names. It's a mistake to get too drawn in/worked up. I mean it's not life or death, it's just two guys posting their thoughts on a message board. If it were personal or face to face all the usual restraints would be in place, and we would never have reached this place in the first place. Try to remember that.

Share this post


Link to post
Share on other sites

God, everyone's a troll in this thread.

 

Just downloaded and installed the patch. Can't tell if anything's changed, except the menu transitions are maybe a quarter-second faster (not that it ever bugged me anyway). No game-wrecking crashes or anything, though, so that's good.

Share this post


Link to post
Share on other sites

Dropped a tweet to Chris.

 

woffen@ChrisAvellone Know anything about the real alpha protocol patch? The one released doesnt work for most people and aint THE patch I hope.

 

ChrisAvellone@woffen Checking with SEGA to see what's up.

 

Lets hope we get some information.

Share this post


Link to post
Share on other sites
God, everyone's a troll in this thread.

 

Just downloaded and installed the patch. Can't tell if anything's changed, except the menu transitions are maybe a quarter-second faster (not that it ever bugged me anyway). No game-wrecking crashes or anything, though, so that's good.

 

Yeah, I'm certainly inventing imaginary problems because I have nothing better to do! It's not like, say, I encountered those problems! You are the beacon of truth and hope Karl! Go on! You are the new Jesus Christ! :)

Share this post


Link to post
Share on other sites
My first orders of business will be to ban Purkake from life and make WUE get a real username. :)

 

Sorry for the reaction, I was in a really bad mood. Still, my point stands, people have been complaining because there are problems, not because they like to complain, and if you actually look at their post history, a lot of those people that were complaining have defended AP.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...