Jump to content
  • 0
Manulla

Mac: Game won't launch at all (workaround doesn't work either)

Question

I have a new Retina MacbookPro 15 inch AMD Radeon R9 M370X. Downloaded the game via Steam. No trouble. But it won't launch. Screen goes black, small "Preparing"-screen appears and then nothing. Similar to the launching problems already reported. Only that the workaround with the original file from the library doesn't work either. Kind of frustrating. Anyone else has this problem?

 

 

 

Player.log.zip

Edited by Manulla

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

Hi Manulla,

 

I'm going to try and get one of those ASAP, but if I may ask, do you happen to have Wasteland 2 and/or Shadowrun? Curious if they run OK or if you run into issues with them.

 

Either way, we'll get our hands on one and try it out and see if we can see what's up.

 

Thanks,

Darren


OBSIDIAN ORDER OF ETERNITY - Officially sponsored most generously by Pierre and SD!

Share this post


Link to post
Share on other sites
  • 0

I don't have those games. But I can tell you that meanwhile I tried PoE in boot camp on windows. Seems to work fine there...

Share this post


Link to post
Share on other sites
  • 0

Hello.  We are aware of the situation and doing what we can to test this issue internally to hopefully come up with a fix.  Sorry for the inconvenience, and thank you for the support.


- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Share this post


Link to post
Share on other sites
  • 0

Hey guys,

 

I have the same problem with a 2015 Macbook Pro with AMD R9 370X graphics card.

 

I found two solutions to the problem.

i) plug on a monitor via HDMI

ii) in Settings / Energy (OS X settings; don't know the exact terms, my system runs in german) there is a option to automatically switch between Intel and AMD graphics card. Deactivate it.

 

Both work in my case. Hope I could help.

Share this post


Link to post
Share on other sites
  • 0

I have a new Retina MacbookPro 15 inch AMD Radeon R9 M370X. Downloaded the game via Steam. No trouble. But it won't launch. Screen goes black, small "Preparing"-screen appears and then nothing. Similar to the launching problems already reported. Only that the workaround with the original file from the library doesn't work either. Kind of frustrating. Anyone else has this problem?

Disable AUTOMATIC GPU SWITCHING in energy saver

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Switching to windowed mode helped me just a little while. After couple transitions between areas, crashes started to occur again. I don't have external monitor and I only have one GPU ("Intel Iris 1536 MB"), so aforementionted fix is not going to work for me.

 

Developers, let me know how can I help. I can send you logs, run test code, or do whatever is needed to get this fixed. This is way too great game to prevent Mac users to enjoy this.

Share this post


Link to post
Share on other sites
  • 0

Hey guys, sorry about the issues you're experiencing!

 

I've just heard from the ~powers that be~ that there's a hotfix coming shortly for this issue.

 

We'll update as we know more. Thanks for your patience.

Share this post


Link to post
Share on other sites
  • 0

Ive just installed it now from Steam on my MBPr 2013 integrated graphics, 10.10.5, 8 Gb and it wont go past character creation into the game without crashing.

 

Graphics hardware encountered an error and was reset: 0x00000003, EXC_CRASH (SIGABRT) in the Unity thread.

 

A hotfix hasnt been coming shortly, should i get a refund?

Share this post


Link to post
Share on other sites
  • 0

Hello Captainjon,

 

Welcome to the forums! I hope you had an awesome holiday season! Have you tried the solution that was resolved in this thread? The hotfix was released in mid June. Could you please post your system specs? 

 

Thanks a bunch!


Whats this at obsidian.net?

Share this post


Link to post
Share on other sites
  • 0

Hello Aarik,

 

i also purchased the steam-version during the winter-sale and experience the same problem. 

 

I´ve overcome the initial crash (right after the beginning dialog) by switching to window-mode. After that, i was able to play about 18 hours (act II) without any crashes; but now the game dies with every transition or save...

 

I´ve got a Late-2013 MBP (https://support.apple.com/kb/SP690?locale=en_US), 16 GB running OS X 10.10.5

 

I´m currently downloading the El Capitan-Update, hoping this might solve the issue... these 18 hours really got me hooked :)

 

Thanks for your support 

 

 

 

 

 

Hello Captainjon,

 

Welcome to the forums! I hope you had an awesome holiday season! Have you tried the solution that was resolved in this thread? The hotfix was released in mid June. Could you please post your system specs? 

 

Thanks a bunch!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...