Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Mac: Game won't launch at all (workaround doesn't work either)

Crash Launch Start Mac

Best Answer Fumanchu , 14 June 2015 - 10:16 AM

Hey guys,

 

I have the same problem with a 2015 Macbook Pro with AMD R9 370X graphics card.

 

I found two solutions to the problem.

i) plug on a monitor via HDMI

ii) in Settings / Energy (OS X settings; don't know the exact terms, my system runs in german) there is a option to automatically switch between Intel and AMD graphics card. Deactivate it.

 

Both work in my case. Hope I could help.

Go to the full post »


  • Please log in to reply
14 replies to this topic

#1
Manulla

Manulla

    (0) Nub

  • Initiates
  • 3 posts
  • Steam:manulla

I have a new Retina MacbookPro 15 inch AMD Radeon R9 M370X. Downloaded the game via Steam. No trouble. But it won't launch. Screen goes black, small "Preparing"-screen appears and then nothing. Similar to the launching problems already reported. Only that the workaround with the original file from the library doesn't work either. Kind of frustrating. Anyone else has this problem?

 

 

 

Attached Files


Edited by Manulla, 09 June 2015 - 07:07 AM.


#2
Darren Monahan

Darren Monahan

    Dread Lord Grandmaster Chef of the Obsidian Order

  • Developers
  • 158 posts
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer

Hi Manulla,

 

I'm going to try and get one of those ASAP, but if I may ask, do you happen to have Wasteland 2 and/or Shadowrun? Curious if they run OK or if you run into issues with them.

 

Either way, we'll get our hands on one and try it out and see if we can see what's up.

 

Thanks,

Darren



#3
Manulla

Manulla

    (0) Nub

  • Initiates
  • 3 posts
  • Steam:manulla
I don't have those games. But I can tell you that meanwhile I tried PoE in boot camp on windows. Seems to work fine there...

#4
fullasagoog

fullasagoog

    (1) Prestidigitator

  • Members
  • 6 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer

Here's an earlier topic on this exact same issue:

http://forums.obsidi...ro-retina-2015/

 

Let me know if there's any additional info i can provide.  Eager to get playing again ;)



#5
celliott

celliott

    3D Artist - Armored Warfare

  • Members
  • 640 posts
  • Pillars of Eternity Silver Backer
  • Kickstarter Backer

Hello.  We are aware of the situation and doing what we can to test this issue internally to hopefully come up with a fix.  Sorry for the inconvenience, and thank you for the support.



#6
Fumanchu

Fumanchu

    (0) Nub

  • Initiates
  • 2 posts
✓  Best Answer

Hey guys,

 

I have the same problem with a 2015 Macbook Pro with AMD R9 370X graphics card.

 

I found two solutions to the problem.

i) plug on a monitor via HDMI

ii) in Settings / Energy (OS X settings; don't know the exact terms, my system runs in german) there is a option to automatically switch between Intel and AMD graphics card. Deactivate it.

 

Both work in my case. Hope I could help.



#7
phanbuey

phanbuey

    (0) Nub

  • Initiates
  • 2 posts

I have a new Retina MacbookPro 15 inch AMD Radeon R9 M370X. Downloaded the game via Steam. No trouble. But it won't launch. Screen goes black, small "Preparing"-screen appears and then nothing. Similar to the launching problems already reported. Only that the workaround with the original file from the library doesn't work either. Kind of frustrating. Anyone else has this problem?

Disable AUTOMATIC GPU SWITCHING in energy saver


  • Manulla likes this

#8
Manulla

Manulla

    (0) Nub

  • Initiates
  • 3 posts
  • Steam:manulla

Disabling GPU switching works! Thanks a lot!



#9
SpectreX

SpectreX

    (1) Prestidigitator

  • Members
  • 13 posts
  • Location:Fort Campbell, KY

try running it in a windowed mode? Maybe press command + M?



#10
mihail2000

mihail2000

    (0) Nub

  • Initiates
  • 3 posts

Switching to windowed mode helped me just a little while. After couple transitions between areas, crashes started to occur again. I don't have external monitor and I only have one GPU ("Intel Iris 1536 MB"), so aforementionted fix is not going to work for me.

 

Developers, let me know how can I help. I can send you logs, run test code, or do whatever is needed to get this fixed. This is way too great game to prevent Mac users to enjoy this.



#11
mashamoshpit

mashamoshpit

    Obsidian Alumni

  • Members
  • 8 posts
  • Location:California
  • Steam:mashamoshpit

Hey guys, sorry about the issues you're experiencing!

 

I've just heard from the ~powers that be~ that there's a hotfix coming shortly for this issue.

 

We'll update as we know more. Thanks for your patience.



#12
captainjon

captainjon

    (0) Nub

  • Initiates
  • 1 posts

Ive just installed it now from Steam on my MBPr 2013 integrated graphics, 10.10.5, 8 Gb and it wont go past character creation into the game without crashing.

 

Graphics hardware encountered an error and was reset: 0x00000003, EXC_CRASH (SIGABRT) in the Unity thread.

 

A hotfix hasnt been coming shortly, should i get a refund?



#13
Aarik D

Aarik D

    Community Manager

  • Developers
  • 3235 posts
  • Black Isle Bastard!

Hello Captainjon,

 

Welcome to the forums! I hope you had an awesome holiday season! Have you tried the solution that was resolved in this thread? The hotfix was released in mid June. Could you please post your system specs? 

 

Thanks a bunch!



#14
haters-gonna-hate

haters-gonna-hate

    (0) Nub

  • Initiates
  • 2 posts

Hello Aarik,

 

i also purchased the steam-version during the winter-sale and experience the same problem. 

 

I´ve overcome the initial crash (right after the beginning dialog) by switching to window-mode. After that, i was able to play about 18 hours (act II) without any crashes; but now the game dies with every transition or save...

 

I´ve got a Late-2013 MBP (https://support.appl...90?locale=en_US), 16 GB running OS X 10.10.5

 

I´m currently downloading the El Capitan-Update, hoping this might solve the issue... these 18 hours really got me hooked :)

 

Thanks for your support 

 

 

 

 

 

Hello Captainjon,

 

Welcome to the forums! I hope you had an awesome holiday season! Have you tried the solution that was resolved in this thread? The hotfix was released in mid June. Could you please post your system specs? 

 

Thanks a bunch!



#15
haters-gonna-hate

haters-gonna-hate

    (0) Nub

  • Initiates
  • 2 posts

Update to El Capitan seems to work! no crash so far 

 

I´m currently downloading the El Capitan-Update, hoping this might solve the issue... these 18 hours really got me hooked :)

 


  • Aarik D likes this





Also tagged with one or more of these keywords: Crash Launch Start, Mac

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users