Jump to content

Question

So I've been happily (and sneakily)  exploring Raedric's Hold. Was slowly making my way in the Hold's interior when I went up the Siege Platform exit. Due to my ever-loving danger sense, I saved... about thrice.

 

So when I saw it's safe, looted the place, and returned back inside... the game crashed. Right now I'm stuck and can't re-enter the castle... which makes me a sad regicide :(

 

If there is any information I need to give, feel free to ask. I'm just hoping i'm not permanently stuck :p

  • Like 10

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

exactly my Problem too. i entered the secluded armory on the sanctuary map looted the Quality armors and everytime i try to leave there is the loading Screen for a few seconds and then a black Screen with the movement Cursor. application stopped working. i have a steam copy and there is already a thread there. appearantly all those who are affected do not have the game in their Profile appearing. same goes for me.

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

It will help the dev's if you can upload your save file and output_log.txt (latter from \SteamApps\common\Pillars of Eternity\PillarsOfEternity_Data). I've got this problem too, and I'm wondering if the bottom of your log has the same error as mine which is :

ArgumentException: An element with the same key already exists in the dictionary.

  at System.Collections.Generic.Dictionary`2[system.Guid,ObjectPersistencePacket].Add (Guid key, .ObjectPersistencePacket value) [0x00000] in <filename unknown>:0 
  at PersistenceManager.SaveObject (.Persistence persistence) [0x00000] in <filename unknown>:0 
  at PersistenceManager.SaveGame () [0x00000] in <filename unknown>:0 
  at GameResources.BuildSaveFile (System.String name) [0x00000] in <filename unknown>:0 
  at GameResources.SaveGame (System.String filename) [0x00000] in <filename unknown>:0 
  at GameState.Autosave () [0x00000] in <filename unknown>:0 
  at GameState.FinalizeLevelLoad () [0x00000] in <filename unknown>:0 
  at LevelStartWrapperExit.Update () [0x00000] in <filename unknown>:0 
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

 

It will help the dev's if you can upload your save file and output_log.txt (latter from \SteamApps\common\Pillars of Eternity\PillarsOfEternity_Data). I've got this problem too, and I'm wondering if the bottom of your log has the same error as mine which is :

ArgumentException: An element with the same key already exists in the dictionary.

  at System.Collections.Generic.Dictionary`2[system.Guid,ObjectPersistencePacket].Add (Guid key, .ObjectPersistencePacket value) [0x00000] in <filename unknown>:0 
  at PersistenceManager.SaveObject (.Persistence persistence) [0x00000] in <filename unknown>:0 
  at PersistenceManager.SaveGame () [0x00000] in <filename unknown>:0 
  at GameResources.BuildSaveFile (System.String name) [0x00000] in <filename unknown>:0 
  at GameResources.SaveGame (System.String filename) [0x00000] in <filename unknown>:0 
  at GameState.Autosave () [0x00000] in <filename unknown>:0 
  at GameState.FinalizeLevelLoad () [0x00000] in <filename unknown>:0 
  at LevelStartWrapperExit.Update () [0x00000] in <filename unknown>:0 

 

That is indeed the case with me as well, yes.

Where can I find my savegame file, so I can upload it someplace together with the output log file? Thanks in advance!

Share this post


Link to post
Share on other sites
  • 0

I have almost the same problem, except reverse. I am inside raedrics hold, doing everything just fine, but when i try to leave, it fails to load the zone i end up at  (black screen + movement cursor after load screen), and clicking anywhere freezes the game.

  • Like 4

Share this post


Link to post
Share on other sites
  • 0

I have the same error lines at the bottom of my output_log.txt as well. The game crashes anytime I try to leave to the exterior of the hold (lower ramparts, seige ramparts, courtyard etc). It loads for a bit then goes to a black screen with the movement cursor and if I click anywhere the game does not respond. I am using the steam version.

output_log.txt

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Same issue, stuck inside the keep, can't leave, have tried all the exits to outdoors. Goes to a black screen after loading screen and then crashes. Can't progress either. Really bad bug, gamebreaking. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Same. I can't re-enter the castle from any entrance after leaving the big double doors in the courtyard. Thankfully I can world map out and the rest of the game works, but all castle entrances are unusable.

Share this post


Link to post
Share on other sites
  • 0

Its occurring for me anytime I try to go to an outside area. I can still traverse the castle internally but am even unable to enter the siegeworks, exit via the sewers, etc.

Share this post


Link to post
Share on other sites
  • 0

Same bug here, cannot progress @Raedric's hold, stuck.

 

(also, launching game through steam gives me zero voice overs, red questionmarks instead of portraits - had to DL Gog.com version to fix that).

Share this post


Link to post
Share on other sites
  • 0

I'm having the same problem. I've completed most of the keep, went down to the dungeon area again to finish looting, and now when I try to zone out it goes to black screen with the cursor.  Unfortunately, both my autosave and regular save are in the dungeon, so I'm stuck with waiting or starting over.  Thanks!

 

Edit: here is my output log info. Seems about the same as others.

 

Tier1Backer cannot be loaded because the asset bundle type is not supported!
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Tier2Backer cannot be loaded because the asset bundle type is not supported!
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

ArgumentException: An element with the same key already exists in the dictionary.
  at System.Collections.Generic.Dictionary`2[system.Guid,ObjectPersistencePacket].Add (Guid key, .ObjectPersistencePacket value) [0x00000] in <filename unknown>:0

  at PersistenceManager.SaveObject (.Persistence persistence) [0x00000] in <filename unknown>:0

  at PersistenceManager.SaveGame () [0x00000] in <filename unknown>:0

  at GameResources.BuildSaveFile (System.String name) [0x00000] in <filename unknown>:0

  at GameResources.SaveGame (System.String filename) [0x00000] in <filename unknown>:0

  at GameState.Autosave () [0x00000] in <filename unknown>:0

  at GameState.FinalizeLevelLoad () [0x00000] in <filename unknown>:0

  at LevelStartWrapperExit.Update () [0x00000] in <filename unknown>:0
 
(Filename:  Line: -1)

Tier1Backer cannot be loaded because the asset bundle type is not supported!
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Tier2Backer cannot be loaded because the asset bundle type is not supported!
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)
 

Edited by kkrraagg

Share this post


Link to post
Share on other sites
  • 0

I have almost the same problem, except reverse. I am inside raedrics hold, doing everything just fine, but when i try to leave, it fails to load the zone i end up at  (black screen + movement cursor after load screen), and clicking anywhere freezes the game.

Same issue with me, on the roof, stuck crashing out when trying to load it.  No dice even as admin.  Save the TrialOfIronSave line, mine's roughly the same:

ArgumentException: An element with the same key already exists in the dictionary.
  at System.Collections.Generic.Dictionary`2[System.Guid,ObjectPersistencePacket].Add (Guid key, .ObjectPersistencePacket value) [0x00000] in <filename unknown>:0 
  at PersistenceManager.SaveObject (.Persistence persistence) [0x00000] in <filename unknown>:0 
  at PersistenceManager.SaveGame () [0x00000] in <filename unknown>:0 
  at GameResources.BuildSaveFile (System.String name) [0x00000] in <filename unknown>:0 
  at GameResources.SaveGame (System.String filename) [0x00000] in <filename unknown>:0 
  at GameState.TrialOfIronSave () [0x00000] in <filename unknown>:0 
  at GameState.Autosave () [0x00000] in <filename unknown>:0 
  at GameState.FinalizeLevelLoad () [0x00000] in <filename unknown>:0 
  at LevelStartWrapperExit.Update () [0x00000] in <filename unknown>:0 

Share this post


Link to post
Share on other sites
  • 0

I am having the same issue.  Don't feel the need to post my log because it's the same exact issue.  Top of the hold, try to zone in, loading screen, then a black screen that plays effects and it crashes.

 

All I wanted to do was get loot :(.

Share this post


Link to post
Share on other sites
  • 0

Same problem. I've tried multiple exits and I'm sealed in. 

 

ArgumentException: An element with the same key already exists in the dictionary.
  at System.Collections.Generic.Dictionary`2[System.Guid,ObjectPersistencePacket].Add (Guid key, .ObjectPersistencePacket value) [0x00000] in <filename unknown>:0 

  at PersistenceManager.SaveObject (.Persistence persistence) [0x00000] in <filename unknown>:0 

  at PersistenceManager.SaveGame () [0x00000] in <filename unknown>:0 

  at GameResources.BuildSaveFile (System.String name) [0x00000] in <filename unknown>:0 

  at GameResources.SaveGame (System.String filename) [0x00000] in <filename unknown>:0 

  at GameState.Autosave () [0x00000] in <filename unknown>:0 

  at GameState.FinalizeLevelLoad () [0x00000] in <filename unknown>:0 

  at LevelStartWrapperExit.Update () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

Tier2Backer cannot be loaded because the asset bundle type is not supported!
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Share this post


Link to post
Share on other sites
  • 0

My game crash also in Raedric but only when i try to re-enter the chapel.

 

For additional information, it started to crash after i killed Nedmar's men, then i went to osrya to rest and then i could not go back anymore to the chapel.

 

output_log.txt

Edited by Norida

Share this post


Link to post
Share on other sites
  • 0

I occasionally got crashes when area transitioning to and from interior/exterior map in Raedrics - however - the crashing upon reload was isolated (in my case) to the autosave that was made automatically - my previously made quick and manual saves were fine, and though the game would, on occasion, crash again at transition, it wouldn't do so immediately after reloading - however, it would always crash on transition if I loaded from the autosave. 

 

I've been really really anal about saving before area transitions because the original KOTOR had similar problems and I didn't have internet when I was a teenager, so I just had to deal with the unpatched constant area transition crashes lol. 

Edited by Gallenger

Share this post


Link to post
Share on other sites
  • 0

Same things happening to me. Initially entered through the roof down into the Sanctuary, cleared the Sanctuary but didn't have the mechanic skill to get into the two locked rooms. So I went down into the dungeon and cleared that, just talked to the crazy lady and was headed back up to the Sanctuary level, but when I got out into the main level and went to click on the stairs in the kitchen to go back up, the game loaded to a black screen and a movement cursor. I'm stuck right now, all my saves seem to be doing the same thing and I don't have any more recent saves than down in the dungeon. 

 

Everything was going smoothly, not a single bug and now I'm really sad because I'm stuck because of this.

 

edit - To add to this. Entering the Sanctuary level from any of it's points leads to the black screen with movement cursor and followed by the game crashing. This is really disappointing :(

Edited by trashmyego

Share this post


Link to post
Share on other sites
  • 0

Can we get a dev in here to give us an ETA on if this can get fixed?  I would like to enjoy this game but I feel that it's going to be impossible passing this area if it continues to black screen.

  • Like 4

Share this post


Link to post
Share on other sites
  • 0

cant leave Hold at all dosent seem to let u out of any doors leaving hold just gose black screen with cog and then  after waiting bit says game has crashed tryed each and every door. same thing ( only seems to crash when leaving )

Share this post


Link to post
Share on other sites
  • 0

And this, folks, is why you never play Ironman on your first game. ;)

 

Not helpful. Also, this isn't an issue with ironman, all three of my saves do this.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...