Jump to content
  • 0

[BUG][1.2.0] AI Behavior editor is unclickable.



10 answers to this question

Recommended Posts

  • 0

Hello hekiller,


Thank you very much for posting! We have this issue logged currently as a high priority issue to fix in an upcoming patch.


In the meantime, would you mind getting me a video of the issue if possible? I do have the matter entered myself, I just want to be sure I have every instance of this bugged to support you guys.





I like big bugs and I cannot lie...

Link to comment
Share on other sites

  • 0

Not sure if this helps but I am experiencing the same problem.  I thought it might have something to do with my ultrawide monitor, but even changing the resolution does not work.  Sometimes I can get minor functionality by finding the sweet spot and moving with middle mouse button, but even that freezes after a while.  


Short video example

Link to comment
Share on other sites

  • 0



I suffer from the same problem, but apparently only since about Wednesday (in this extent).

One think that significantly helps (from a Steam forum post):

- Select a character portait within the game with no Ui open (left or right dependent on your UI layout)

- right click on the AI - button which hovers atop the party portraits

- the bahviour editor opens and e.g. condition selector items should be clickable



Iopen e.g. the Inventory

select a character

click the behaviour button below the portrait

click on "Edit behaviour"

click on a existing behaviour or create a new one

click on a condition (e.g. "always true" on a new bwehaviour set)

you are only able to click some of the items (upper two items, some in the middle), scroll bar ist not always working.


I guess the underlying window is still active somehow. But (in contrast to Pillars I) Ui Windows are not freely moveable. Reducing font size does not reduce UI size.

I tried to change "Windowed" to "Fullscreen" and lowered font size without success. However, above workaround to open AI Editor from party panel worked.

Link to comment
Share on other sites

  • 0

Still experiencing this issue in 2.1.


Can we get an official response? How can we get this fixed?



here is the video about what I am experiencing: 

This exact same thing is still happening to me. Is there an available fix to this yet?


Link to comment
Share on other sites

  • 0

Hey everyone,


I just got an email forwarded to me asking for an update on this.  This issue was supposed to have been fixed so I just checked it out again due to the email.  For me it looks like the change fixed a large portion of the issue, but I am seeing a couple of smaller sections where the layering is still an issue.  I reassigned it to the Programming team for a fix so that they can get this completely fixed up.


The bigger question to me is if this issue is still as bad for you as it once was for me, because after the patch it has been improved about 98% in my case(it was barely usable for me before).


Thanks, and sorry for the bug still being present.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...