Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

[BUG][1.2.0] AI Behavior editor is unclickable.

BUG 1.2.0

  • Please log in to reply
10 replies to this topic

#1
hekiller

hekiller

    (1) Prestidigitator

  • Members
  • 6 posts

This happened once I installed the 1.2.0 patch.

 

AI behavior editor is very slow and lots of the buttons(like in the conditionals menu) became unclickable.



#2
Cdiaz

Cdiaz

    Community Support Specialist

  • Developers
  • 1855 posts

Hello hekiller,

 

Thank you very much for posting! We have this issue logged currently as a high priority issue to fix in an upcoming patch.

 

In the meantime, would you mind getting me a video of the issue if possible? I do have the matter entered myself, I just want to be sure I have every instance of this bugged to support you guys.

 

Best,

 

-Caleb



#3
vadriel

vadriel

    (0) Nub

  • Initiates
  • 2 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Not sure if this helps but I am experiencing the same problem.  I thought it might have something to do with my ultrawide monitor, but even changing the resolution does not work.  Sometimes I can get minor functionality by finding the sweet spot and moving with middle mouse button, but even that freezes after a while.  

 

Short video example



#4
blacklionisd

blacklionisd

    (0) Nub

  • Initiates
  • 2 posts
  • Steam:eMaRDi

Hi,

 

I suffer from the same problem, but apparently only since about Wednesday (in this extent).

One think that significantly helps (from a Steam forum post):

- Select a character portait within the game with no Ui open (left or right dependent on your UI layout)

- right click on the AI - button which hovers atop the party portraits

- the bahviour editor opens and e.g. condition selector items should be clickable

 

Reproduction:

Iopen e.g. the Inventory

select a character

click the behaviour button below the portrait

click on "Edit behaviour"

click on a existing behaviour or create a new one

click on a condition (e.g. "always true" on a new bwehaviour set)

you are only able to click some of the items (upper two items, some in the middle), scroll bar ist not always working.

 

I guess the underlying window is still active somehow. But (in contrast to Pillars I) Ui Windows are not freely moveable. Reducing font size does not reduce UI size.

I tried to change "Windowed" to "Fullscreen" and lowered font size without success. However, above workaround to open AI Editor from party panel worked.



#5
LDawg

LDawg

    (0) Nub

  • Initiates
  • 3 posts
  • Deadfire Backer

Hey I also have this issue. 

 

Running Osx 10.11.6 on a late 2013 Macbook Pro.  

 

But blacklionisd's solution worked for me! Thanks friend!!



#6
Promethea

Promethea

    (0) Nub

  • Initiates
  • 4 posts

I am having a lot of issues with the AI editor as well. I am going to record a crappy video with my phone. hold on. 



#7
Promethea

Promethea

    (0) Nub

  • Initiates
  • 4 posts

here is the video about what I am experiencing: 



#8
Baron821

Baron821

    (0) Nub

  • Initiates
  • 1 posts

here is the video about what I am experiencing: 

This exact same thing is still happening to me. Is there an available fix to this yet?



#9
arst

arst

    (0) Nub

  • Initiates
  • 2 posts
  • Lords of the Eastern Reach Backer

Still experiencing this issue in 2.1.

 

Can we get an official response? How can we get this fixed?

 

 

here is the video about what I am experiencing: 

This exact same thing is still happening to me. Is there an available fix to this yet?

 



#10
arst

arst

    (0) Nub

  • Initiates
  • 2 posts
  • Lords of the Eastern Reach Backer
Bump

#11
SChin

SChin

    Product Services Manager

  • Developers
  • 851 posts
  • Location:Irvine, CA

Hey everyone,

 

I just got an email forwarded to me asking for an update on this.  This issue was supposed to have been fixed so I just checked it out again due to the email.  For me it looks like the change fixed a large portion of the issue, but I am seeing a couple of smaller sections where the layering is still an issue.  I reassigned it to the Programming team for a fix so that they can get this completely fixed up.

 

The bigger question to me is if this issue is still as bad for you as it once was for me, because after the patch it has been improved about 98% in my case(it was barely usable for me before).

 

Thanks, and sorry for the bug still being present.







Also tagged with one or more of these keywords: BUG, 1.2.0

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users