Jump to content
  • 0
purluno

[Input Device] Mouse click doesn't work mostly

Question

1. A brief summary of the bug.

 

Most click failed to interact with Game UI.

2. A screen shot of the bug.

 

YouTube:



3. Detailed steps of how to reproduce the bug.

 

1) Start the game

2) Click

4. A save file from before the bug occurred.*

 

None

5. An output.log file.**

 

See an attached file

 

output_log.txt

  • Like 9

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Same problem. Sometimes clicking works fine, sometimes I need to click 4-5 times. 

W10, 16gb Ram, i7 4930k, 1080ti, 2 monitors at 2560x1440. Happens in both Fullscreen and Windowed.

 

Some things I noticed:

 

It never happens for the movement clicks. Moving works 100% of the time, ship or on ground.

It can happen in all menu clicks, settings, conversation, leveling, combat, etc.

Sometimes the buttons depress like I'm holding left click, but not always.

Slow clicking (holding for a half second before releasing) seems to help, but that could be placebo.
It takes a few minutes to start having problems after starting the game (I never see it within the first minute or 2 of loading the game, but I've not restarted enough to debunk that)
 
Will test disabling Steam overlay and post my findings.
 
Also, I would upload my output_log, but it's 2,011 KB and exceeds the upload limit here and on pastebin. If it's needed, let me know how you'd like me to share it.
 
Thanks.
 
EDIT: Disabling Steam Overlay seems to have resolved the issue for me as well.
Edited by Sorekaz2

Share this post


Link to post
Share on other sites
  • 0

Same problem, happen not only on clicks but i think on keyboard buttons too, sometimes they don't respond. Also in combat when i am trying to select a character, it's often drags the portrait instead like if i hold the button.

Very annoying bug.

 

UPD: Confirming that disabling steam overlay is a workaround! 

Edited by Hartgroove

Share this post


Link to post
Share on other sites
  • 0

Logged in just to post this. This is the only bug I've experienced after 3 hours of playing. Using full screen or window doesn't seem to help.

Share this post


Link to post
Share on other sites
  • 0

Turning off the Steam overlay fixes it for me as well.

 

Bit annoying since I like using the built-in frame counter, but there's always Fraps.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'm facing this too.  I'd say about 20% of my clicks are "lost."  They either disappear entirely or they cause mouse0 to be locked down, and I can click again to try to release it.

 

I noticed this happens with keyboard input too, e.g. when typing my character name - about 20% of keys were lost.

 

I'm playing in English (no IME) on Windows 7.  I have a 4k display but run PoE at 1080p, in fullscreen.  I've had Steam overlay enabled so far, but would be fine turning it off for now.  Output log attached.

output_log.txt

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Not sure if this is in the same vein, but...

 

I was having issues with renaming my character from the vanilla "Watcher" during creation; the mouse would not click in the box and/or the text was never highlighted.  Turned off the Steam overlay as suggested, and now I can click in the box and the text is immediately highlighted.  

Not sure if this is in the same vein, but...

Share this post


Link to post
Share on other sites
  • 0

Yep! Disable the Steam Overlay in the Steam Settings and it'll fix this issue. I came here looking for a fix because I was having the same problem - thanks guys!

 

mPOghrs.png

  • Like 4

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

I was struggling with the issue and doing the following seemed to have fixed it for me.   I had been using dual keyboards with microsoft IME (Korean and English)

 

Start -> Edit Language and Keyboard Options

1) Make sure English is set to default.

2) REMOVE foreign language keyboard(s). Annoying, I know, but this is what fixed it for me. Just a temp fix until Obsidian can fix the issue.

 

I restarted my computer just in case, and the game runs perfectly now. No mouse click errors.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Yep! Disable the Steam Overlay in the Steam Settings and it'll fix this issue. I came here looking for a fix because I was having the same problem - thanks guys!

 

 

FYI, you can disable the overlay just for this game: Right click PoE II in your games list, select properties, and then uncheck "Enable Steam Overlay while in-game."

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Very often the left click of the mouse does not work anymore, even in the menus (I can not even leave the game without alt-F4). I play 21: 9 for info...

 

I also noticed that if I change my game zone it works well ... for a while.

 

Edit :

I'll try to disable Steam Overlay to see what happen !
Edited by BillyCorgan

★ ★ ★ ★ ★ ★ ★ ★ ★ I ' M ★  ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ B L A C K S T A R   ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ 

Share this post


Link to post
Share on other sites
  • 0

Tested some cases.

 

output_logs.zip

 

1. windowed mode

 

clicks mostly not working

 

2. fullscreen mode

 

same as above

 

3. disabled the Steam Overlay

 

same as above

 

4. switching between the English IME and the Korean IME (using alt + left shift)

 

No problem only when switching to the English IME, at least in a short period

 

---

 

I hope this bug is fixed soon!

 

Share this post


Link to post
Share on other sites
  • 0

I wrote a separate thread about a similar problem and it is kinda related to this, but for me it's not problems with the UI but in-game. I can select an ability but when I click on an enemy for example nothing happens, it does not register the click.

 

I've come 5 hours into the game just letting the characters do their AI thing but now there's a harder fight and the game is thus unplayable for me atm.

 

I've tried the suggestions in this thread, the problem persists.

Edited by beatspores
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I tried fullscreen and windowed, I still get it. Tried every graphics option I could think of as well, including disabling vsync etc.

It's definitely counting single clicks as a "click and hold" at times, for instance it causes me to drag character portraits when I try to select a character. Usually a double click handles it.

It happens in gameplay/options menu/the little drawn cutscenes, you name it.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Heya everyone,

 

Sorry you're all going through this. We're trying to pin this one down. Quick question: are you guys using a non-english IME in Windows?

 

We'll get to the bottom of this don't worry!

 

I'm using regular english/US windows 10 and getting this click madness.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Same problem. Multiple monitors. Clicks seem to only half work? The buttons get depressed yet do not actually click the button. A second click works.

Also have multiple monitor setup (3 screens) with one having different resolution and being flipped 90 degrees. Dedicated fullscreen seems to have fixed the issue for me so far.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Disabled the Steam Overlay works for me. TY for the tip.

  • Like 1

★ ★ ★ ★ ★ ★ ★ ★ ★ I ' M ★  ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ B L A C K S T A R   ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ ★ 

Share this post


Link to post
Share on other sites
  • 0

Yep! Disable the Steam Overlay in the Steam Settings and it'll fix this issue. I came here looking for a fix because I was having the same problem - thanks guys!

 

mPOghrs.png

 

It isn't necessary to disable it for all games. Just right-click on PoE2 in the games list, select "properties", and from the General tab uncheck "Enable the Steam overlay in game".

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Same Problem popping up for me from time to time. IME is german. Will try it with disabled Steam Overlay.

I would upload the output log, but the damn file has like 17MB which can't be good, so i'm just putting the last few errors here (they're all pretty similar):

 

 

 

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.SetEnabled (Boolean state) [0x00000] in :0
at Game.UI.UIMultiSpriteImageButton.SetEnabledHelper (Boolean state) [0x00000] in :0
at Game.UI.UIMultiSpriteImageButton.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.SetEnabled (Boolean state) [0x00000] in :0
at Game.UI.UIMultiSpriteImageButton.SetEnabledHelper (Boolean state) [0x00000] in :0
at Game.UI.UIMultiSpriteImageButton.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.UI.UIImageButtonRevised.get_MousedColor () [0x00000] in :0
at Game.UI.UIImageButtonRevised.NotifyModeChanged () [0x00000] in :0
at Game.UI.UIImageButtonRevised.OnyxDisable () [0x00000] in :0
at Onyx.OnyxBehavior.OnDisable () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.Item.GetSpriteIcon () [0x00000] in :0
at Game.InGameHUD.SetWidgetIcon (.UITexture texture, .UISprite sprite, IIcon iconSource) [0x00000] in :0
at Game.UI.UIInventoryBaseGridItem.RefreshIconBase () [0x00000] in :0
at Game.UI.UIInventoryBaseGridItem.RefreshIcon () [0x00000] in :0
at Game.UI.UIInventoryGridItem.RefreshIcon () [0x00000] in :0
at Game.UI.UIInventoryBaseGridItem.Block () [0x00000] in :0
at Game.UI.UIInventoryShipEquipment.LoadItem (Game.UI.UIInventoryGridItem grid) [0x00000] in :0
at Game.UI.UIInventoryShipEquipment.Reload () [0x00000] in :0
at Game.UI.UIInventoryShipEquipment.OnSelectedObjectChanged () [0x00000] in :0
at Game.UI.UIInventoryShipEquipment.OnyxDestroy () [0x00000] in :0
at Onyx.OnyxBehavior.OnDestroy () [0x00000] in :0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Game.Item.GetSpriteIcon () [0x00000] in :0
at Game.InGameHUD.SetWidgetIcon (.UITexture texture, .UISprite sprite, IIcon iconSource) [0x00000] in :0
at Game.UI.UIInventoryBaseGridItem.RefreshIconBase () [0x00000] in :0
at Game.UI.UIInventoryBaseGridItem.RefreshIcon () [0x00000] in :0
at Game.UI.UIInventoryGridItem.RefreshIcon () [0x00000] in :0
at Game.UI.UIInventoryBaseGridItem.Block () [0x00000] in :0
at Game.UI.UIInventoryShipEquipment.LoadItem (Game.UI.UIInventoryGridItem grid) [0x00000] in :0
at Game.UI.UIInventoryShipEquipment.Reload () [0x00000] in :0
at Game.UI.UIInventoryShipEquipment.OnSelectedObjectChanged () [0x00000] in :0
at Game.UI.UIInventoryShipEquipment.OnyxDestroy () [0x00000] in :0
at Onyx.OnyxBehavior.OnDestroy () [0x00000] in :0

(Filename: Line: -1)
 

 

 

 

Update: Disabled Overlay, and it seems to be fixed.

Edited by dasdrache

Share this post


Link to post
Share on other sites
  • 0

I have a similar problem with the mouse clicks and figured I'd check the forum to see if I'm the only one. Looks like I'm not. To be clear, I can click on menus and objects, but it usually takes at least two or three of them to register, and that's very frustrating when in combat for example. I'm using windowed mode so I'll check the fullscreen to see if it persists. Thanks for being on top of things, gentlemen!

 

 

 

 

Edit: I turned off the overlay and the mouse clicks are registering as they should.

Edited by vetiver

Share this post


Link to post
Share on other sites
  • 0

It happened to me too. No input from mouse. Quick save, quit game, launch again solve the problem. For 18 hours only 2 times, but I remember this issue from the beta.

 

Also often I can't extend dialog history during the conversation. Button at the upper center of the windows doesn't seem to work most of the time.

  • Like 1

giphy.gif

Share this post


Link to post
Share on other sites
  • 0

I've been having the same issue and I might have found a possible solution.

 

For me, disabling in-game steam overlay did the trick. Haven't had any mouse issues after that.

 

I hope this helps.

Thanks for the tip! It was really annoying me!

Share this post


Link to post
Share on other sites
  • 0

Thanks for the tip of disabling the overlay. Made me a very happy person. It was starting to really irritate me. I just clicked around on things for like 5 minutes feeling the joy of the game responding to my clicks.

 

I feel for the rest of you that that doesn't fix the problem for!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...