Jump to content
  • 0
pagulhan

[3.01] Weapon and shield keep disappearing

Question

Every few hours weapon and shield of my main character disappear from in-game view, although they are still visible in the inventory. As you can see in the left side of the picture, my char has no weapon and no shield. He also cannot attack (both set AI and manual order don't work). It happened a few times to the other charaters as well but mostly to my char.

 

btw How do you upload images? It says I'm not allowed to use .jpg file on this community oO

 

http://postimg.org/image/5swpg3r5p/

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hey pagulhan,

 

Could you upload a save file and an output log so I can take a look? 

 

Thanks!


Whats this at obsidian.net?

Share this post


Link to post
Share on other sites
  • 0

I've had this happen to me too but reloading usually fixes it. Seems to be erratic; very hard to repro.


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

I got this as well. Switching weapons will fix it for me. It happens erratically for me. If I see it, I'll upload the save.

Share this post


Link to post
Share on other sites
  • 0

I'm having similar issues as well. Items in my inventory seem to disappear, but if you mouse over the inventory slot a tooltip will pop up showing the item is there. Reloading usually fixes the problem. Something that seems to be related (another graphical glitch) is I'm getting random black boxes showing up on the screen that are stationary relative to the world, i.e. if I scroll the screen the black boxes move with the rest of the world. They even show up on the map screen. Again, reloading fixes.

Share this post


Link to post
Share on other sites
  • 0

I am not a developer so maybe i dont understand some things but wtf guys? How the hell can anyone introduce compleately new bugs in version 3.0x? This is first time it happened in this game. Do the creators do a complete game mechanics overhaul each time they patch it? Because its only way i know to introduce some buvs that we are seeing now...

Share this post


Link to post
Share on other sites
  • 0

I'm having the same issue.

 

Actually it's my medium shield who's just gone. I can see it in inventory and its bonus applies. But when i close the inventory i can't see on my character on the screen. I tried several shields on several characters. It seems it's on ly the medium shields which are concerned, no matter which character.

 

Other shields are fine. Reloading or restarting the game does NOT fix this.

Share this post


Link to post
Share on other sites
  • 0

I've been digging this bug and found that it affects only medium shields which description mentions "this shield have been used by a xaurip".

 

I'm not sure what is the problem though, because i can equip it in the inventory screen.

It seems to me that for some reason i shouldn't be able to equip it and that these shields are meant only to be sold ? Anyway that's the only explanation i could think of, and there is definetely something not ok here. Not game breaking of course, but still annoying.

 

I'm playing with version 3.02.

 

Also excuse my poor english, i'm french.

Share this post


Link to post
Share on other sites
  • 0

I'm having the same issue.

 

Actually it's my medium shield who's just gone. I can see it in inventory and its bonus applies. But when i close the inventory i can't see on my character on the screen. I tried several shields on several characters. It seems it's on ly the medium shields which are concerned, no matter which character.

 

Other shields are fine. Reloading or restarting the game does NOT fix this.

 

Heya Palanthis,

 

We had a bug with all shields/equipment that would cause them to disappear (only visually) if you equipped them in the same scene that you looted them from while examinables were toggled on. This should have been fixed in 3.02, but it seems to be happening still for shields looted from Xaurips.

 

I'll write up a report and pass it on. =)

 

Thanks!


I try my very best.

Share this post


Link to post
Share on other sites
  • 0

I'm digging this out again – I can confirm and give slightly more detailed facts.

 

I'm playing the current version of the game, 3.05, and am not working with the console nor have I any mods installed.

 

Affected are all (so far) Medium Shields (Heater) that have been looted from Xaurips.

They show up on the dummy in inventory, the stats are listed, but out of inventory and back in the world, the character doesn't wield a shield visually.

 

That also applies to the Xaurips itself, which I noticed only recently: no xaurip, no champion wields his shield.

 

I tested with interactables not permanently highlighted and an area change, before equipping – the shield remains unvisible.

 

 

Addendum: Shields, found on Human Skeletons, work fine.

Edited by compleCCity

Share this post


Link to post
Share on other sites
  • 0

I'm digging this out again – I can confirm and give slightly more detailed facts.

 

I'm playing the current version of the game, 3.05, and am not working with the console nor have I any mods installed.

 

Affected are all (so far) Medium Shields (Heater) that have been looted from Xaurips.

They show up on the dummy in inventory, the stats are listed, but out of inventory and back in the world, the character doesn't wield a shield visually.

 

That also applies to the Xaurips itself, which I noticed only recently: no xaurip, no champion wields his shield.

 

I tested with interactables not permanently highlighted and an area change, before equipping – the shield remains unvisible.

 

 

Addendum: Shields, found on Human Skeletons, work fine.

 

Same here.


It would be of small avail to talk of magic in the air...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...