Jump to content
  • 0
AlphaMagnum

Difficulty Bugs

Question

I select Hard difficulty but when moving through the introduction sequence the enemy density seems to fit "Easy" or "Normal" instead.

 

There's 1 Archer and 2 Huntresses by the tree on Hard, and 4 total enemies with Heodan back at camp as well.

 

Despite choosing Hard, sometimes there's just 1 archer and no one else by the tree, and just 2 enemies back at camp. I'm guessing this represents a lower difficulty setting which has somehow been activated without my knoedge.

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

Addendum - this occurs unpredictably. The same save from around when you kill the wolves for the springberry can lead to either Hard enemy density or abnormally low enemy density. I haven't been able to pin down what is causing this issue.

Share this post


Link to post
Share on other sites
  • 0

I've also had this issue occur regularly (though again, inconsistently). I saw a Steam thread that proposed it was an issue with Macs going between full and windowed mode but I don't think that's it. It can also skewer a Path of the Damned game because you can't change back to PoTD once you are reset to Easy.

 

Didn't see anything referring to it explicitly in the patch log today... I couldn't get it to happen just now but I'm basically resigned to not playing until it's fixed.

Share this post


Link to post
Share on other sites
  • 0

I'm on a 2014 Macbook Pro. This has started happening to me constantly. Around the same time this began happening, I started using CMD+F to go into windowed mode, because I can't alt-tab out of the game. This bug could be related to entering windowed mode.

Share this post


Link to post
Share on other sites
  • 0

I will add a little more info about this. Basically, I start a game on Path of the Damned/Trial of Iron. I'm working my way through the prologue. At some point, I will notice I'm killing things very easily or there aren't as many enemies as there should be. So I check the difficulty setting and it will say Path of the Damned. But if I save and quit, then reload the game, when I check the difficulty again it says easy.

 

I played the game for about four hours last night and I was constantly going between windowed and full-screen. I restarted the game a couple times and at least half the times this bug would occur. It probably happened four times. I am 90% sure it happens whenever I switch from full-screen to windowed mode (or vice versa, I'm not sure). 

 

I have since stopped switching window modes and it hasn't happened.

Share this post


Link to post
Share on other sites
  • 0

I will add a little more info about this. Basically, I start a game on Path of the Damned/Trial of Iron. I'm working my way through the prologue. At some point, I will notice I'm killing things very easily or there aren't as many enemies as there should be. So I check the difficulty setting and it will say Path of the Damned. But if I save and quit, then reload the game, when I check the difficulty again it says easy.

 

I played the game for about four hours last night and I was constantly going between windowed and full-screen. I restarted the game a couple times and at least half the times this bug would occur. It probably happened four times. I am 90% sure it happens whenever I switch from full-screen to windowed mode (or vice versa, I'm not sure). 

 

I have since stopped switching window modes and it hasn't happened.

 

I'm having the same problem, but I never switch between screen modes. Anyone seen any work arounds?

 

Start a game in Hard, but the number of enemies is clearly on Easy. For example, the mobs on the starting map just before the dialog encounter at the camp. No matter what difficulty I set, there's only the one. Used to be many more on Hard/PotD.

Share this post


Link to post
Share on other sites
  • 0

Addendum -- changing the difficulty from Hard to Easy (and vice versa) has no effect whatsoever on enemy composition.

 

The Maerwald fight when completing The Old Watcher quest ought to have 1 Flame Blight on Easy/Normal, 2 Flame Blights on Hard, and 3 Flame Blights on Path of the Damned from what I understand.  Regardless of what difficulty I choose (Easy/Normal/Hard), I only ever get 1 Flame Blight in that fight.

 

How can I fix this?

 

EDIT -- Used IEMod's exposed console command "SwitchPotD" to attempt to force the game onto Path of the Damned difficulty.  Nothing changed.  Now I'm very confused.

Edited by AlphaMagnum

Share this post


Link to post
Share on other sites
  • 0

I select Hard difficulty but when moving through the introduction sequence the enemy density seems to fit "Easy" or "Normal" instead.

 

There's 1 Archer and 2 Huntresses by the tree on Hard, and 4 total enemies with Heodan back at camp as well.

 

Despite choosing Hard, sometimes there's just 1 archer and no one else by the tree, and just 2 enemies back at camp. I'm guessing this represents a lower difficulty setting which has somehow been activated without my knoedge.

Hey guys,

I was able to reproduce the lower difficulty issue and have written a bug report for it. Thanks for bringing this to our attention! 


Got a bug :cat:?? Help us squish it!

  • In your report Include your *save file* (C:\Users\YourNameHere\Saved Games\Pillars of Eternity) and ...
  • PC: *output_log.txt* (In your PillarsOfEternity_Data folder)
  • Mac/Linux: *Player.log* (In your Unity folder)

  • Thank you for your help!

Share this post


Link to post
Share on other sites
  • 0

That's great to hear. I seriously appreciate the communication. Please let us know if you would like any further information from our end, or if the team discovers some kind of temporary solution which we can implement before an official patch rolls out.

Share this post


Link to post
Share on other sites
  • 0

So I couldn't help myself, and despite saying that I'd hold off on playing further until this got fixed, I went ahead and killed off my saves until I found one (2 hours previously) which was not experiencing this bug.  I proceeded to continue on that save and so far (2 battles -- Raedric fight and Will O Wisps @ start of Temple of Eothas) the game has maintained an appropriate enemy density.

 

It looks like something is definitely going wrong with save files since there was nothing I could do to fix the issue on saves which were experiencing it.  I did not try uninstalling and reinstalling the game but that's a lot to ask for in order to fix a non-gamebreaking bug.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...