Jump to content
  • 0
Cirventhor

UI Scaling - blurry font

Question

When running higher resolutions than 1080p, the interface seems to be scaled. This makes the UI elements, particularly the font, fairly blurry.

On my 1920x1200 monitor I've had to bump down my resolution to 1080p to get crisp fonts. Is it possible to disable the scaling of the UI so it runs at it's default size even when using higher resolutions?

  • Like 2

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hi. This is a known issue that was reported in the backer beta as well.

 

Hopefully it will get fixed in the first patch. Particularly the font should be always crisp at all resolutions in such a text-heavy game.

  • Like 1

"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

Moved to support as per Cirventhor's wishes.  Good luck and happy gaming!

  • Like 1

Fionavar's Holliday Wishes to all members of our online community:  Happy Holidays

 

Join the revelry at the Obsidian Plays channel:
Obsidian Plays


 
Remembering tarna, Phosphor, Metadigital, and Visceris.  Drink mead heartily in the halls of Valhalla, my friends!

Share this post


Link to post
Share on other sites
  • 0

thanks for the tip. I was very disappointe by the bluriness of the whole UI, not just the text.

 

Setting the resolution to 1080p fixed that for me, unfortunately I see the windows mouse icon when I move the cursor outside of the game content. The "cage cursor" option doesn't help.

 

This also makes scrolling with the mouse tedious because I have to keep the cursor just inside the game content to be able to scroll.

 

Also, which is a lot more annoying, the Steam Overlay gets "stuck" in the black bars at the top and the bottom of the game. Alt-tabbing out of the game fixes this temporarily.

 

(I am using a Radeon graphics card with the newest drivers).

post-51437-0-67068400-1427406750_thumb.jpg

Edited by physicalist

Share this post


Link to post
Share on other sites
  • 0

I ended up actually connecting an old 1080p monitor that was laying about.

 

Probably the best way to handle it until Obsidian patches things up.

Share this post


Link to post
Share on other sites
  • 0

thanks for the tip. I was very disappointe by the bluriness of the whole UI, not just the text.

 

Setting the resolution to 1080p fixed that for me, unfortunately I see the windows mouse icon when I move the cursor outside of the game content. The "cage cursor" option doesn't help.

 

This also makes scrolling with the mouse tedious because I have to keep the cursor just inside the game content to be able to scroll.

 

Also, which is a lot more annoying, the Steam Overlay gets "stuck" in the black bars at the top and the bottom of the game. Alt-tabbing out of the game fixes this temporarily.

 

(I am using a Radeon graphics card with the newest drivers).

You can work around this by setting your desktop resolution to 1920x1080 before starting the game.

Share this post


Link to post
Share on other sites
  • 0

I also have the same problem with the blurry text. I'm running the game at 2560x1440 which is the native res of my display.

 

Switching to 1080p doesn't solve anything, since the image is automatically upscaled by the GPU/display, and then everything is blurred (not just the text).

 

In such a text-heavy game this issue should be fixed as soon as possible. In BG:EE and BG2:EE, for example, the text is crystal clear at 1440p.

 

Let's hope they get it fixed in the next patch.

  • Like 4

Share this post


Link to post
Share on other sites
  • 0

I don't think font scaling is an easy fix, but it certainly would be great to have.

 

Playing at 2560x1600, it's the biggest concern I have that hasn't already been addressed or slated for next week's patch. All the 2D content is beautifully rendered save for the text. I've tried scaling it down using the Font Scale option, but it still has sampling artifacts.

Share this post


Link to post
Share on other sites
  • 0

I hope the font will be fixed soon! Playing on 1440p... my eyes get tired pretty soon reading the blurry text.

Edited by madPav3L
  • Like 4

Share this post


Link to post
Share on other sites
  • 0

Certain icons and UI elements scale worse than others, apparently.

 

The Chanter's UI, for example, looks very pixellated at 2560x1440 ... same for most helmet icons.


"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

On a closer look it appears to also affect the 3D character preview window in-game as well as in character generation. So it's the entirety of the UI that gets upscaled/interpolated and thus blurry.

Share this post


Link to post
Share on other sites
  • 0

I really wish the UI wouldn't upscale on higher resolutions. I can somewhat handle the blurry icons, but the blurry text is horrible to read, esp. in a game that's all about reading dialogue.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Registered to confirm this issue. As a 1440p monitor user, i'm also having trouble enjoying the game fully because of the blurry scaling (a game that has been excellent for me except for this problem). 

 

Has anyone from Obsidian recognized the issue, seeing that apparently this was an issue since backer beta?

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

Give manual scaling slider for menus, maybe? I dunno. What I do know is what others have expressed. In a game so heavilty text based. This blurry, interpolated text is not easy on the eyes... at all.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Yes UI scaling would be useful. I cant play at best resolution because of stutter, but then it becomes large and blurry. It should be scaled down to remain crispy.

Edited by Striped_Wolf

Share this post


Link to post
Share on other sites
  • 0

Sooo, looking at the patch notes for 1.03, nothing changed when it comes to UI scaling, and no word from Obsidian. A shame. Think i might hook up a 1080p panel from another room instead of hoping for any relief on this.

Share this post


Link to post
Share on other sites
  • 0

Maybe it will be fixed in a future patch, but I don't get my hopes up too much because I read somewhere that this issue has been around since the Beta.

 

Since I don't have a spare 1080p display, I tried disabling Scaling in the nVidia Control Panel, in other to prevent the GPU from automatically upscaling the image to 1440p. It works fine with most other games, but for some reason it doesn't work with PoE: the game is upscaled anyways :-(

Share this post


Link to post
Share on other sites
  • 0

Yeah... I tried nVidia Dynamic Super resolution if it helps but with no improvement.

It's up to Obsidian to do something with it...

Share this post


Link to post
Share on other sites
  • 0

As said before, this issue might take a long while before it gets addressed, as it is seen as low priority. Most of us will have long finished the game by the time this gets resolved. Very unfortunate. 

Share this post


Link to post
Share on other sites
  • 0

If blurry text is considered low priority, in a game that primarily conveys it's story with text. I don't even want to know what else is considered low prio tbh..

Edited by Asmodean-
  • Like 4

Share this post


Link to post
Share on other sites
  • 0

Would be nice to hear from a dev about this as it is still an issue (apparently not fixed by the upcoming 1.4 patch).

  • Like 1

"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke

Share this post


Link to post
Share on other sites
  • 0

I confirm that with latest Nvidia drivers 350.12 text and interface became blurry, had to reset resolutions to fix it.

Edited by oldschool

Share this post


Link to post
Share on other sites
  • 0

The upscaling is fixed for the most part for 1920x1200 in the current Beta (1.05, Steam). Only minor problems remain.

 

There doesn't seem to be proper text scaling for resolutions higher than 1920x1200, though.

Edited by physicalist

Share this post


Link to post
Share on other sites
  • 0

I wish they would say something about this issue... even that they are not going to fix it. Anything would be better than this silent.

Share this post


Link to post
Share on other sites
  • 0

The upscaling is fixed for the most part for 1920x1200 in the current Beta (1.05, Steam). Only minor problems remain.

 

There doesn't seem to be proper text scaling for resolutions higher than 1920x1200, though.

 

Christ, why for the love of god don't they just allow the option to disable UI scaling. I understand that redesigning or rerendering the UI assets to cater to the niche resolutions won't happen (i play at 1440p). But it really can't be that hard to just allow people that don't want abysmal blurry UI and text, to just disable the scaling altogether?

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...