Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

For the love of Luminious Adra - Stop Auto Attacking!


  • Please log in to reply
23 replies to this topic

#1
Tawmis

Tawmis

    (2) Evoker

  • Members
  • 95 posts

Okay - so I beat the game already with my ranger and his wolf companion... So I thought I'd try something different. I'd go for a spell casting type - like a Druid (it's one step away from a Ranger). Now.. the problem I am having is - when combat starts, I am clicking on the foe to tell the party to attack - my druid is running up there - whether he has swords or fists - to physically attack. I set his AI to "Cautious Druid" and "Passive" - so I figured he would NOT attack. This would give me an opportunity during combat to try some spells (which I never even used with my Ranger... literally did Ranger originally to have my wolf companion). But no matter what - my Druid rushes into combat. The only way I've gotten around this is - clicking the target - then clicking my druid (so only he's selected), click away from direct melee, then click him again to cast a spell - and oh, look. The party already killed the monster. :(

 

From time to time, when my druid shifts to bear form and gets knocked out - he stands up (before combat is over) - as if he were "alive" - but can't do anything. (Similar to monsters/mobs you kill, who die - but stay standing up). But this happens so randomly, it's nearly impossible to replicate to see exactly what's causing it.

Attached Files



#2
TheMetaphysician

TheMetaphysician

    (4) Theurgist

  • Members
  • 391 posts
  • Deadfire Backer
  • Fig Backer

If you have your party selected and click on a foe to attack it, that overrides the AI -- you've just commanded an attack. Is that what you are doing? If so, you shouldn't be surprised. If you don't want him to attack, don't tell him to attack, and his AI will take over.


  • Tawmis, Karkarov, Ichthyic and 5 others like this

#3
Big-Ben

Big-Ben

    (4) Theurgist

  • Members
  • 245 posts
  • Location:Desolation Row
  • Steam:Big Ben
  • Deadfire Silver Backer
  • Fig Backer
  • Black Isle Bastard!

I heard that it's also very effective to yell "DON'T ATTACK" at your monitor as loud as you can. Do this and everyone will act the way you want them to.


  • Volourn, DVSman, Tawmis and 11 others like this

#4
Casper

Casper

    (4) Theurgist

  • Members
  • 250 posts
  • Deadfire Backer
  • Fig Backer
  • Black Isle Bastard!

well, if you don't want him to run up and say hi to his enemies, but still want to order him to attack, maybe try a ranged weapon, like a rod or wand?


  • Tawmis, Suen, Karkarov and 3 others like this

#5
M4xw0lf

M4xw0lf

    (5) Thaumaturgist

  • Members
  • 495 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

If you want the AI behaviour to take over, simply sneek into detection range of the nearest enemy and then switch off stealth. All Party members will start doing what their AI tells them.


Edited by M4xw0lf, 01 June 2018 - 10:06 PM.

  • Tawmis, TheMetaphysician and Epimetreus like this

#6
Aotrs Commander

Aotrs Commander

    (4) Theurgist

  • Members
  • 201 posts
  • Location:Derby, UK and Bleak Despair battlestation
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

Turn his AI off and take direct control of him yourself...? Then we won't do anything unless you tell him to.

 

Maybe also turn the combat speed down a notch. I found with both Pillars games that default combat speed was too fast for me to really get what was going on,, and the slower speed actually enables me to more easily micromanage my party (when I want to) without having to turn on "pause on completion of action" of every few seconds. One notch down isn't like the fight is in slow motion or anything, not really.


  • Tawmis likes this

#7
Slotharingia

Slotharingia

    (5) Thaumaturgist

  • Members
  • 485 posts
  • Location:Germany
  • Deadfire Backer
  • Fig Backer

As has been mentioned above, unless you are wielding a ranged weapon in at least one hand, clicking on someone will make you attack them in melee. Or pick a spell and then select the target.

 

Turn his AI off and take direct control of him yourself...? Then we won't do anything unless you tell him to.

 

Maybe also turn the combat speed down a notch. I found with both Pillars games that default combat speed was too fast for me to really get what was going on,, and the slower speed actually enables me to more easily micromanage my party (when I want to) without having to turn on "pause on completion of action" of every few seconds. One notch down isn't like the fight is in slow motion or anything, not really.

 

How do you turn down combat speed?


  • Tawmis likes this

#8
Casper

Casper

    (4) Theurgist

  • Members
  • 250 posts
  • Deadfire Backer
  • Fig Backer
  • Black Isle Bastard!

As has been mentioned above, unless you are wielding a ranged weapon in at least one hand, clicking on someone will make you attack them in melee. Or pick a spell and then select the target.

 

Turn his AI off and take direct control of him yourself...? Then we won't do anything unless you tell him to.

 

Maybe also turn the combat speed down a notch. I found with both Pillars games that default combat speed was too fast for me to really get what was going on,, and the slower speed actually enables me to more easily micromanage my party (when I want to) without having to turn on "pause on completion of action" of every few seconds. One notch down isn't like the fight is in slow motion or anything, not really.

 

How do you turn down combat speed?

there's like this little clock/gears looking circular thing on the bottom center of your screen, there are a few small little buttons there. (sorry, i don't recall the keyboard commands off hand).

 

--- edit

here, hope this helps

Attached File  clock buttons.jpg   79.75KB   2 downloads

 

 


Edited by Casper, 02 June 2018 - 02:44 AM.

  • Tawmis, Suen, Porcelyn and 1 other like this

#9
Slotharingia

Slotharingia

    (5) Thaumaturgist

  • Members
  • 485 posts
  • Location:Germany
  • Deadfire Backer
  • Fig Backer

 

As has been mentioned above, unless you are wielding a ranged weapon in at least one hand, clicking on someone will make you attack them in melee. Or pick a spell and then select the target.

 

Turn his AI off and take direct control of him yourself...? Then we won't do anything unless you tell him to.

 

Maybe also turn the combat speed down a notch. I found with both Pillars games that default combat speed was too fast for me to really get what was going on,, and the slower speed actually enables me to more easily micromanage my party (when I want to) without having to turn on "pause on completion of action" of every few seconds. One notch down isn't like the fight is in slow motion or anything, not really.

 

How do you turn down combat speed?

there's like this little clock/gears looking circular thing on the bottom center of your screen, there are a few small little buttons there. (sorry, i don't recall the keyboard commands off hand).

 

--- edit

here, hope this helps

attachicon.gifclock buttons.jpg

 

Wow. Never noticed that. Thanks!


  • Tawmis likes this

#10
Wormerine

Wormerine

    Arch-Mage

  • Members
  • 3104 posts
  • Location:Belfast
  • Deadfire Backer
  • Fig Backer

How do you turn down combat speed?


Slider below “round pause thing in the middle of the UI” allows for slowing down/acccelerating combat. I found the thing a bit too fiddly so I recommend setting shortcuts for it in options.
  • Tawmis, Suen and Slotharingia like this

#11
Yosharian

Yosharian

    (8) Warlock

  • Members
  • 1185 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer

I'm not sure if English is not your first language but I can't tell what your initial steps are.

 

This: 

 

> Now.. the problem I am having is - when combat starts, I am clicking on the foe to tell the party to attack - my druid is running up there - whether he has swords or fists - to physically attack.

 

doesn't make grammatical sense.

 

I can come up with some strategies to help you, but only if I know exactly what you're doing at the start of combat.



#12
Tawmis

Tawmis

    (2) Evoker

  • Members
  • 95 posts

If you have your party selected and click on a foe to attack it, that overrides the AI -- you've just commanded an attack. Is that what you are doing? If so, you shouldn't be surprised. If you don't want him to attack, don't tell him to attack, and his AI will take over.

 

Ah, that makes sense... It's odd (because when I did my previous game, Aloth always stayed behind and cast spells)... But that's probably because...

 

well, if you don't want him to run up and say hi to his enemies, but still want to order him to attack, maybe try a ranged weapon, like a rod or wand?

 

... he always had a wand/rod in his hand. So that makes sense. I can't remember what my druid is equipped with (I think it's a dagger)... so that'd explain his blood lust of running up and wanting to poke people.

 

I heard that it's also very effective to yell "DON'T ATTACK" at your monitor as loud as you can. Do this and everyone will act the way you want them to.

 

I've tried this. You can even ask my wife. She will vouch for me. :D

 

If you want the AI behaviour to take over, simply sneek into detection range of the nearest enemy and then switch off stealth. All Party members will start doing what their AI tells them.

 

I think the ranged weapon thing will do the trick... going to try that now.

 

Turn his AI off and take direct control of him yourself...? Then we won't do anything unless you tell him to.

 

Maybe also turn the combat speed down a notch. I found with both Pillars games that default combat speed was too fast for me to really get what was going on,, and the slower speed actually enables me to more easily micromanage my party (when I want to) without having to turn on "pause on completion of action" of every few seconds. One notch down isn't like the fight is in slow motion or anything, not really.

 

By the Deadfire! I never noticed that little thing... I always thought it was decoration of the UI...!

 

I'm not sure if English is not your first language but I can't tell what your initial steps are.

 

This: 

 

> Now.. the problem I am having is - when combat starts, I am clicking on the foe to tell the party to attack - my druid is running up there - whether he has swords or fists - to physically attack.

 

doesn't make grammatical sense.

 

I can come up with some strategies to help you, but only if I know exactly what you're doing at the start of combat.

 

English is indeed my primary language... everyone else seemed to get what I was saying.

Essentially when I clicked attack - I want my druid to hang back and not rush up and either stab or melee punch the enemy.

The suggestion of a distance attack weapon is probably going to resolve my issue.

 

 


  • TheMetaphysician and Wormerine like this

#13
Masticator

Masticator

    (2) Evoker

  • Members
  • 61 posts
  • Deadfire Backer
  • Fig Backer

Yeah my guys with lighter armor I prefer to have ranged weapons like bows, crossbows, arquebuses, pistols, blunderbuss (though I can't stand these), rod, sceptor, or wand. I generally give this to my mages, druids, and priests, and rangers for obvious reasons. Ciphers and chanters I prefer to be ranged as well.

 

When combat starts I usually already have entire party selected and click on a foe to attack. And everyone will auto attack at the start and be focus fired on who I want. They usually eventually start using their abilities. But honestly for spell casters, I prefer to cast my own spells. They tend to cast stupid stuff, at least in POE 1 (I haven't really fully utilized the AI in POE 2 to comment on that yet)


Edited by Masticator, 02 June 2018 - 09:26 AM.

  • Tawmis likes this

#14
Casper

Casper

    (4) Theurgist

  • Members
  • 250 posts
  • Deadfire Backer
  • Fig Backer
  • Black Isle Bastard!

i usually pause & micromanage every few seconds. so for me it's usually something like pause. eder go over here knock this guys on his ***, move my character here attack this guy with flames of devotion, maia use wounding shot on that mage, and send your hawk to knock his boots off, aloth put a fireball here, adjust firezone about half way through casting, and xoti move here and cast a bit of healing. 

 

but to each his or her own.

 

---edit typo (just woke up)


Edited by Casper, 02 June 2018 - 01:36 PM.

  • Tawmis and Slotharingia like this

#15
Yosharian

Yosharian

    (8) Warlock

  • Members
  • 1185 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
So you're ordering your character to attack, and then you're complaining that your character is attacking? Forgive me, but this seems like a rather stupid complaint.

#16
indika_tates

indika_tates

    (2) Evoker

  • Members
  • 74 posts

I'm still wondering why dev's have not implemented a hold button to tell your dumb party members not to walk inside your own chilling fog. It would be nice. If I recall correctly I remember in BG's there was an option to do it.

 

Please, implement it someday it shouldn't be too hard to do.


  • Tawmis and Casper like this

#17
Casper

Casper

    (4) Theurgist

  • Members
  • 250 posts
  • Deadfire Backer
  • Fig Backer
  • Black Isle Bastard!

I'm still wondering why dev's have not implemented a hold button to tell your dumb party members not to walk inside your own chilling fog. It would be nice. If I recall correctly I remember in BG's there was an option to do it.

 

Please, implement it someday it shouldn't be too hard to do.

i usually resort to manually dragging them out of harms way, wish they wouldn't run right back into it though. 

 

--edit typo


Edited by Casper, 02 June 2018 - 10:02 PM.

  • Tawmis and Slotharingia like this

#18
Tawmis

Tawmis

    (2) Evoker

  • Members
  • 95 posts

Yeah my guys with lighter armor I prefer to have ranged weapons like bows, crossbows, arquebuses, pistols, blunderbuss (though I can't stand these), rod, sceptor, or wand. I generally give this to my mages, druids, and priests, and rangers for obvious reasons. Ciphers and chanters I prefer to be ranged as well.

 

When combat starts I usually already have entire party selected and click on a foe to attack. And everyone will auto attack at the start and be focus fired on who I want. They usually eventually start using their abilities. But honestly for spell casters, I prefer to cast my own spells. They tend to cast stupid stuff, at least in POE 1 (I haven't really fully utilized the AI in POE 2 to comment on that yet)

 

Yup! Equiping the Druid with a rod has stopped him from just charging into battle. But, by Adra's Illumination do spells take a long time to cast - even now that I am able to control my druid much better. Even those first level spells!

 

i usually pause & micromanage every few seconds.

 

I never did that the first time I played; because my ranger was fine rushing into battle. But playing a druid, I am finding that the pause trick is working better for trying to get spells cast...

 

I'm still wondering why dev's have not implemented a hold button to tell your dumb party members not to walk inside your own chilling fog. It would be nice. If I recall correctly I remember in BG's there was an option to do it.

 

Please, implement it someday it shouldn't be too hard to do.

I've been wondering why they're suicidal like that as well...

Also why - when a trap is spotted - they insist on still walking over it because I had clicked past the trap before it was spotted. You'd think they'd stop from walking across a spotted trap. :)

 

So you're ordering your character to attack, and then you're complaining that your character is attacking? Forgive me, but this seems like a rather stupid complaint.

 

I am not sure what you're missing (that everyone else picked up on) - but the issue was the druid was rushing into battle (and as I said, I never did the caster, so I wasn't sure why he was - despite setting the AI and what not to be passive) - and that I wasn't aware clicking the attack would over ride that AI. But your... feedback... is noted... and I am thankful other folks in the thread understood me quite clearly and helped me resolve the problem of me not understanding a specific mechanic to the game without coming across so... unique.
 


Edited by Tawmis, 02 June 2018 - 09:37 PM.


#19
Casper

Casper

    (4) Theurgist

  • Members
  • 250 posts
  • Deadfire Backer
  • Fig Backer
  • Black Isle Bastard!

i got used to playing chess, and old school strategy games. so basically i strategically position my party, and make all my initial moves at once, adjusting for time, as it might take longer for my melee characters to get into striking range, when compared to my mage casting spells or my ranger sniping.

 

in the original dragon age there was an achievement called tactician. to earn this you had to eliminate 250 enemies without any of your party members taking damage in the exchange. i miss achievements like that. 



#20
Slotharingia

Slotharingia

    (5) Thaumaturgist

  • Members
  • 485 posts
  • Location:Germany
  • Deadfire Backer
  • Fig Backer

i usually pause & micromanage every few seconds. so for me it's usually something like pause. eder go over here knock this guys on his ***, move my character here attack this guy with flames of devotion, maia use wounding shot on that mage, and send your hawk to knock his boots off, aloth put a fireball here, adjust firezone about half way through casting, and xoti move here and cast a bit of healing. 
 
but to each his or her own.
 
---edit typo (just woke up)

Okay back to my noob questions: How do you adjust a firezone half way through casting? If I try to change the landing asurface, they start the whole casting process again (and usually by the time they are done there is either no one there or the wrong people).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users