Jump to content
  • 0
Sign in to follow this  
LordFey

Option to reduce particles? Please?

Question

One thing I did encounter quite often in this game is that if I'm on a map/scene with a lot of particle effects (like fog, rain, biawac in the beginning, ...), the framerate drops tremendously. On native resolution (1920x1080) and AA off I run this game around 45-50 fps, but everytime the weather goes to rain for example I can be lucky if my fps stay above 30 fps. The same applies for scenes like the biawac in the beginning and every other "flashy" scene only that it goes down to like 19 fps and thats quite annoying in my opinion.

 

I don't know the exact reason for that, but I guess it has to do with the particles in the game and how they affect my CPU.

 

I'm curious if I'm the only one with this problem and I also wanna ask, if an option to turn down particle effect may solve it?

Edited by LordFey

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Yeah some effects are extremely particle heavy. I have had several spells that dropped my game to 3-4 FPS for several seconds (then back up to max).

A certain lightning attack from will'o'wisps, if I remember right?

Share this post


Link to post
Share on other sites
  • 0

I'm having trouble imagining the particle effects boosting frame rates.

Would love an option to turn them off and/or down (and not just spell effects, but constant environmental fog/dust/whatever effects, as well).

 

*sigh*


This statement is false.

Share this post


Link to post
Share on other sites
  • 0

One thing I did encounter quite often in this game is that if I'm on a map/scene with a lot of particle effects (like fog, rain, biawac in the beginning, ...), the framerate drops tremendously. On native resolution (1920x1080) and AA off I run this game around 45-50 fps, but everytime the weather goes to rain for example I can be lucky if my fps stay above 30 fps. The same applies for scenes like the biawac in the beginning and every other "flashy" scene only that it goes down to like 19 fps and thats quite annoying in my opinion.

 

I don't know the exact reason for that, but I guess it has to do with the particles in the game and how they affect my CPU.

 

I'm curious if I'm the only one with this problem and I also wanna ask, if an option to turn down particle effect may solve it?

Are we going on the assumption that such slowdowns are totally independent of the GPUs installed in the machines affected  ?


Kiwi

Share this post


Link to post
Share on other sites
  • 0

 

Are we going on the assumption that such slowdowns are totally independent of the GPUs installed in the machines affected  ?

 

 

There are several abilities and effects that have such an excessive particle spam, that they reduce framerate of machines way beyond optimum hardware recommendations for PoE.

 

I have a highend PC and still suffer from a severe FPS drop when the constructs in crucible keep use that shiny blue spark spell.

Also, the fog effect in Sun in Shadows heavily drops FPS for me - and I have a stable max FPS in all other situations.

 

It's clear that it's an excess of particles, not the hardware that is to blame.

Edited by Zwiebelchen

Share this post


Link to post
Share on other sites
  • 0

I also don't think that my video card is just too weak. If it is, then I should have more problems than just the particles.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...