Jump to content
  • 0

[Bug] Additional Weapon Sets Dissappeared!


L233

Question

Hi,

 

I just had Weapon Set 3 and 4 disappear on my Island Aumaua with Arms Bearer talent, i.e. die Weapon Sets provided by the Talent and the Racial are gone! I only have two weapon sets now, making my weapon switiching Rogue build utterly useless!

 

I spend a few nights in my Stronghold to pass time until the Craft Shop was completed, then went shopping and when I tried to equip the new gun, I only had 2 weapon sets instead of 4!

 

Any idea how to fix this?

 

Edit: The weapons were still equipped initially but once removed could not tbe re-equipped.

Edited by L233
Link to comment
Share on other sites

20 answers to this question

Recommended Posts

  • 0

Hey 1,233,

 

Four gun pally is my jam, so I'm going to check this out. Can you send me over your Save File, and output.log?

 

Thanks

 

Can't attach the file... it says it's too big. I guess my savegame files are completely screwed up.

 

 

I uploaded the .zip here:

http://www.file-upload.net/download-10474565/savegame_output_log.zip.html

 

Hope it helps.

Edited by L233
Link to comment
Share on other sites

  • 0

Alrighty, so... we have a bug in our system about the extra slots appearing locked after switching between characters in the inventory. That is only graphical though, and goes away if you equip and unequip. You somehow made it permanent. The extra weird thing is your Kana has the same ability but he still has full use of his. I'm going to through your information into the system and see if the programmers can see what happened. There is nothing we can really do about your current dude though, sorry man. You can either just weather the wasted talent or start fresh.

 

Keep up the good work citizen

Link to comment
Share on other sites

  • 0

Alrighty, so... we have a bug in our system about the extra slots appearing locked after switching between characters in the inventory. That is only graphical though, and goes away if you equip and unequip. You somehow made it permanent. The extra weird thing is your Kana has the same ability but he still has full use of his. I'm going to through your information into the system and see if the programmers can see what happened. There is nothing we can really do about your current dude though, sorry man. You can either just weather the wasted talent or start fresh.

 

Keep up the good work citizen

 

I have this issue on Kana, during the quest in Raedric keep the Armed to the teeth trait disappeared from his character sheet and the third set as well. The weapon was assigned to the set by shown red, after I removed the set became locked. 

Link to comment
Share on other sites

  • 0

I just came across this bug today and noticed that it triggers even when you have no party members. After some fiddling around I realized it was being triggered when equipping items - more specifically double clicking a piece of armor to equip it when you already have armor of the same type equipped.

 

So in my case I had the helm that you find in the tutorial dungeon (the one you pick up from the body next to the chamber with the spiders) equpped and found an open helm off a bandit in Valewood; I double-clicked on the open helm to see what it looked like and noticed my third weapon slot immediately turned red. I reloaded and proceeded to test with armor as well (default scale armor equipped, tested with hide armor, leather armor, and even a second se of scale armor) and found it also triggers the bug.

 

Double clicking to equip armor that does not have to replace anything already equipped does not trigger this bug.

 

Hope this helps narrowing down the errant bit of code.

  • Like 1
Link to comment
Share on other sites

  • 0

I just came across this bug today and noticed that it triggers even when you have no party members. After some fiddling around I realized it was being triggered when equipping items - more specifically double clicking a piece of armor to equip it when you already have armor of the same type equipped.

 

So in my case I had the helm that you find in the tutorial dungeon (the one you pick up from the body next to the chamber with the spiders) equpped and found an open helm off a bandit in Valewood; I double-clicked on the open helm to see what it looked like and noticed my third weapon slot immediately turned red. I reloaded and proceeded to test with armor as well (default scale armor equipped, tested with hide armor, leather armor, and even a second se of scale armor) and found it also triggers the bug.

 

Double clicking to equip armor that does not have to replace anything already equipped does not trigger this bug.

 

Hope this helps narrowing down the errant bit of code.

This could be the cause as I remember double clicking armours in Raedric keep, when you have the option to disguise yourself with robes in the temple floor. 

Link to comment
Share on other sites

  • 0

Oh man guys,

 

Don't know how I didn't place this issue before. This is the losing passives bug after double clicking an item to equip it. We are working on a fix for the next update.

 

This is this link for the issue, if you want to get some more information.

http://forums.obsidian.net/topic/72923-psa-game-breaking-bug-affecting-everyone-including-you-temporary-fix-for-party-members-only-currently/?hl=passives

 

My bad

Link to comment
Share on other sites

  • 0

This is NOT the same as losing your weapon slot from double clicking. There is something else that causes it additionally. I made sure to not use double clicking in inventory with new game and didn't lose other abilities, just this one.

 

I still got the weapon slot grayed out AND got the third weapon selectable by every party member during battle. There is another bug related to this - I was playing around and once after removing the weapon from this additonal buggy slot, put the weapon in inventory, closed and opened inventory » weapon was gone for good. It dissapeared, wasn't on any character or in stash, I didn't put it away anywhere.

 

After having my aumaua leave and rejoin the party he only had the weapon slot working correctly for one inventory switch (opened inventory, switched weapons in the buggy slot, closed and reopened inventory - bug is back). This is not the same as the talent not working, which corrects itself by reseting party member.

 

People saying they replicate bug by doubleclicking are wrong, they are triggering the different bug and causing talent to stop working.

Link to comment
Share on other sites

  • 0

I wrote the OP and I am pretty certain that the problem I described was caused by the double click equip bug because it occurred right after I went on a shopping spree and shuffled around tons of equipment in my inventory and on my characters. And yes, I can replicate the bug by double clicking.

 

The third weapon slot being visible for every party member during combat is probably entirely different issue and it's merely cosmetic. It doesn't seem to do anything or have any negative effect.

Link to comment
Share on other sites

  • 0

I have this bug now in the latest version 1.0.2.0508-steam.

Primary weapon and grimoire just disappeared from Aloth inventory in one of the battles at Endless Path.

I have a save file before this bug happens but this bug repeats again if a I load this save where  Aloth has a weapon yet and start the battle weapon disappeares again. I dismissed Aloth and took him in the team again but it didn't help. I removed all weapon from Aloth and had one battle then. After it I gave him his weapon back and started a new battle and the weapon dissapeared again then. It looks like this character is just broken now.

Here is the save file https://yadi.sk/d/I3VeDF1hfhayp - Just start some battle there and Aloth weapon will disappeare during the battle.

It has nothing to do with doubleclicking bug mentioned before in this thread. It's definetly a separate bug.

Edited by Rusknight
Link to comment
Share on other sites

  • 0

I did some additional tests and It looks like my bug with Aloth weapon disappearance has something to do with the spell "Kalakoth's Minor Blights". Primary weapon and  grimoire disappear now if I use this very spell in the battle. If I use some other spells (didn't test them all though) the bug doesn't happen. It's weird cause I used "Kalakoth's Minor Blights" spell a lot before and it was ok, but now it leads to the weapon bug. 

Link to comment
Share on other sites

  • 0

I did some additional tests and It looks like my bug with Aloth weapon disappearance has something to do with the spell "Kalakoth's Minor Blights". Primary weapon and  grimoire disappear now if I use this very spell in the battle. If I use some other spells (didn't test them all though) the bug doesn't happen. It's weird cause I used "Kalakoth's Minor Blights" spell a lot before and it was ok, but now it leads to the weapon bug. 

 

You're describing a completely different bug from what the OP is talking about. We're talking about weapon slots 3 and 4 disappearing (becoming locked), not the weapons themselves disappearing.

Link to comment
Share on other sites

  • 0

I encountered a similar issue today.

Playing on 1.03.530 (GOG version).

I had given Edér the Arms Bearer talent and equipped him with a 3rd weapon.

For a while it worked as expected, but today he had lost his 3rd weapon slot. I was able to fix it by dismissing and rehiring him, but I have no idea why it happened at all.

I'm relatively sure that I never equipped anything by double-clicking and anyway that bug should be fixed, shouldn't it?

Link to comment
Share on other sites

  • 0

This is still happening with the GoG version patched to 1.04 (gog-4). Sadly it happened on my character so I can't dismiss and rehire to fix it.

Here is the save.

https://drive.google.com/file/d/0B9jgMl5BnHvLQVlRRHpnd1FZbDg/view?usp=sharing

 

Patch 1.05 seems to have fixed it, at least for this save. No idea what caused it in the first place.

Edited by srlapo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...