Jump to content
L cleistenes

Auto engagement in Turn Based mode is not working

Recommended Posts

Hi all,

 

So i just downloaded the new pathc that supossedly fix the engagement system in turn based, so the enemie will activated the engagement when passing trhough the tank, but still not working, every enemie pass by my tank as he was nothing, making the tank build useless in this mode.

 

Anyone having the same problem?

 

Obsidian, can you fix this?

  • Like 1

Share this post


Link to post
Share on other sites

It seems more like a bug.

It's a mixed bag for me. It seems to work better than before but I still need to manually "engage" enemies most of the time.

  • Like 1

h1dczBG.jpg

Share this post


Link to post
Share on other sites

I'm seeing four things:

 

1. Engagement seems to set up when you use an ability. For example with Swashbuckler Eder, if I Escape into the middle of the enemies (ghetto charge!) Engagement triggers correctly and boom a bunch of enemies are Engaged. But if I walk up to the same position and attack, it only Engages the one I attacked automatically. I can then add Engagements but clicking on nearby enemies. Weird.

 

2. You can Engage enemies outside your turn but you have to actively click. Ie if Eder is next to someone but hasn't Engaged them, despite still having more Engagements available, then even though it is his turn, I can click him and have him Engage them.

 

3. You can usually Engage people even if you already used your action. For example my Chanter main can shout, then walk up to someone and Engage them.

 

4. 2 and 3 don't work reliably for some characters for no apparent reason. With Pallegina for example, it seems a direct melee weapon attack is the only way to get Engagement. As I am typing this I am wondering if 2 and 3 only work right if you can Engage at least two targets, as Pallegina is 2h in my playthrough and cab only Engage one.

Share this post


Link to post
Share on other sites

The auto engagement works for enemies, at least from one fight I observed against the Ironclad, where he just automatically engaged Eder, and sadly it doesnt work for us, unless we manually pick the enemies, yes, even after attacking and moving, as long as the turn doesnt end. (I turn on auto turn, which makes my tank most of the time not engaging anyone lese beside the on he is attacking) 

 

As for enemies, it seems to work most of the times, as long as we walk within their engagement coverage. There is also a possibility that the coverage area simply too small or not calculated correctly in turn base mode, since the pathing system itself still kinda worked weirdly. It might be nice to maybe add some sort of engagement area circle to each character that have engagement capabilities. 

 

Some games like Divinity has some sort of circular area around the char whenever someone get close to them (this works as some sort of proximity beacon and kind of indicator if you would be walking to close and might then trigger an engagement). 

 

At least few things are certain:

1. Enemies always auto engage when you get close to them, but it doesnt work the other way around.. My Eder supposed to engage enemies but they seem to just pass by him, even when they walk truly close to him. and just walk right to my back liner mages. 

 

2. For player, moving close doesnt trigger engagement as well, especially after triggering The defense stance from Fighter class. In my playthrough my Swashbuckler Eder, with +1 engagement from Rogue passive and Shield equipped.

Sometimes he engages 2 enemies, but most of the time only the attacked enemy will get engaged, even when other enemies get close to Eder and attacking him, he still only engage one enemy, despite the passive and shield. 

Edited by nivodeus

Share this post


Link to post
Share on other sites

Hey everyone,

 

Thanks for the heads-up about the engagement still not being quite right.  I reopened the bug report and linked this thread as a reference, so if you discover anything else about this, please continue to discuss it here so the team will see it.

 

Thanks for the help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...