Jump to content
  • 0
cheesevillain

[Mac] Unable to start game, black screen

Question

The game freezes in a black screen after the initial bit in the In-between.

 

I've tried to upload the player.log file, but the forum software refuses to upload that "type of file".

 

Edit: Here's my player.log file copied to pastebin: https://pastebin.com/sKuxpJ24

Edited by cheesevillain
  • Like 2

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Same issue for me
 

MacBook Pro (Retina, 13-inch, Early 2015)

2,7 GHz Intel Core i5

8GB 1600 MHz DDR3

Intel Iris Graphics 6100 1536 MB

macOS High Sierra 10.13.4

Share this post


Link to post
Share on other sites
  • 0

I am having this issue as well. this is my mac info:

 

MacBook Pro (Retina, 13-inch, Early 2015)

Processor 2.9 GHz Intel Core i5

Memory 16 GB 1867 MHz DDR3

Graphics Intel Iris Graphics 6100 1536 MB

 

Share this post


Link to post
Share on other sites
  • 0

I'm having the same problem. I launch the game from Steam and get hit with a black screen and spinning beach ball. Have tried several times and have tried verifying the local files through Steam as well. Here are the specs on my machine:

 

macOS High Sierra (10.13.4)

2017 15-inch MacBook Pro

2.9 GHz i7

16 GB RAM

Radeon Pro 560

 

Thanks for working on this issue! Can't wait to get into the game. 

Radeon Pro 560 

 

Share this post


Link to post
Share on other sites
  • 0

seriously what the ****...was this game not tested at all on mac? how can so many people have the same problem and yet obsidian still releases this ****?

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

seriously what the ****...was this game not tested at all on mac? how can so many people have the same problem and yet obsidian still releases this ****?

 

 

The problem is isolated to MacBooks, I think.

Share this post


Link to post
Share on other sites
  • 0

 

seriously what the ****...was this game not tested at all on mac? how can so many people have the same problem and yet obsidian still releases this ****?

 

 

The problem is isolated to MacBooks, I think.

 

 

 

I'm not so sure about that; I've heard people with iMacs having the same problems; I can't spot any common trait among all the people experiencing it.

Share this post


Link to post
Share on other sites
  • 0

Has anyone else noticed that the game as is, right now just straight up eats battery?

I have been testing a bunch of settings and found that the game could eat 15% of a charge just walking down to the pillar in the first section. That doesn't feel right to me.

Has anyone else seen this?

 

Also yes. I've seen the primary reported issue. My system is a

 

MacBook Pro (Retina, 13-inch, Early 2015)

OS High Sierra 10.13.4 (17E199)

Edited by daveh86

Share this post


Link to post
Share on other sites
  • 0

 

seriously what the ****...was this game not tested at all on mac? how can so many people have the same problem and yet obsidian still releases this ****?

 

 

The problem is isolated to MacBooks, I think.

 

 

Not so for me, I'm on an iMac late 2015 and I have the same problem. I reeeally hope it's a quick fix! 

Share this post


Link to post
Share on other sites
  • 0

same issue here, tried lowest graphic settings

 

High Sierra, Version 10.13.4. macbook pro

 

i wrote a test script for ya'll to use on macbooks 

 

step 1) play game for 3 minutes

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

The same thing is happening with me, unfortunately. I get sucked into the Adra placed into the loading screen then (no doubt to save it from freezing and needing a hard reset) the game quits out and I'm left staring at a reflection of myself in the screen.

 

My details are:

 

  MacBook Pro Retina, 15 inch, Mid 2014

  MacOS Sierra - version 10.12.6

  Intel Core i7

 

Share this post


Link to post
Share on other sites
  • 0

I'm having the same problem! Glad to know y'all are aware of it, but WOW I honestly can't believe the game wasn't delayed a bit on Mac to work this out.

 

High Sierra 10.13.4

13" MacBook Pro with Retina Display, late 2013

2.6 GHz Intel Core i5

Intel Iris 1536 MB

 

Running the game through Steam. I already tried the "verify install files" thing, and since people are saying uninstalling the game doesn't help, i haven't tried that yet. I also haven't adjusted my graphics settings for the same reason.

Edited by copperleaves

Share this post


Link to post
Share on other sites
  • 0

Same - MacBook Pro (Retina, 15-inch, Mid 2015)

 

How can you release a non working product? 

Share this post


Link to post
Share on other sites
  • 0

Same here.

 

MacBook Pro (Retina, 13-inch, Mid 2014)

Processor 3 GHz Intel Core i7

Memory 16 GB 1600 MHz DDR3

Startup Disk Macintosh H

Graphics Intel Iris 1536 MB

Share this post


Link to post
Share on other sites
  • 0

Hi all signed up just for this. But my game is running fine on a mid-2011 iMac. I'm past the first initial act, character customisation etc. Perhaps there's an issue with MacBook Pros?

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hi all signed up just for this. But my game is running fine on a mid-2011 iMac. I'm past the first initial act, character customisation etc. Perhaps there's an issue with MacBook Pros?

 

Other people with iMacs have also experienced this, and their computers are newer.

Share this post


Link to post
Share on other sites
  • 0

Hi all signed up just for this. But my game is running fine on a mid-2011 iMac. I'm past the first initial act, character customisation etc. Perhaps there's an issue with MacBook Pros?

 

Someone else on this thread said they're running a 2015 iMac, and I saw a couple MacBook Airs in here too.

 

It doesn't seem to be an OS problem bc of how many different versions are in the thread, but MacBook does seem to be pretty common...but not 100%.

 

So basically it's a newer (post 2013, seems like??) Mac issue that's affecting a lot of us, and it sucks really really bad.

Edited by copperleaves
  • Like 3

Share this post


Link to post
Share on other sites
  • 0

 

Hi all signed up just for this. But my game is running fine on a mid-2011 iMac. I'm past the first initial act, character customisation etc. Perhaps there's an issue with MacBook Pros?

Other people with iMacs have also experienced this, and their computers are newer.

Yes, I see now. Two people mention issues with the 2015 iMac. I don’t know if it’ll help devs fix what is wrong but everything is fully functional on my mid-2011 iMac. I’ve a newer model as well and a brand new MacBook Pro so will try on them and report back.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

 

So basically it's a newer (post 2013, seems like??) Mac issue that's affecting a lot of us, and it sucks really really bad.

 

Ah!

 

Maybe its an issue with the newer Intel Processors that do CPU scaling? That would only be on newer machines and could explain the mega battery drain I saw.

Share this post


Link to post
Share on other sites
  • 0

Hi all signed up just for this. But my game is running fine on a mid-2011 iMac. I'm past the first initial act, character customisation etc. Perhaps there's an issue with MacBook Pros?

 

FWIW it's working fine on my 2014 MBP (though performance leaves much to be desired).

 

Posting this here in case it helps the devs find the issue.

 

Screen_Shot_2018-05-09_at_13.29.18.png

Edited by Quantics
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Me to. Black after in-between scene.

 

  Model Name: MacBook Air

  Model Identifier: MacBookAir7,2

  Processor Name: Intel Core i7

  Processor Speed: 2.2 GHz

  Memory: 8 GB

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...