Jump to content
  • 0
Sign in to follow this  
smokey1196

Spell Striking seems to not work in the 3.03 Beta Patch

Question

Jolting touch on both Cloudpiercer and Azureith's Stiletto are not working for me in the new 3.03 beta patch. In the combat log it says that they have triggered but no damage is done. Before they would also say the damage done in the combat log but that appears to not be happening either. I tried using different characters with the weapons as well as equipping and reequipping and it still doesn't trigger. The Patch notes say something about spell striking not triggering twice but it seems to not trigger at all now. 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Seconded, Stiletto doesn't trigger for me either. Presumably it's the same issue as with the Dominate on the Soulbound scepter, noted elsewhere in the Tech forum.

Share this post


Link to post
Share on other sites
  • 0

Any news about other spell striking items? Does proc effects work as it suppposed to?

 

It's improtant fix, so whoever have  beta steam, pls give  some info.

Edited by Gs11

Share this post


Link to post
Share on other sites
  • 0

Man, I just thought I had been getting _really_ unlucky with the proc. 

 

Let's see... would I rather have a fix for the stacking def/reflex or functional spell striking...

Share this post


Link to post
Share on other sites
  • 0

We will have a fix for this in our next beta update (should be soon.) 

 

Sking

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...