Jump to content
  • 0
Stahlbart

[BUG] Party member's inventory gone after switching them

Question

Hey folks,

 

yesterday, after getting my 6th party member I was struggling with choosing which one to dismiss. So I switched around a bit and noticed, that every time I get a character back into the party, their inventory would vanish completely. 

Checked the stash: nope.

Checked the chests in the bedrooms in the stronghold: nope.

So I googled, found nothing, asked at Steam and went to bed.

As I got up, no answer. I started the game, tested it again and the inventory was still there.

Luckily I had a save before switching around, but Durance's inventory seems to be gone for good....

 

TL;DR: 

Inventory vanished after switching out party members. Next day, bug was gone, but Durance's inventory is lost.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I've been doing a lot of party swapping, but haven't been hit by the inventory loss/reset bug. Must only be happening to certain people, which is why it hasn't been fixed. I've done the swap outs both at inns and the Stronghold, too.

 

I do notice that "Personal" stats seems to reset, but that almost makes sense, even though they probably should persist properly. For all I know that might be a design decision on their part.

Share this post


Link to post
Share on other sites
  • 0

Hey guys,

I've  gotten this bug once in an older build but not again in 1.04. Has anyone here gotten this bug in a new 1.04 game? If you have, please help us by listing detail steps. Thanks!

  • Like 2

Got a bug :cat:?? Help us squish it!

  • In your report Include your *save file* (C:\Users\YourNameHere\Saved Games\Pillars of Eternity) and ...
  • PC: *output_log.txt* (In your PillarsOfEternity_Data folder)
  • Mac/Linux: *Player.log* (In your Unity folder)

  • Thank you for your help!

Share this post


Link to post
Share on other sites
  • 0

I reinstall teh game from 0 with teh new patch and I have the bug in Inn and Stronghold.

 

This is saved with bug. I run GoG version, Windows 7, Spanish languaje.

 

https://www.dropbox.com/s/41eab64vvmyquyk/2e20a116331544ada86bd4212918b0d9%208082355%20ElSabuesoNegro.savegame?dl=0

 

 

EDIT: I forget the Log and System Spec

 

https://www.dropbox.com/s/b7iqz2xqvl0llxr/output_log.txt?dl=0

 

https://www.dropbox.com/s/040x76sscl920cg/DxDiag.txt?dl=0

Edited by Aranduin
  • Like 3

Share this post


Link to post
Share on other sites
  • 0

It is still happening. Aloth just lost all his grimmoires and bunch of other stuff. Luckily i had an earlier save. This needs to be fixed assap.

 

Gog install here by the way.

Edited by Carados
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I reinstall teh game from 0 with teh new patch and I have the bug in Inn and Stronghold.

 

This is saved with bug. I run GoG version, Windows 7, Spanish languaje.

 

https://www.dropbox.com/s/41eab64vvmyquyk/2e20a116331544ada86bd4212918b0d9%208082355%20ElSabuesoNegro.savegame?dl=0

 

 

EDIT: I forget the Log and System Spec

 

https://www.dropbox.com/s/b7iqz2xqvl0llxr/output_log.txt?dl=0

 

https://www.dropbox.com/s/040x76sscl920cg/DxDiag.txt?dl=0

Thanks Aranduin!

I was able to reproduce this bug with your save. I'll make sure this is a high priority. 

  • Like 6

Got a bug :cat:?? Help us squish it!

  • In your report Include your *save file* (C:\Users\YourNameHere\Saved Games\Pillars of Eternity) and ...
  • PC: *output_log.txt* (In your PillarsOfEternity_Data folder)
  • Mac/Linux: *Player.log* (In your Unity folder)

  • Thank you for your help!

Share this post


Link to post
Share on other sites
  • 0

 

I reinstall teh game from 0 with teh new patch and I have the bug in Inn and Stronghold.

 

This is saved with bug. I run GoG version, Windows 7, Spanish languaje.

 

https://www.dropbox.com/s/41eab64vvmyquyk/2e20a116331544ada86bd4212918b0d9%208082355%20ElSabuesoNegro.savegame?dl=0

 

 

EDIT: I forget the Log and System Spec

 

https://www.dropbox.com/s/b7iqz2xqvl0llxr/output_log.txt?dl=0

 

https://www.dropbox.com/s/040x76sscl920cg/DxDiag.txt?dl=0

Thanks Aranduin!

I was able to reproduce this bug with your save. I'll make sure this is a high priority. 

 

 

A pleasure.

Share this post


Link to post
Share on other sites
  • 0

I have the same issue.... 

Threw eder out so i could lvl aloth who isnt in my party to send him packing on a quest. Got eder back and like 8 magic items were gone from his inventory, including a unique 2h sword.

I didnt notice this till after clearing like 3 lvls of endless paths and i couldnt stand the thought of doing it all over again, i near just quit.

Lost like 80% of my gold in items. 

When is this going to be fixed? 

Will you be able to make it so i dont have to reload a million saves back? If that even fixes it... 

Odd thing is, im pretty sure all but a single item was gone, had a lone blue mace still in my inventory after.

Share this post


Link to post
Share on other sites
  • 0

Hey guys,

Just an update that this should be fix in the next patch. 

  • Like 2

Got a bug :cat:?? Help us squish it!

  • In your report Include your *save file* (C:\Users\YourNameHere\Saved Games\Pillars of Eternity) and ...
  • PC: *output_log.txt* (In your PillarsOfEternity_Data folder)
  • Mac/Linux: *Player.log* (In your Unity folder)

  • Thank you for your help!

Share this post


Link to post
Share on other sites
  • 0

Hey guys,

Just an update that this should be fix in the next patch. 

Do you know exactly what form the fix will take? E.g., will companions that have lost their items have the items restored, or, is the fix only going to prevent items from being lost in future swaps of companions in/out of the party?

Share this post


Link to post
Share on other sites
  • 0

I just discovered this. Played pretty much all the way to the end of Act 2 with the same party. Celebrated by going to the stronghold to level everyone else up, swapping them in and out of the party by the bedroom upstairs in Brighthollow.

 

Merrily carried on and then needed to fish something out of the inventory in Nine Elms. Found all my pets are gone. All of them. Even the Miniature Giant Space Piglet I got as a KS backer...  :(

 

I'm seriously hacked off. This might not be a "gamebreaker", but it's just taken a dirty great sledgehammer to my enjoyment of the game. 

 

It's great to hear that there might be a patch to fix it, but will it correct the mistake? Will we be allowed to add back missing items without triggering the Steam Achievements block that using the console has? Can I get my MGSP back?

Share this post


Link to post
Share on other sites
  • 0

 

Hey guys,

Just an update that this should be fix in the next patch. 

Do you know exactly what form the fix will take? E.g., will companions that have lost their items have the items restored, or, is the fix only going to prevent items from being lost in future swaps of companions in/out of the party?

 

Unfortunately, I believe its the latter.

 

Why the bug was occurring:

One of our programmers: "...this happens because the stored companion is being rebuilt in the scene off in the bar so you can go talk to them once dismissing them. All of their items are being restored and some are duplicated and the originals are then deleted. Because of this, when we go to restore the companion back into the party, it can find no original persistence data for the guids stored since they were removed when the companion was placed back in the scene at their "placed companion node"."

 

On a more positive note, we really do appreciate the community's support. Its because of your help we're able to track down the bug and fix it. Thanks guys.


Got a bug :cat:?? Help us squish it!

  • In your report Include your *save file* (C:\Users\YourNameHere\Saved Games\Pillars of Eternity) and ...
  • PC: *output_log.txt* (In your PillarsOfEternity_Data folder)
  • Mac/Linux: *Player.log* (In your Unity folder)

  • Thank you for your help!

Share this post


Link to post
Share on other sites
  • 0

After being lucky(?) to not see this bug until level 9, I finally got it tonight. Had to reload from before I started doing a long combat sequence, so it was "only" a few hours of game time for me.

 

What's weird is that I don't recall doing anything different. Every time, I come to Caed Nua, swap out Aloth for Kana, and then do a level or 2 of Endless Paths. I revert in Brighthollow, but generally use the "H" key to pull up the stronghold menu to swap out characters. Up until today, the game didn't eat any inventory - just reset my stats for the "new" party members.

 

Considering that Kana is also bugged vis a vis the "Armed to the Teeth" talent (which has disappeared), I am shelving the game until the solution is found - it's just a little too shaky for me, and it sounds like I won't have to wait too long.

Share this post


Link to post
Share on other sites
  • 0

Also, I believe the easiest way to deal with the missing inventory items would be let people add them back via console. However, I don't think we have access to item variables. 

 

It would help, certainly, even if some folks would cheat with it. But that's their business.

Share this post


Link to post
Share on other sites
  • 0

Playing steam with latest non-beta. Went to do a couple of Od Nua levels, hit the stronghold, leveled up my hires, and then swapped them out, and retrieved Kana. He came out completely sans inventory/equipped items. Like, naked. Only figured it out once he died at the large encounter in level 5.

 

Kind of a deal breaker. Does the bug strip inventory on save / swap, or is it when I swap him back in? Do you need help reproing this, or save files? I'm not even sure where/when it occurred.

 

Let me know how I can help.

Share this post


Link to post
Share on other sites
  • 0

I've uploaded a screenshot of where I discovered the missing inventory (Bright Hollow). What's the best way to share a zip of save files and more detailed bug info?

Share this post


Link to post
Share on other sites
  • 0

Ok. Here's some save files (before completing Act II, and just after when I went back to Od Nua and encounter the issue). There's also my system info in there, and a textfile describing the issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...