Jump to content
  • 0

Antialiasing ?


Skysect

Question

I was opened a topic about that before release . I am trying to use forced AA from my graphic card's panel . but it seems not working . Especially when I creating characters they looking terrible . I am not looking for Dragon Age 3 graphics . But weapons etc . pixellated and it seems there isn't any filter . Also wondering why no graphic options about them ? Actually even don't have any idea where is the problem . Maybe this game not working with Nvidia Card . But it seems working in my graphic driver panel .

Link to comment
Share on other sites

Recommended Posts

  • 0
  • 0

Yeah MSAA is working, it's just not very strong. But you can see a difference between MSAA 0 and MSAA 8. Zoom in and look at a sword edge, it's definitely noticeable. 

Home/Gaming PC: I7-9700K@4.9GHz/Asus ROG Maximus XI Hero/EVGA RTX 2080 Ti XC ULTRA /Corsair Vengeance LPX 16GB (2x8GB)/Corsair Carbide Quiet 600Q/Corsair RM750i/LG 32GK850G 31.5"/BenQ G2400W 24"/Sound Blaster ZX/Samsung 970 EVO x2, 850 PRO x1/Win10 Pro 64bit/Saitek X52/TrackIR5 - TrackClip Pro

Link to comment
Share on other sites

  • 0

It's just forcing the video driver to use specific FSAA mode regardless of application settings. You just launch PoE with __GL_FSAA_MODE environment variable set to specific FSAA mode ID. There is the start-up command I use in Steam PoE properties:

 

__GL_FSAA_MODE=12 %command%
 

I forgot to mention that it's most likely Linux-specific solution. However you probably can do similar thing in other OS in a different way. (I don't know how)

Link to comment
Share on other sites

  • 0

NVidia users can do the following:

 

In the NVidia driver activate FXAA for this game and in the game deactivate MSAA via the console. Unfortunately you have to deactivate MSAA every time you reload a game or change areas. But for this there is a nice little tool available that will do it for you, it is called PoEKey

  • Like 1

"Two things are infinite, the universe and human stupidity, but I'm not absolutely sure about the universe."
Albert Einstein

Link to comment
Share on other sites

  • 0

If you've got an nvidia card, you can actually permanently disable antialiasing. (I use Nvidia Inspector, but it should probably work fine with the default NV control panel.)

  • Set 'Antialiasing - Mode' to 'Override any application setting'.
  • Set 'Antialiasing Setting' to 'Application-controlled / off'.

 

This will turn off the msaa properly, without it resetting to defaults every time you change location.

 

---- ot;

I've noticed some rendering irregularities, also. From frame dumps. The render target seems to be resetting incorrectly each time you change location(example: enter/leave a building, etc). Lod, and filtering techniques are not affecting things they should be, and are affecting things they shouldn't. Also scaling issues. Thats why the antialiasing isn't even sampling correctly on the 3d components.

 

Another friendly suggestion: In a game like this, that's heavily 2D based. wouldn't it have been better to actually use post-processing antialiasing, rather than hardware based. Seeing as it's not even affecting the 2D scenes. Post AA would.

Link to comment
Share on other sites

  • 0

I care as well.My computer is a bit below specs and anything I can do to get for fps is good for me.Now only if I could disable or lower shadow resolution and dynamic lighting :)

  • Like 1

"Very well permit me on this night. To break your hearts once more. This is the story of the Chain of Dogs. Of Coltaine of the Crow Clan, newly come fist to the 7th Army"- Duiker:Memories of Ice

Link to comment
Share on other sites

  • 0

I'd like the reverse of all that tbh, and increase the quality of them ;p

 

I'd really like to be able to enable the models/textures that are shown in the character creation/level up screen, to also have them ingame :(

 

I create a character - get ingame "huh? that's not the guy I created". ;p

Edited by Asmodean-
Link to comment
Share on other sites

  • 0

Another option for Windows users is SweetFX which can provide SMAA or FXAA anti-aliasing along with several other post-processing options. It does work with Pillars of Eternity (just extract SweetFX into the main PoE folder and amend the SweetFX settings file) but I didn't consider its anti-aliasing much of an improvement over PoE's - however those who can't get PoE's MSAA to work may find it more beneficial.

Link to comment
Share on other sites

  • 0

Another option for Windows users is SweetFX which can provide SMAA or FXAA anti-aliasing along with several other post-processing options. It does work with Pillars of Eternity (just extract SweetFX into the main PoE folder and amend the SweetFX settings file) but I didn't consider its anti-aliasing much of an improvement over PoE's - however those who can't get PoE's MSAA to work may find it more beneficial.

Tried it too still everything seems same :S

 

g9qTDWG.jpg

 

Look at to my weapons . Especially dagger seems awful . Pixellated .

Link to comment
Share on other sites

  • 0

That's pretty much how it looks on my system. You have AA elsewhere (the selection circles and the figures) but bladed weapons aren't smoothed out as well. Maybe there's something in the way they're rendered that limits or prevents AA - given that metallic armour shows the same issue (look at the scales on the rightmost figure by the fire), I'd suspect something to do with bloom or light reflection.

Link to comment
Share on other sites

  • 0

Could it partly be the size of the 3D objects when zoomed out etc? So small, not much for AA to work with, heh?

 

Here's a test you can try just to see if the AA is working at all: if you use the console command to increase the zoom-in of the game a lot, do the weapons look more AA'd then? They do on my PC at very extreme zoom-in (but then the ground textures look utterly horrible heh). Still not perfect but it's doing something.
http://crimsonkeep.com/wallpapers/data/media/139/PoE-Obs-0004.jpg
 
But the farther you zoom out the edges of small objects start to pixelate more. Not quite as much for me as in some of your pics in this and other threads, but still noticeable imo, especially on straight edged weapons.
http://crimsonkeep.com/wallpapers/data/media/139/PoE-Obs-0005.jpg
 
Console command: hit the ` key, hit Enter, type setzoomrange [min] [max] and hit Enter again, then scroll to see the zoom difference. The default is 0.75 1.5 with the first number being the close-in zoom range. My 1st screenshot is probably around .3 or .4, I can't remember. This console command doesn't disable Steam achievements.

“Things are as they are. Looking out into the universe at night, we make no comparisons between right and wrong stars, nor between well and badly arranged constellations.” – Alan Watts
Link to comment
Share on other sites

  • 0

Hi,

 

I have the same problem ... i have a 970 GTX nividia card, and my controllers are very pixelled !!!

 

I have questions :

1 - What is the "simple" way to corrige this ? I get lost and do not understand anything in all his answers.

2 - Where can we change graphic option about POE ? In the game ? In the Steam game options ?

3 - How can we enter commands ? In the game command liner ? How ?

 

This problem is it "really" recognized from Obsidian ? Do you have a link about this problem ?

 

Very thanks for you answer. 

 

Edit : Does "msaa 8" works in the command console for you Kyonshim ?

Edited by Ekkyo

1527234074-capture-d-ecran-2018-05-25-a-

Link to comment
Share on other sites

  • 0

Hi,

 

I have the same problem ... i have a 970 GTX nividia card, and my controllers are very pixelled !!!

 

I have questions :

1 - What is the "simple" way to corrige this ? I get lost and do not understand anything in all his answers.

2 - Where can we change graphic option about POE ? In the game ? In the Steam game options ?

3 - How can we enter commands ? In the game command liner ? How ?

 

This problem is it "really" recognized from Obsidian ? Do you have a link about this problem ?

 

Very thanks for you answer. 

 

Edit : Does "msaa 8" works in the command console for you Kyonshim ?

 

Nope it didn't worked

 

 

Could it partly be the size of the 3D objects when zoomed out etc? So small, not much for AA to work with, heh?

 

Here's a test you can try just to see if the AA is working at all: if you use the console command to increase the zoom-in of the game a lot, do the weapons look more AA'd then? They do on my PC at very extreme zoom-in (but then the ground textures look utterly horrible heh). Still not perfect but it's doing something.

http://crimsonkeep.com/wallpapers/data/media/139/PoE-Obs-0004.jpg

 

But the farther you zoom out the edges of small objects start to pixelate more. Not quite as much for me as in some of your pics in this and other threads, but still noticeable imo, especially on straight edged weapons.

http://crimsonkeep.com/wallpapers/data/media/139/PoE-Obs-0005.jpg

 

Console command: hit the ` key, hit Enter, type setzoomrange [min] [max] and hit Enter again, then scroll to see the zoom difference. The default is 0.75 1.5 with the first number being the close-in zoom range. My 1st screenshot is probably around .3 or .4, I can't remember. This console command doesn't disable Steam achievements.

 

I tried this and saw how it works . But can't revert back now :S Also character creation and inventory screen have same problem . With this zoom feature Anti-aliasing seems working but it seems , this pixellated graphics are another problem , hopefully Obsidian will fix it :(

Link to comment
Share on other sites

  • 0

 

Hi,

 

I have the same problem ... i have a 970 GTX nividia card, and my controllers are very pixelled !!!

 

I have questions :

1 - What is the "simple" way to corrige this ? I get lost and do not understand anything in all his answers.

2 - Where can we change graphic option about POE ? In the game ? In the Steam game options ?

3 - How can we enter commands ? In the game command liner ? How ?

 

This problem is it "really" recognized from Obsidian ? Do you have a link about this problem ?

 

Very thanks for you answer. 

 

Edit : Does "msaa 8" works in the command console for you Kyonshim ?

 

Nope it didn't worked

 

I'm at work, and i don't test this way. So i have an another question for you :

Have you turn off MSAA on Nivida panel before to input conosle command "msaa 8" ?

1527234074-capture-d-ecran-2018-05-25-a-

Link to comment
Share on other sites

  • 0

 

 

Hi,

 

I have the same problem ... i have a 970 GTX nividia card, and my controllers are very pixelled !!!

 

I have questions :

1 - What is the "simple" way to corrige this ? I get lost and do not understand anything in all his answers.

2 - Where can we change graphic option about POE ? In the game ? In the Steam game options ?

3 - How can we enter commands ? In the game command liner ? How ?

 

This problem is it "really" recognized from Obsidian ? Do you have a link about this problem ?

 

Very thanks for you answer. 

 

Edit : Does "msaa 8" works in the command console for you Kyonshim ?

 

Nope it didn't worked

 

I'm at work, and i don't test this way. So i have an another question for you :

Have you turn off MSAA on Nivida panel before to input conosle command "msaa 8" ?

 

 

Yes I tried it too but not working . Probably those solutions are only for people with MSAA problems . But after that zoomrange parameter it seems MSAA working . In the other hand still we have problems with models and waiting for a fix .

Link to comment
Share on other sites

  • 0

 

Yes I tried it too but not working . Probably those solutions are only for people with MSAA problems . But after that zoomrange parameter it seems MSAA working . In the other hand still we have problems with models and waiting for a fix .

 

 

Ok tank for all returns !!

I hope that we aren't the only one in this case because it must be corrected !!!

1527234074-capture-d-ecran-2018-05-25-a-

Link to comment
Share on other sites

  • 0

Tried out various nvidia AA settings and taken a couple of screenshots for comparision.

I've enforced these through the driver using nvidiaInspector.

 

Some of the still visible aliasing comes from post processing shaders like deferred lighting, rim light and such from the game itself as these draw on top of the aliased image. That is common with many titles hence a good post processing AA shader that does not blur textures would be ideal instead of hardware AA.

 

no AA:

http://i.cubeupload.com/jJLdw7.png (zoomed in)

http://i.cubeupload.com/McAkJ5.png

 

2x MSAA

http://i.cubeupload.com/7T3wCi.png (zoomed in)

http://i.cubeupload.com/Msp0p9.png

Viable option at low GPU cost

 

4x MSAA

http://i.cubeupload.com/s9YFiE.png (zoomed in)

http://i.cubeupload.com/HCmNs2.png

Best option out of these IMO

 

8x MSAA

http://i.cubeupload.com/qQAceQ.png (zoomed in)

http://i.cubeupload.com/bKYzfw.png

Barely visible difference to 4x MSAA

 

FXAA

http://i.cubeupload.com/9VsnvI.png (zoomed in)

http://i.cubeupload.com/xdQjVI.png

Basically a post processing shader that affects the entire image, blurs textures quite a lot.

 

4x SGSSAA (4x MSAA + 4x SGSS (Sparse Grid Supersampling))

http://i.cubeupload.com/kL9qSI.png (zoomed in)

http://i.cubeupload.com/GqkBMW.png

Supersampling is out of the question as it renders the background at four times resolution and scales it back down which just blurs prerendered images.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...