Jump to content
  • Sign Up
  • 0
Sign in to follow this  
Orphidos

Sound issue, strange clipping noise

Question

Hello!

 

It started about a minute after I picked the berries at the bush right after leaving the caravans.

It's like a continous clipping noise of sorts, like imagine turning a page in the old Baldurs gate spellbook but cut out the last millisecond of that sound, then put it on repeat. It only goes away if I exit the game to main menu and after loading my save, It's gone for about a few minutes and then suddenly comes back.

 

 

I've tried exiting the game completly, restarting it. Reinstalled sound-drivers, also tried older drivers same issue.

Win 7 Ultimate, Motherboard x58 Pro-E onboard soundchip w/ drivers used.

I'm running the Steam version.

 

I was just wondering if anyone else has noticed this sound issue and possibly found a fix?

Or has any ideas, any whatsoever is good. Feels like I've tried most things I can think of.

 

(here's my updates of things related)

Update 1:  The sound-repeat glitch actually disappeared briefly now when opening, looting and closing a chest just to return a few minutes later completly random.

Update 2: The sound-repeat glitch also seem to disappear when new things to me occur which forces up the tutorial window and auto-pauses the game.

 

Thanks in advance and congratulations to the team for a great game so far (except that sound thingie hehe).

 

Best regards,

Fredrik

Edited by Orphidos

Share this post


Link to post
Share on other sites

24 answers to this question

Recommended Posts

  • 0

Yeah, I also have this problem. I've tried both restarting it from the meny and from desktop, but it always comes back after a while. It's really annoying. 

Share this post


Link to post
Share on other sites
  • 0

Probably would help if i posted what my specs are and i would suggest to everyone with similar problem to do so as well. I am using on board sound on a ASUS P8P67 motherboard and i believe it uses Realtek® ALC 892 8-Channel High Definition Audio CODEC . I am also running Windows 8.1 fully updated on a R9 290 Tri-X AMD GPU with the latest AMD drivers. If there is any other info that is need pleases let us know.

Share this post


Link to post
Share on other sites
  • 0

Same issue here. If I reload a save that had the issue without exiting the game completely, the sound glitch is still there. Running onboard sound on Gigabyte EX58-UD5 motherboard with Core i7 920 processor, GTX560Ti, and game's installed on an OCZ SSD. Windows 7 Pro 64 bit. My video drivers are not up to date, so I'll do that, although I doubt it has anything to do with the sound glitch.

Share this post


Link to post
Share on other sites
  • 0

Here are my specs:

 

HD500GB Samsung SP SATA2* 7200RPM Spinpoint 

CPU Core i5 2500K

PSU Corsair TX 650W V2 /80+ Bronze

Windows®7 Home Swe 64-bit Single OEI, SP1

MK Gigabyte P67A-D3-B3 Socket 1155, P67, ATX

Corsair 8GB (KIT) DDR3 1333MHz/CL9/1.5V

MSI GeForce GTX 970 Gaming

 

If you need anything more than those, let me know and I'll do my best to provide them.

Edited by Ercarret

Share this post


Link to post
Share on other sites
  • 0

I don't know if this helps identify where the problem lies, but I played around with the sound options when it came back. It's not a music or voice problem, but when I turned down the Effects slider it disappeared. 

Share this post


Link to post
Share on other sites
  • 0

Turning off tool tips and combat tips works played for over an hour without the problem :)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I saw this on Incgamers:

 

"I’ve not had this one myself, but by the sounds of things it’s some kind of audio glitch relating to the tutorial hint pop-ups that you get in the game’s first area. If you keep hearing journal page noises where they shouldn’t be playing, try this.

 

Go to the ‘Game’ section of the options menu, find ‘Show In-Game Tutorials,’ and toggle that off. Going by what other people have said, this should fix the problem.

 

Of course this means you won’t get any more tutorial pop-up hints, but it’s mostly stuff like “hey, did you know there’s a Scouting Mode that lets you sneak” and similar things. You can hopefully get by without them. It’s better than listening to endless journal page turning noises, anyway."

 

I haven't tried it yet, but it sounds like the problem we're having. 

 

http://www.incgamers.com/2015/03/pillars-of-eternity-journal-sound-bug-fix

Share this post


Link to post
Share on other sites
  • 0

Same issue here. Really annoying.

Share this post


Link to post
Share on other sites
  • 0

Haha, I see we all found the same solution at roughly the same time. :) 

 

I've only played for perhaps 15 minutes after turning off the hints, but yeah, it seems to be working. Good thing I've played the old Infinity Engine games and am familiar with most of the hints being offered.

 

But at least it's a solution.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Heh, I was just going to post to suggest disabling the tutorial tips as well. Keep on adventuring, then, folks!

Share this post


Link to post
Share on other sites
  • 0

hmmm. I disabled the tips and I still hear it. Sounds like those flying skulls from ocarina of time, so annoying.

Share this post


Link to post
Share on other sites
  • 0

I've only played about 15 minutes myself after disabling tooltips, but I haven't heard it again yet. Will report again after more time has passed.

Share this post


Link to post
Share on other sites
  • 0

hmmm. I disabled the tips and I still hear it. Sounds like those flying skulls from ocarina of time, so annoying.

Have you tried quitting and loading the last save since you disabled the hints? 

 

Also: I think there are different tooltips (combats and general) that you can disable. "Show in-game tutorials" is the one I disabled, and since then I haven't had any problems.

 

Hope it helps!

Share this post


Link to post
Share on other sites
  • 0

I have yet to rehear that sound. This game is amazing, and so much better without that noise!

Share this post


Link to post
Share on other sites
  • 0

Enabled or disabled the tooltips (combat and tutorial), changed the time, everything else...

 

Nothing helps, and it's getting to annoying that I'm going to reroll...

Share this post


Link to post
Share on other sites
  • 0

I have this also, how can stuff like this make it onto the full release, unbelievable. 

 

Other than this it seems to be a really good game so far.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...