Jump to content

characters wont move after combat


Recommended Posts

I have a feeling I may be doing something wrong, but I don't remember the original kotor acting like this. After combat ends my characters won't move, I can't use the keyboard keys or the mouse left+right buttons to move forward. They seem to become unstuck after a bit but I just got the droid under my control for the second time (t4?) and after a recent battle he is not moving at all, no matter what I do.

 

I hope it's just something I'm doing wrong. If not this is a pretty major bug.

Link to post
Share on other sites
I have a feeling I may be doing something wrong, but I don't remember the original kotor acting like this. After combat ends my characters won't move, I can't use the keyboard keys or the mouse left+right buttons to move forward. They seem to become unstuck after a bit but I just got the droid under my control for the second time (t4?) and after a recent battle he is not moving at all, no matter what I do.

 

I hope it's just something I'm doing wrong. If not this is a pretty major bug.

 

 

Same problem here. Can't move after combat

Link to post
Share on other sites

For me, I enter certain areas on Peragus and nothing works for movement. I have entered the fuel depot ? area with T3 and cannot continue the game because he won't move.

 

I tried remapping the keys, but that didn't help. Other things respond (camera movement with key control and menu selection and camera panning with mouse) but he will not respond to the WASD keys at all.

 

Any thoughts or work arounds for this would be appreciated.

Link to post
Share on other sites

I found that this seems to be caused by either getting 'stuck' on an enemy corpse or from looting a corpse, or both.

 

Saving the game, exiting, then loading seems to clear any 'stuck' issues.

 

I think maybe the bouding boxes for enemies is not clearing fast enough after they die and you end up getting stuck in it when trying to run over/loot them. If anyone knows of or can find a console command toggle or clear corpses it may be a better fix until a patch is released.

 

[edit] after becoming very briefly stuck on what seemed to be an open spot in the floor (no combat had taken place here at all) i retract my previous assumption

 

it seems like the character is indeed becoming stuck, i have yet to be stuck long enough with multiple party members to see if switching between them allows me to keep running

 

if anyone has experienced this and tested thoroughly please post your thoughts! i'm sure furgy and the crew want to know what's up

Link to post
Share on other sites

There's not much I can do for testing, as I can't seem to undo it at this point. Saving and reloading doesn't help. I will give more detail, however.

 

Both instances so far have been with T3 only on Peragus. The first time it happened was at the bottom of the same area where the hanger is (down after an area transition - where you pick up the explosives from the guy's corpse in a small sub-area). When I first entered this area, I found I suddenly could not use the WASD keys any longer, but I COULD (for some strange reason) use the Z key to go sideways and if I clicked on the various items I both moved to battle and moved to loot. I also noted a distinct decrease in framerate in this small room, so I thought perhaps it was some video problem (though everything else is up to par, my processor is a bottleneck at the minimum 1 Ghz). Therefore, I tried turning various graphic items down. It looked sucky, but didn't help the problem so I turned them back up. In this instance, in order to leave the area I turned the camera apropriately and scooted back out. Once back in the hangar area, the game returned to acting normally and I was able to navigate without a problem.

 

However, as soon as I blasted the door to the right of the hangar console and went through that area transition in the hallway beyond, the same thing happened again (framerate slowdown and cannot move) except this time NO movement keys worked at all. I can pan around using the keys and the mouse, but there's nothing in range to click on to see if either moving to loot or combat an get the poor little guy moving again. Again, saving and reloading has no effect. Turning all graphics options down has no effect (besides making everything look really bad, of course :( ). Desperate and random clicking has no effect. Threatening my computer with its imminent destruction has no effect. I am well and permanently stuck and cannot continue.

 

I do not know if this is a similar symptoms to what others are experiencing, but that's what I have ATM.

Link to post
Share on other sites

I'm not sure if this is the same thing, but I've gotten inadvertently shifted into mouse-look mode a couple of times. I believe, that in mouse-look, you can pan the camera around with the mouse but the WASD keys do not allow movement.

 

I'm still on Peragus and have had the problem occur in the Mining Tunnnels and the Fuel Depot. Typically, my character was in a tight space (around droid corpses, in a doorway or at the workbench) when I saw the issue.

 

After toggling the CAPS LOCK key and/or right mouse button a few times (read: beat the keyboard/mouse in frustration whilst muttering various profanities gleaned from 4 years of naval service), my character unstuck and I was able to move normally again.

 

EDIT (a little more info): I am using the default keymap.

Link to post
Share on other sites
Both instances so far have been with T3 only on Peragus. The first time it happened was at the bottom of the same area where the hanger is (down after an area transition - where you pick up the explosives from the guy's corpse in a small sub-area). When I first entered this area, I found I suddenly could not use the WASD keys any longer, but I COULD (for some strange reason) use the Z key to go sideways and if I clicked on the various items I both moved to battle and moved to loot. I also noted a distinct decrease in framerate in this small room, so I thought perhaps it was some video problem (though everything else is up to par, my processor is a bottleneck at the minimum 1 Ghz). Therefore, I tried turning various graphic items down. It looked sucky, but didn't help the problem so I turned them back up. In this instance, in order to leave the area I turned the camera apropriately and scooted back out. Once back in the hangar area, the game returned to acting normally and I was able to navigate without a problem

 

Same issue here in the same area. I enter the lower hanger decks and the game slows to a crawl and/or freezes. The movement keys lock up as well but am able to still pan the camera with eh mouse and keyboard. You think, after the bugs in the first game, Obsidian would have learned from Bio Ware and released a working game.

Link to post
Share on other sites

I reloaded this morning and after some right clicking and such I did get the little droid moving, though the framerate slowdown made navigating difficult. I can guarantee that the caps lock was never on (as that was one of the possibilities I thought of) and random right clicking didn't work before. *shrugs* Switching back to my main character, I was able to get down to the mining tunnels , but standing before the super heated ones again drop my framerates to nothing, and I suspect dashing through there with the energy shield is going to be a trial.

 

It's quite possible that, for me, it's mostly a matter of minimum requirements for the processor don't really work. My machine:

 

AMD 1Ghz

1.25 G memory (Yes, trying to overcompensate for the processor. No it doesn't usually work)

Soundblaster Audigy

GeForce FX 5600 256M

 

Well, at least I'm no longer permanently stuck. I'll try turning the video options down when I get home from work to see if that gets me through the mining tunnels.

Link to post
Share on other sites

yeah im getting same problems in mining tunnels. i have a 1.6 ghz P4, Ati Radeon 9200 (updating drivers will mess up other games so i wont update) Soundblaster Audigy 2 ZS, 768 Ram. Im not gonna play KOTOR II until there is a patch fixed

Link to post
Share on other sites

I hit the same problem with T3 in the fuel depot area. Couldn't get him unstuck, so I shut down for the night. The next morning I went in and he moved fine.

 

Also, this morning I got stuck with my character in the tunnels. He got stuck on a corpse. I tried the shutdown thing again, but this time it didn't work. Somehow I managed to hit on an odd combination of forward and side movement, at the same time and right direction, and he came unstuck.

 

I'm feeling rather fortunate and/or lucky right now. Hopefully, this will be addressed soon.

Link to post
Share on other sites

Having the same problem as the first poster. My character freezes but only after combat (not noticed it anywhere else) and its only started happening recently. Didn't notice it my first few hours of play.

 

Sometimes if I just sit and wait a few seconds (10 or there abouts) it becomes unstuck. i've also found changeing my weapon config sometimes helps, but more often than not I end up having to save and then reload again. It wouldn't bother me if it was only every now and then but it seems the further I go on in the game the more frequently it is occuring. Before I went to bed last night and stopped playing it was beginning to happen every other fight. I'm hoping its just cause I had been playing so long with out stopping that the problem won't persist tonight... If it does however I could see myself shelveing the game til a patch comes out as stopping to save/reload every other fight is just beyond tedious.

Link to post
Share on other sites

Couple of observations that might help with the "one frame every two seconds leading to complete loss of movement" bug while initially in the Peragus fuel tank area:

  • If you spin the camera around to point just to the left of the entry door, your frame rate will return to normal until you change the view again. It is really hard to move and fight at such an angle, but this might be useful to momentarily take the strain off whatever hardware struggling.
  • After the combat has finished, the frame rate may return to normal - no idea precisely what triggers this.
  • If the frame rate doesn't return to normal, the droid gets stuck - no movement is possible. Having got stuck, reloading doesn't always solve the issue, even when reloading a save prior to entering the level; but restarting the game should.

So my advice would be to reload a save made just prior to entering this area, and replay the sequence a few times until you get lucky and complete it without getting stuck. Unfortunately I don't understand what causes the frame rate to return to normal after the battle - perhaps you have to fight the battle very quickly, or kill the enemy droids in a certain order, or just get lucky with the way they die, or something.

 

Edit: Few more experiments. The odds of even seeing the initial framerate slowdown seem to be reduced considerably if you restart the entire game immediately before first entering the level. The level is still a little shakey, but playable.

 

(This isn't entirely unexpected; the whole game seems to be littered with resource (eg memory) leaks, most of which will be cleared by a restart.)

Link to post
Share on other sites

saving does nothing, I was in a normal room, with no risk of being "stuck" no corpse to get stuck on, just me and the door.. so I saved it right there just incase i get stuck later... but when i did get stuck and reload to that point.. I got stuck and couldnt move at all.

 

heh, good job it's not just me then

Shane Tyduk

Some awesome title name here

 

"If you sharpen a knife to its limits,

you run the risk of cutting your own

hand. The knife has no choice but to

be as sharp as you made it."

Link to post
Share on other sites

As an aside, I did an update on my NVidia drivers and for me the issues have stopped. Occasionally after a combat I will somehow get in lookaround mode and right clicking will clear it up.

 

I suspect, for me, the issue is with responsiveness in certain areas, especially areas with lots of smoke/steam.

Link to post
Share on other sites
  • 3 months later...

Ok. I tried everything i've read in these forums and more, but my droid STILL won;t !@#$%^& move in the fuel depot. Here's the config:

 

WinXp with SP2

INtel Celeron 2.7 GHz

1GB RAM

ATI RADEON 9250 256 MB graphics card.

Catalyst 5.6 drivers

KOTOR Patch 1.0b installed.

 

Anyone ever get the bloody thing to move?

Link to post
Share on other sites
  • 3 months later...

Sometimes, if you wait for the "combat" music to stop, your character will be able to move.

 

Most of the time, a quicksave and reload will fix the problem.

 

I remember the quicksave/reload not working for me once or twice, and exiting the game, and loading the quicksave recovered the problem.

 

I've got a pretty good gaming rig: p4/3.0, 1gb RAM, 6600GT AGP; and I still get this occasionally - most of the time, just waiting for the combat music to end is all it takes.

 

I have had seom framerate issues on Dantooine, usually when the Koonda vents are blocked from view by another structure (the entrance from the landing pad, for example) or are just barely off-screen but these usually clear up after a few seconds (and go away entirely when I disable optional effects - gress, shadows, pixel flare, etc.)

Link to post
Share on other sites

I've waited for combat music to stop and yet the issue still remains for me at least. I've only found thus far 2 ways to get past this annoying bug.

 

1) Save, exit and reload: works 100% of the time so far (Knock on wood)

 

2) Move the main PC via mouse. As long as they're able to take even 1 step, the

issue disappears and I can resume using the keyboard for movement.

 

Strangely enough, even when I'm got party members, this issue crops up.. stranger still is that I an switch over to someone else, move THEM easily enough but when I switch back to the main character, they're still frozen in one spot until I use either method above.

 

As an aside, I'm NOT using the latest patch, just running right out of the box.

Link to post
Share on other sites

Any of you guys just simply lowered your screen resultution? I had lock ups on Nar Shadaa and I lowered the resolution and it seemed to sort it out..

Failing that... the person with thE NvIDIA CARD. Are you running sp2? I had some major problems on several games that were corrected as soon as I got an ATI graphics card and installed the drivers that has PASSED Windows Logo Testing. For those of you who do not know what this is then I shall enlighten you: It is what more recent versions of windows look for on hardware products like graphics cards. To pass this test verifies the compatability with Windows, it is a risk to install things that do not. So try this: If your graphics card has not passed this then find some drivers for the card that do

This site has some that do:

XP passed drivers for ATI

Link to post
Share on other sites

i have this problem, but sometimes when i save and exit, im still stuck. someone seriously needs to make a new patch to fix this problem, or hack the game to fix it and tell us how to do it. its starting to royally piss me off.

Link to post
Share on other sites
  • 8 years later...

I was just running out of the cafeteria towards the dorms on Peragus when suddenly this huge lag happened. When it stopped, I had run into a wall, and now, I can only move sideways. I can pan the camera and select things, but nothing else. I tried saving and exiting, and all the listed camera tricks. I shut it down for the night and will try again today to see if the problem has been fixed. I hope it is. 

Link to post
Share on other sites
  • 3 weeks later...

I was just running out of the cafeteria towards the dorms on Peragus when suddenly this huge lag happened. When it stopped, I had run into a wall, and now, I can only move sideways. I can pan the camera and select things, but nothing else. I tried saving and exiting, and all the listed camera tricks. I shut it down for the night and will try again today to see if the problem has been fixed. I hope it is. 

It has been fixed, and I'm well into the story!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...