Jump to content


Recommended Posts

I belive that i have encunterd a bug but im not sure if it was a but or not, oh well.






Okey, so i was on Koriban and where in the "trial" and when i had cleard the part where you have to decide if you are to protect or fight against the old woman, i noticed that the old woman didn't disapeer so i did that part 3 times before i could move on to the last part.




*End of spoiler*

Link to comment
Share on other sites

I'm on the Sky Ramp on Onderon. I've gotten to the second barrier, but without Bao-dur in my party. Others who have encountered this problem say that a lightsaber can disrupt the field. However, when I try to do so, nothing happens. Thanks.

Link to comment
Share on other sites

OK-I'm thoroughly irritated now. I first played the game up to near the end of Peragus. Went to go from one area to another, and the game locks up and crashes. No big deal right? Well, I hadn't saved it in a bit, so I get to start over. However, when I restart, all the areas that I had previously visited are viewable, all the items that I had found were in my inventory, all the things I needed to do were done, yet none of the objectives were met. So, now I'm stuck. I've already done the things required, but the game says I haven't. Hmmm.. OK. Uninstall. Reinstall after updating my video drivers.

Game runs a bit more smoothly this time around. This time I get all the way to Citadel Station. Game crashes as I go from one area to the next. Auto save slot gets borked again, same as it did before. I go back to a manual save I had done. The closest one was also borked. Tried another (before I even got to Citadel Station) and amazingly it works.

So, I continue on with my game. This time I am all the way to Malachor V, just before I meet up with Sion and "xxxxx" (spoiler). Game locks up again. This time every single one of my save game slots (7 of them plus the auto save) are corrupted. I can't go any farther.


I'll be damned if I start this entire game over with this kind of glitch possibly happening again. Please tell me something is in the works for fixing this, or that something else can be causing this that can be corrected. Otherwise, I guess I've wasted $45 I could have used on something else.


Hmmmm... Against my own better judgement, I restarted a brand new game. Guess what? My brand new game which I started with an entirely newly created charactor has an entire inventory of items, armor, weapons, etc. and can see the entire initial map. I deleted all the save games except for the auto-save slot, and all of a sudden I can only see part of the map, but I still have a full inventory. Wierd. So, I wander around a bit and try saving the map. Quit the game and come back in, load the manual save point and "whallah", the entire map is viewable again, even tho I hadn't explored it all.

Thus far, I'm the only person who seems to keep getting corrupted save points (although I certainly haven't read ALL the posts here). I've uninstalled the entire game, (savepoints and all) and reinstalled it so I can start completely over.

Link to comment
Share on other sites

3) Dantooine will all of the sudden become lag city. After leaving the ebon hawk all of the sudden the character will run in circles,not move,not respond to movement.Even after rebooting and restarting the game it still happens in the same exact spot.This one is a gameplay killer as i can not advance beyond this point now

Going to try another planet in the meantime.


i found the quickest way to get around this is to save, exit the game, but don't quite, reload. but is a reccuring problem

Link to comment
Share on other sites

Probably mentioned before, hopefully solved in the next patch, in any case trying to offer some help:


The first planet I visited after Telos was Dantooine. I did not solve the Redemption quest there. After Dantooine I visited all other planets and solved most quests. Then I wanted to return to Dantooine. The ship lands, I walk to the exit of the Ebon Hawk, choose the partymembers and after clicking OK get stuck with a black screen and green cursor with nothing happening anymore.


Now for the "trying to offer some help" bit. I have uploaded my last save game, right before I try to leave the Ebon Hawk on Dantooine and get stuck, in zip format (approx 4MB) at the following url www.xs4all.nl/~aphex/kotor2bug.zip


I don't know if it will be of any help, but at least I am trying ;-)

Link to comment
Share on other sites

on dantooine, between the bridge and the exit to the area where the scavangers are is an area where frame rates drop down to single digits.


This is an engine error with regard to Vertex Buffer Objects. It affects ATI cards more readily than Nvidia because of the architecture of the ATI chipsets.


Some users have said:


Put "Disable Vertex Buffer Objects=1" under the Graphics Options in swkotor2.ini helps solve this problem. Some say it does not.


Others have said use different Catalyst drivers from 4.11 all the way to 5.2 (or just the atioglxx.dll).


In reality, it is a multi-faceted problem that has to do with inferior ATI OpenGL support (drivers), the engine itself and possibly other factors that may or may not have to do with particular hardware setups.

Link to comment
Share on other sites

not sure if this has already been listed by anyone and since it's 4 am for me and i've spent the last 5 hours fixing my computer after the last KotoR2 crash with reboot and freeze I'm too tired to read this whole thread.

In any case I have a swoop racing bug or two. When I start my swoop races i keep ending up above the track, it's like i did that reverse boost thing to jump except i dont come back down and i didnt do the jump i just started my engines, so I cant hit any of the acceleration pads, needless to say this makes the race a bit pointless.

Second amazingly enough i beat one of the track record times floating over the course without hitting any of the pads since i cant hit any obstacles either, but the race master doesnt acknowledge this...was only like secodn to last time of the time he lists so maybe thats why... but same thing happened on one of the 3 occassions i managed to run the race normally, actually beat the number 1 time but he says i didnt beat any track records...

Also in the start sequence if i don't hit escape to bypass the video of the ebon hawk flying through the asteroid field the game crashes to desktop. I have the dreaded ATI card which is probably why... have an nvidia lying aournd here that i took out because it kept crashin a different game, maybe i'll swap it back in for playing KotoR2 LOL least til patch comes out.

hmmm... oh my npc friends "explode" periodically... they turn into a giant spikey ball of pixels and i had to restart the game from just after you lose all your friends without any idea of what happened to them because the game crashed and corrupted all 10 of my save game files.

The swoop racing issue is my main concern atm though I dont mind restarting but i loved swoop racing in the first game and I'm really good at it :p so i want to be able to do it in KotoR2 and i cant if i keep ending up above the track for no apparant reason.

Link to comment
Share on other sites

1.) Sometimes text flies by (NPC TEXT and SOUND) that I can't read or hear any of it. This was and still is a problem in the original KotOR as well. It is like an instant fast forward to my next set of conversation choices.


2.) Many times my group NPCs will miss their cue for an interjection. IE: I did the Mandalorian stuck on the cliff part 4 times as a test with the same save game/characters/everything.


The first time the Handmaiden interjected and asked why I spared his life. She then said she'd think on what I had just said.

The next 2 times she missed her cue and on the 4th and final test I did she said her lines. I am positive that it has something to do with the distance she is away from me at the time of her attempt of interjection.


This dissappoints me to no end. How much of the game am I missing because of this? I've witnessed maybe 5 interjections total (not counting Kreia's since she doesn't have to be in the party to open her fool mouth :p )



3.) Lightside/darkside shifts in my party members for no apparent reason. (No I am not using cheats, never used them yet) One minute the Handmaiden is max light, the next she's max dark. This happens when loading up a new map/zone. Same for all party members aside from Kreia.


4.) You can get the handmaiden to equip herself with her 'family jedi robe' over and over and over and sell it off. More of an exploit bug I suppose.


5.) No matter what side (light or dark) or what conversation options I choose with bao-dur I can't get him to say much of anything. After about 2 sets of conversations he doesn't have anything to say because I have nothing to say to him but the 'I'll be leaving' phrase.


6.) Many crashing/system restart bugs. They are so intense that one time the reset bug caused my cat who was laying on my lap to actually get up and take a dump on my KotOR game discs, then refuse to bury them. How many cats do you know that don't bury their crap? I guess he figured it wasn't just his crap on my desk, eh? I think I heard him laughing as he left my room saying 'Sucker!' in cat-talk.






I'm glad I had this chance to pay to beta test your product and find it had the worst ending in the history of gaming attached to it. (Along with many many many bugs)


This is the first game I only finished once and stopped at the 2nd last level of each game there after (a total of 3 unfinished games because I didn't want to witness that poor excuse of an ending again.)

Link to comment
Share on other sites

"Hey, ive lived with the annoying bugs this game has and have otherwise enjoyed it. After playing for the last week or so, i have finaly met all the jedi and gone to Datooine. when i say i want to go to telos the game just goes to the main menu and despite the fact i can move my mouse i can't click on anything or do anything. This happens every single time. If someone could help i would greatly appreciate it "

Link to comment
Share on other sites

Two plot bugs both on Nar Shadaa


1. In the bar of the entertainment district if youve allready done the hutt quests and done GOTO yacht, if you go into stealth mode and listen to the two transohans the journal gets hit with a quest thats allready done


2. I cant finish the quest to get the refugee family of the planet from FASA. Even though I have done GOTOs yacht the dock master still says Ive got to stop the attacks on the freighters....I suspect this is because I fixed the power computer near him but didnt take the hows business quest...As I did the goto yacht quest first. Its in my journal but I cant complete it and Im stuck.


Not sure if this is a bug but the AI is pretty poor during combat. Its possible to run from them and they get stuck, and you can pelt them with ranged weapons fire. Its all too "arcedy" in its feel and intelligence.

Link to comment
Share on other sites

Guest Dowie100

Save Bug:


I have tested this on almost evey planet now,



IF you save and straight away walk into a new area the game will crash every time.



Not sure if I am the only one with this problem


My Specs:


3Ghz P4 Processor


Windows XP SP2

Radeon X300 128MB Ram Graphics Card

Sound Blaster 24bit Sound Card

5.1 Surround Sound

Link to comment
Share on other sites

1. The swoop racing is entirely screwed up. I set the new record on Telos and that idiot Twi'lek said I didn't even finish the race. After I won several times only to hear that garbage, I just decided to leave it. Then on Onderon I tried swoop racing again. Again I shattered the record, and again I was told I didn't finish the race.


2. Dantooine. Need I say more? The entire planet is just one big problem. The rest of the game runs smooth, but Dantooine is literally unplayable. It lags so severely that I lose control of my characters, who sometimes run into angry kinrath of their own will. Actually, I'm sure my characters don't really want to die, but Obsidian's GREAT programmers cause them to. Obsidian, are you guys amateurs? Learn how to optimize a zone. Shrink the draw distance to 3 feet, if you have to! It seems to be an optimization issue as I can get the framerate to playable levels if I face a wall or something (provided I am able to get to a wall before lag takes over), but the minute the open field becomes visible, it's like I decided to run 6 instances of Doom 3 at Ultra quality at the same time. I even dropped the graphics to the lowest possible ... 800x600 60hz, no AA, no AF, no shadows, no grass, low texture quality; the problem persists.


Obsidian ought to be ashamed of themselves. BioWare released KOTOR1 with only a memory leak issue, which they fixed relatively quickly. KOTOR2 has issues so severe that it affects gameplay and yet they refuse to even announce a patch? It's things like this that will cause me to pirate a game or wait until it's $19.99 or less, as this indicates no sign of a $50 work.


I think my computer should be capable...


P4C 2.4GHz @ 3.4GHz (FSB = 1.132GHz)

Abit IC7 (i975 chipset)

[built by] ATi Radeon 9700 Pro 128mb (stock)

2x 256MB OCZ EL Platinum edition DDR (453MHz 2.5-3-3-7)

SoundBlaster Audigy

Antec TrueBlue480

Link to comment
Share on other sites

I don't know if this bug has yet been posted, but I posted a temporary solution to it in the solution forum. Heres the post:




I dont know if this has been posted yet, but I have a temporary solution to all those suffering from VERY poor FPS after loading new areas (which means pretty much all the time). After EVERY load, go into options, then advanced settings, and then TRICK the game into thinking you made a change. For example, I set my AF down one level, then back to its orginal level, and then apply. The game will apply the "new" settings.


Why do this? I used FRAPS to test it on citadel station and this is what I found:


After a new load: 8-10 FPS (horrible)

After a new load and 'faking' and graphic change: 20-25+ FPS (very playable)


These results were consistently reproducable for several hours of gameplay.


Now I know these are bad fps in general, but i have a crappy system--the point is the difference


I hope that the patch fixes this bug becuase it gets REALLY annoying to have to do this after EVERY load, but at least its a temporary fix. I wish I knew what the TRUE source of this bug was because obviously this not fixing the true problem. Hope this helps anybody with the same problems. :D


AMD Athlon 1000+

ATI Radeon 9600 XT

512 ram

SB Audigy 2 zs




I dont know what the actual bug is, but it sounds kinda like after every load the game is not applying graphic settings correctly--forcing the user to have to reapply them after every load. Or it could be that the game is not taking full advantage of the video card untill settings are reapplied...no idea but very annoying. <_<

Link to comment
Share on other sites

I would also like to post a few bugs I noticed, not sure if ALL of them have been mentioned before. They seem like work for a patch, so hopefully someone from the developer team reads this thread at all.


1) The swoop racing problem has already been mentioned. If you forfeit the race once, you will likely be unable to run it again ever (will get course incomplete message, even if you do complete the course).


2) Map Related: Upon entering Residential 082 East (Czerka Corp and Exchange offices) on Telos, there are periodic freezes/drops in frame rate (i.e. one second the game runs smooth, another second the game runs poorly, again, again, ...) This was on GeFroce 5700 Ultra/Windows XP SP2 (driver version 66.93). The workaround is to save a game, exit to the main menu, and reload the game. (OpenGL textures not properly flushed on map change?)


3) Force Alignment Masteries: When party members other than the main player character gain light/dark side mastery, the bonuses do not apply properly to that character. Instead, they seem to apply to the main player character (but I could be wrong here). The stat screen says that the bonus is present (top line), however, the statistic display remains unaffected. I don't know if they are actually applied in the game, however.


4) Upgrade Statistics: When upgrading an upgradeable item that already has bonuses to some statistic, with upgrade items that boost the same statistic, the bonuses do not stack properly.


For example, I have an item called "Corellian Powesuit" [Defense 10, Strength +2]. I upgrade it with Strengthening Underlay [strength +3, Constitution +3]. After the upgrade, therefore, I should get an armor with [Defense 10, Strength +5, Constitution +3]. But I only get an item with +3 strength (judging by description; I'm not sure if it is actually +5 in the game rolls).


Another (more weird) example: an armor called "Mandalorian Combat Suit". It has 10% physical damage immunity. I upgrade it with Ballistic Shielding Mark I (10% physical damage immunity again). The resulting item should have 20% physical damage immunity. The item description however, shows the same bonus twice, making it unclear whether the bonus is actually stacked. [side note: there should be a reasonable limit to how much you can up the % statistics, say, 75% or 95%. Otherwise, there is a possibility of getting it over 100%, which in this case would mean you healing on physical damage. I'm not sure if this would be cheating, though, since there appear to be some enemies, too, that heal on blaster damage.]


Same issue with upgrading ranged weapons with two or more bonuses that add the same type of damage.


5) Dialogues: These are too numerous to mention all, including but not limited to premature voiceover cutoffs, long pauses where they should not be, characters facing away from you occasionally in dialogues (e.g. Atton on Ebon Hawk). I'll mention those I remember clearly. /* POSSIBLE SPOILERS BELOW */


a) When discussing their droid natures with HK-47 or G0-T0 on Ebon Hawk, some dialogue options cause you to drop out of the dialogues prematurely (i.e. with no intention to do so indicated in the dialogue).


b) T3-M4 sometimes plays incorrect voiceovers (belonging to T1-N1 instead). e.g. when asking him about the lost Jedi. Other times, there is a lot of missing voiceovers (text is displayed, but no sound is made).


c) Master Zez-Kai Ell (Nar Shaddaa) repeats the same phrase twice in a row when discussing Force Bonds.


d) If you manage to convince the Handmaiden to become a Jedi Guardian but then say that you have to think about training her, the cutscene of Kreia and Atris sensing her betrayal still plays (even though no character class change is actually made). If you save the game at this moment, then fly the Ebon Hawk to another location, then leave and re-enter the ship, another cutscene will play, after which the screen would go blank and remain that way.


6) Refresh Rate: The game does not allow refresh rates higher than 85 Hz (XP/2000/NT only) to be set from the menu, or the .ini file. The limit of 85 Hz is hardcoded in the executable; there is nothing short of hex editing the hardcoded limit (at VA .7B95F0) from 00 00 AA 42 (85.0f) to 00 00 7F 43 (255.0f) or higher to properly fix this.

Link to comment
Share on other sites

Not sure if this is a "bug" or just poor character management as it were... but my party members Kreia and Atton poof after I'm returned to being my jedi character from having been in solo mode as b-4d4 on telos for the crack czerka mainframe quest. The ithorian dismisses b-4d4 talks to me at length and then I'm solo... no explanation as to where my group is and I can't find them anywhere. NOw I'm beign attacked by far more baddies than I can handle solo, so I'm assuming that either it's a bug and kreia/attom poofed or someone neglected to add the "your friends have returned to <insert wherever here> to wait" line... Rather frustrating since my chances of progressing when i'm suddenly solo and about level 7 or 8 are rather slim.

Link to comment
Share on other sites

Currently I have the alignment bug in which your NPCs will shift from neutral to either LS or DS when all you've done is transit to another map.


Also, during an earlier playthrough, had a bug on Peragus in which the PC skipped the entire dialogue node that allows Kreia to join you and instead, jumped right to the battle with HK-50. Oddly enough, Kreia is a part of that battle, but not actually in your party.


I know I'm running a laptop, but (so far) I haven't encountered any graphic bugs to my knowledge. No lag on Dantooine etc.


System specs:

Dell Inspiron 8200 laptop

Pentium 4m 1.4Ghz

64mb Quadro4 700GoGL


Link to comment
Share on other sites

when the hk baddies come to the base on the onderon moon after taking the shuttle to the polar region, the spoken dialogue is completely out of whack with the written dialogue, they start talking with a line that comes before what's written and then the written dialogue vanishes too fast to read it so the entire conversation is very confused. also i found a czerka employee at the base who asked me to lead him out. I agreed but he stopped following me in the next room, talked to him repeatedly (he gives you the option of saying stop following me or keep following me) using the keep following me choice, but he did not move so in the end i had to leave the place with him standing around in the middle of nowhere.

Also i've started kotor2 on 3 seperate computers now (2 with nvidia cards one with an ati card all 3 pentium 4 and 1MB RAM, all 3 with the latest driver versions) and each time when i go to swoop race on telos i've had the problem i mentioned in an earlier post where my swoop bike floats along the ceiling unable to hit the acceleration pads, even so i beat the number 4 track record but the racing master does not notice this. in addition all 3 either stutter, knock me to desktop or compleely crash the game if i dont hit esc to skip the opening movie sequence.

Laslty, after fixing the issue mentioned in my last post where my group members were gone after the b-4d4 scenario (i could get them back by selecting them off change group members screen) i had to repeatedly turn solo mode on and off for atton and kreia to finally start following me around again and once they did the game crashed when i zoned from the czerka office sector to the ithorian sector, which corrupted my 3 most recent save files.

Just as a sidenote, i can live with almost all of these issues except the swoop bike thing. i want to be able to race :lol:

Link to comment
Share on other sites

Haven't finished the game yet, but these are the bugs that I've seen so far(not including the occasional weird graphic bug, of course):


1) Someone has already mentioned the irritating quality of certain armor which causes some of their bonuses not to stack; i.e. if you add a Ballistic Overlay to certain Mandolorian armors which already have protections against Bludgeoning, Piercing, and Slashing attacks, the protection from the Ballistic Overlay will not stack with the protections that are already part of the armor. This bug has already been mentioned, but I thought I'd add that, logically, I can see no reason for the protections not to stack. If you take a piece of metal that will protect you from a knife, and then add another piece of metal to it which will also protect you from a knife, then the resulting object is equal in strength to both of its component pieces.


2) In addition to this, it also seems that Keen bonuses don't stack. If you take a weapon with a 19-20 Critical Threat range, add a Keen bonus to it to make the Crit. Threat range 17-20, then add another Keen upgrade, the weapon will still show a Crit. Threat range of 17-20. I can understand why the developers might intentionally prevent Keen bonuses from stacking, since a lightsaber can get to be pretty disgusting with the right upgrades, but Keen bonuses DID stack in the original KOTOR, so I thought I'd mention it.



WARNING: The next two bugs contain SPOILERS.



3) When you complete the Skill task for Kreia, in which she supposedly increases both your lowest and your highest skills as a reward, this doesn't happen. You still get the Force increase and the XP, but not the skill increases.


4) I'm not certain that this is a bug, but it seems like it might be, so I thought I'd mention it. On Onderon, if you have the Handmaiden with you, there seems to be a bug with her influence increasing. There are two best Light Side choices to give your two visas to: Telryn and her children, and the Republic agent. When you give the first visa to either of them, the Handmaiden will make a comment and your Influence with her will increase. When you give the second visa to the other person, though, the Handmaiden will make the comment, but not give you the Influence increase. For example, I give the first visa to Telryn, and get the compliment and Influence increase from the Handmaiden. Then I give the second visa to the Republic agent, and she still makes the comment, but there's no Influence increase. The same thing will happen if you give the first visa to the Republic agent, and then second to Telryn; you'll gain Influence with the first visa, but none with the second.



EDIT: Heh, I found out what the problem was with the Handmaiden's Influence, thanks to the damned-handy KOTOR Saved Game Editor. Later on, on Dantooine, she wasn't gaining Influence when she was supposed to, either, and I started to become concerned that she was bugged. So, I downloaded the Editor, and discovered that she was already at 100. Oops. In my defense, though, I had no way of knowing that, since she still refuses to answer some of my questions with "Influence: Failure" as the given reason. Guess I'll have to kick her ass in training again first, or something.

Edited by AcornArmy
Link to comment
Share on other sites

I think my computer should be capable...


P4C 2.4GHz @ 3.4GHz (FSB = 1.132GHz)

Abit IC7 (i975 chipset)

[built by] ATi Radeon 9700 Pro 128mb (stock)

2x 256MB OCZ EL Platinum edition DDR (453MHz 2.5-3-3-7)

SoundBlaster Audigy

Antec TrueBlue480


I think this may be due more to an ATI driver issue than Obsidian's programming. My PC is quite a bit less butch than yours and I have -no- framerate problems whatsoever on Dantooine. I'm using:


Athlon 1.4 Ghz Thunderbird

Biostar M7MIA-R motherboard (AMD 761 chipset)

ATI Radeon 9000 Pro, 128MB



With the ATI Catalyst 4.12 drivers. So the only things that I can think of that might cause such a difference are either graphics driver problems(depending on which drivers you're using, you didn't mention them) or, possibly, the 512MB of PC RAM instead of the two 256MB-- but the RAM seems less likely, with all of the other hardware upgrades on your PC.

Link to comment
Share on other sites

IMO this is a buggy game. Reason I say this is because the Xbox version has the same issues. I had some many issues with the Xbox version, along with incredibly slow load times, I got sick of it and picked up the PC version. At least the load times arent slow anymore. The problems are various and to numerous, main ones are characters not facing you when talking, not properly applying stackable bonuses to items, cut-scenes cutting off, very poor framrates in (Khoonda primarily), and my Damage and To-Hit bonuses do not seem to be applying.


Im familiar with the D&D3.5 rule-set, and I dont think To-Hit bonuses, and Damage Bonuses are not being applied properly. Now for example, starting on the Xbox, I have on fight with 6 or so baddies and took them all down in about 4 minutes, but a fight with 1 individual (Boss) took less then a minute. Same exact fight, except I have a higher Strength, better To-Hit, 6 baddies took again about 4 minutes, but the Boss took well over 5 minutes. Unfortunately the game doesnt allow you to see the math calculations going on behind the scenes, so I have no idea of my rolls and the opponents rolls.


As a side note to this, one time while goofing with something (Xbox version), dont remember exactly what I was doing, but all my Stats dropped to 8...and wouldnt reset until I restarted from a save.


Another item to mention, is on the PC version the main character seems to take longer to get in battle and start fighting then on the Xbox. There are no intiative checks, so I know its not that, would make sense if it were. Also, I should have a better to hit with a balanced weapon then having 2 seperate weapons (most of the time anyway). I know this uses a refined version of the D&D rules. But if your going to apply a rule-set, please follow it. That way characters can be designed and built up correctly to our (the players) specifications.


Dantoonie is my first planet, and I only have graphic problems in Khoonda...but just Khoonda...no where else on Dantoonie. I fixed this by going into the graphics options and turning everything down and off, and went right back to the game. I needed to do this everytime either dialog was started or I went to the menu screen (Item/Character/Map/etc...).


Those people that say they are not having problems, proboly do not notice them. With all these inconsistencies, I feel like Im playing a game thats still in Beta. :-


Anyway, here are my specs:


AMD64 FX-55

Abit K8T800 Pro

2GB DDR-400 Corsair

X800 XT Platinum Edition

SB Live Audigy2 ZS Platinum Pro

Saitek GamerBoard

Razer Diamonback High Precision Gaming Mouse

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...