Jump to content
  • 0

Party selection is broken. (swapping or assigning members fails)



I have the problem since I have more than 6 Members to choose from. In my Case since I've met "Hiravias". I am not able to swap party members because seemingly no matter which strategy I am using to, the character which is supposed the be there is not;
The castle dialog menu to assign shows everything is alright, but the in game member slot stays empty, no visible character, no portrait, no message in the console that a new party member has joined

Swapping characters back does not help either, the because no member I choose appears as a 6th member from now on. 
So It is essentially not possible to change the party. 

I've tried one thing that worked for the first time: Loasing a savegame before the bug event, returning to the castle, dismissed Kana, then went out to meet the new party Member and let it join during the first dialog. Then I went back to the castle and swapping worked. BUT only until my next journey into the underlying dungeon. As I returned from the dungeon to the catle and tried to swap the members, the bug was there again and it seems if the bug appears for the first time it is permanent and the party slot is "lost" for reassignments..

This is a bug that has a huge impact on the game play and I read some posts that I am not the only one who suffers from it. Please do something about it.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

It's fixed in 3.04, which is currently in beta.

"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke | Permanent Per-Rest Bonuses | PoE Items for Deadfire | No Recyled Icons | Soul Charged Nautilus


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...