Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Paladin stuck in walking animation

bugs paladin

  • Please log in to reply
11 replies to this topic

#1
magicwallis

magicwallis

    (1) Prestidigitator

  • Members
  • 22 posts
  • Pillars of Eternity Backer
  • Deadfire Backer
  • Fig Backer

Not sure what caused it but one of my Paladins is stuck in a fast walking animation.  Not game breaking I know, but it is irritating.

 

Save: https://drive.google...iew?usp=sharing

 

Thanks for any support you can give.



#2
Shadowhawke

Shadowhawke

    (0) Nub

  • Initiates
  • 3 posts

I got the same bug on my druid.
I did a google search to find a solution and I came across your post.

I was able to solve my problem by adding Pillars of Eternity to Steam as a non-Steam game.

I have the GOG version.

I launched Pillars of Eternity from my Steam launcher and my main character was no longer stuck in the fast walking animation.

I hope this helps.

 

 



#3
Shadowhawke

Shadowhawke

    (0) Nub

  • Initiates
  • 3 posts

The bug came back.
I had to reload from a previous saved game to get rid of the stuck fast walk animation.
I lost 30 minutes of game time.



#4
Sking

Sking

    QA Lead

  • Developers
  • 650 posts
  • Location:Huntington Beach

Hey Magicwallis,

 

There used to be an issue pre3.02 where items that granted speed bonuses would cause players to 'fast walk'. Is your game patched up to 3.02?

 

I got your back

-Sking



#5
Shadowhawke

Shadowhawke

    (0) Nub

  • Initiates
  • 3 posts

My game is patched to 3.02. 
 

I also have White March Part 1 and 2.

I get this bug every now and then, but not sure how to reproduce the glitch.

Maybe I should stop using movement speed as my rest camp bonus.



#6
magicwallis

magicwallis

    (1) Prestidigitator

  • Members
  • 22 posts
  • Pillars of Eternity Backer
  • Deadfire Backer
  • Fig Backer

Hi Sking

 

I am running 3.02.



#7
sman

sman

    (0) Nub

  • Initiates
  • 2 posts

Hello Sking,

 

I've encountered this same issue with my level 2 paladin. I'm running 3.03. Seems to occur sometimes after enabling Zealous Charge. It looks similar to descriptions I've read of the Boots of Speed bug that was resolved in a previous patch.

 

Great game so far BTW!



#8
Jojobobo

Jojobobo

    (9) Sorcerer

  • Members
  • 1287 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

I mentioned this in a recent thread, I found resting (with one of the Caed Nua resting bonuses) and reloading fixed it. This was with the movement speed resting bonus from survival causing the issue in the first place, so maybe it's not that related - still worth a shot.



#9
sman

sman

    (0) Nub

  • Initiates
  • 2 posts

Hello Sking,

 

Here's the workaround I'm using (similar to Jojobobo's solution):

 

1) Glitch is triggered sometime after enabling Zealous Charge and certain combat situations (still don't know the exact trigger for the glitch)

2) once combat is over, deactivate Zealous Charge (glitch will still be in effect)
3) save game

4) reload that save (the glitch is gone)

 

This has worked for me on 2 saved games that had this issue. Other things I tried like resting, leaving the area, traveling in the world map, dropping party members etc didn't help.

 

Once again, the game is great, thanks for your continued support.



#10
Pus-in-Boots

Pus-in-Boots

    (1) Prestidigitator

  • Members
  • 27 posts
  • Location:Civitas Beatae Virginis, Poland

I have this problem with Pellagina only. Others execute normal running animation while she just walks. Like a proper lady.

 

Nothing have worked - I've tried resting, reloading, etc. My game version is also up to date. WM 1&2 installed.


Edited by Pus-in-Boots, 03 September 2016 - 09:43 AM.


#11
dunehunter

dunehunter

    (7) Enchanter

  • Members
  • 961 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Gold Backer
  • Fig Backer

I have this problem with Pellagina only. Others execute normal running animation while she just walks. Like a proper lady.

 

Nothing have worked - I've tried resting, reloading, etc. My game version is also up to date. WM 1&2 installed.

 

Same issue come across to me recently, are there any solution to this problem? Also only Pellagina is bugged.

 

Rest with survival bonus and reload fixed the issue! thx!


Edited by dunehunter, 18 January 2018 - 01:01 AM.


#12
dunehunter

dunehunter

    (7) Enchanter

  • Members
  • 961 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Gold Backer
  • Fig Backer

So the Zealot Speed aura is just broken because whenever your paladin picked it,  he gonna stuck in walking animation zzz. Hope to see a fix!

 

Btw I have no extra movement bonus from rest, just Zealous Charge and there is a very high chance my paladin will be bugged after combat, stuck in walking animation.

 

OK more details on the bug, so when the Zealous Charge is off, both save/load and quicksave/quickload works normally.

 

When Zealous Charge is on, save/load, quicksave/quickload will result my paladin into walking animation when not in combat.

 

When in combat, both case the paladin will run not walk.

 

@Sking wound you mind take a look into the issue? I think based on my description, it is quite obvious that save/load will mess up with paladin's speed when zealous charge is on.


Edited by dunehunter, 21 January 2018 - 06:09 PM.






Also tagged with one or more of these keywords: bugs, paladin

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users