Jump to content
  • 0

The map is not displayed correctly


D101101

Question

Location map does not work.

World map works fine.

 

Load the attached saved game.

Press 'M'.

 

Save game

Log file

System:    Host: Arch Kernel: 4.2.4-1-ARCH x86_64 (64 bit) Desktop: Xfce 4.12.3 Distro: Arch Linux
Machine:   Mobo: Gigabyte model: B85-HD3 v: x.x Bios: American Megatrends v: F10 date: 08/18/2014
CPU:       Quad core Intel Core i5-4690 (-MCP-) cache: 6144 KB 
           clock speeds: max: 3900 MHz 1: 3829 MHz 2: 3880 MHz 3: 3860 MHz 4: 3815 MHz
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Card-2: Advanced Micro Devices [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
           Display Server: X.Org 1.17.2 driver: fglrx Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD TAHITI (DRM 2.43.0, LLVM 3.7.0) GLX Version: 3.0 Mesa 11.0.4
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel
           Card-3 Advanced Micro Devices [AMD/ATI] Tahiti XT HDMI Audio [Radeon HD 7970 Series]
           driver: snd_hda_intel
           Card-4 Asahi Kasei Microsystems AK5370 I/F A/D Converter driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.2.4-1-ARCH
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 94:de:80:c5:75:ae
Drives:    HDD Total Size: 1240.3GB (19.4% used) ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
           ID-2: /dev/sdb model: SAMSUNG_HD120IJ size: 120.0GB
           ID-3: /dev/sdc model: KINGSTON_SV300S3 size: 120.0GB
Partition: ID-1: / size: 20G used: 11G (58%) fs: ext4 dev: /dev/sda4
           ID-2: /home size: 740G used: 214G (31%) fs: ext4 dev: /dev/sda5
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 55.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 156 Uptime: 13 min Memory: 2554.3/7860.1MB Client: Shell (bash) inxi: 2.2.28

s_1446033904_5243618_5e9225dad9.jpg

s_1446033904_5808415_b66a71b293.jpg

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Hello D101101, 

 

Welcome to the forums! I loaded up your save and didn't see your issue. Make sure that your graphics card are up to date and verify your game cache in Steam. In your Steam Library, right click Pillars of Eternity > Properties > Local Files > Verify Integrity of Game Cache. That should clear up the issue for you.

 

Thank you for your support!

Link to comment
Share on other sites

  • 0

Hello again,

 

Our Linux tester loaded up your save and didn't have any of the issues you are experiencing. It could be a hardware issue on your end. 

 

A user on the forums has created codes on how to fix some of these issues. Take a look and see if that works for you.

http://forums.obsidian.net/topic/82667-rendering-issues-on-linux-now-theres-a-work-around/?hl=%2Blinux+%2Bhack

 

Thanks

Link to comment
Share on other sites

  • 0

Mesa 11.0.4

Our Linux tester loaded up your save and didn't have any of the issues you are experiencing. It could be a hardware issue on your end.

 

Apparently it only happens with Mesa 11 and not with earlier driver versions. (And only with AMD cards.)

 

Until now the only people who had Mesa 11 installed were users of small bleeding-edge Linux distros, which is why not many people complained about it.

But a new big Ubuntu release just came out this month, and it includes Mesa 11, so expect

this to become more of a mass problem if Obsidian devs don't hurry to fix it on the PoE side!

 

While a Mesa bug-report has been opened, the take-away from it is that this is not actually a Mesa bug. Just a performance optimization that was added to Mesa which should not affect any standard-compliant OpenGL program - but exposes a bug in PoE's minimap fog-of-war  rendering code.

 

So the Obsidian devs can't wait this one out - it has to be fixed on the PoE side.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...