Jump to content
  • 0

2.02 Patching error?


wanderon

Question

Got this message on Patch log (GOG):

 

Pillars of Eternity patch log
File not found (for patching): C:\GOG Games\Pillars of Eternity\PillarsOfEternity_Data\assetbundles\prefabs\objectbundle\draining.unity3d
 
 
I originally assumed I only needed the WM 2.02 patch and downloaded and installed that first - then read I needed both patches and downloaded and installed the other one - at the end of the installation process I got a message that errors had occured and to check the patch log for details (above).
 
Do I need to re-download/reinstall the patch with the error message?
 
When the game starts it shows 2.02.0749 PX1

Nomadic Wayfarer of the Obsidian Order


 

Not all those that wander are lost...

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

I downloaded both 2.02 gog patches straight from the beginning, tried to install the main game's patch first and got an "error" message in the end, I then proceeded to install the expansion's patch and it installed without any error whatsoever also in the bottom left corner when I run the game the patch version is the correct one. I don't know whether it's working as intended or not though. So far I haven't had any crashes or weird textures or anything.

 

PS: For 2.01 I installed both.

Link to comment
Share on other sites

  • 0

I also have had this issue and ended up back with 2.01 because it is totally wacked once I patch the main game after White March patch number 2.

To clarify what I did I am copying what I wrote elsewhere since  a dev commented here and perhaps will see it and it will help.

 

I am using the GoG version and when I Patch White March it seemed to be fine with only 2 errors for 2 files I modded anyway.

Both files are veterans recovery.

However when patching the base game with GoG version 2.5.0.11 I get a lot of errors
Then the game loads and my cursor is the ground walk cursor and then it crashes when I try to load a save game I have a huge list of patch errors.

In the patch log it states it is trying to upgrade from version 2.4.0.9 but in order to not have a pink mess in White March I had to patch the Base game to version 2.4.1.10 These numbers correlate to GoG versions

2.4.0.9 was patch 2.0
and 2.4.1.10 patched it to 2.01
However the patch 2.5.0.11 which is supposed to be from 2.01 to 2.02 is looking for version 2 which is 2.4.0.9

It seems impossible to patch this manually with 2.5.0.11.

Potentially I could go back and install 2.4.0.9 and see if I can use 2.5.0.11 from that but it is incredibly time consuming.

As it is the install process unless I do it from safe mode is arduous and lengthy.

What patch for GoG am I supposed to use to go from 2.01 with White March installed?
Do I only use White March Patch for 2.02
Totally confused at this point.

 

As I have written elsewhere I would suggest creating some method of communication that is more direct or something to handle this GoG mess.

I think that install instructions are imperative as is cross platform patch notes and direct communications from the main developer which in this case would be Obsidian.  A shared news feed would be awesome. As would requiring them to add install notes and known issues in a readme and visibly on their website under the PoE forum space.

Edited by sapientNode
Link to comment
Share on other sites

  • 0

it looks like after this patch  game is lucking of draining.unity3d... so in the game no weapon has draining system

 

but if you copy draining.unity3d from previous version and pasted manually, than patching error won't occur... still question is if game works as intended to be

Edited by Gs11
Link to comment
Share on other sites

  • 0

So I just started a new game with the addon, got there and was welcomed by this:

Anyone knows why? Bad installation (no prompts of something going wrong)? Any solution? Everything else works well. Graphic card drivers up to date. It's not IEmod.

 

 

post-151733-0-58591000-1443883908_thumb.jpg

If my post hasn't been edited yet, I'm still looking to find the error I made typing it.

Link to comment
Share on other sites

  • 0

Looks like a bad install. Pink blotches are missing textures. Are you on GOG.com and manually patching?

 

If so, you need to install both patches for the game to work: The patch for the base game AND the patch for the expansion.

"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke | Permanent Per-Rest Bonuses | PoE Items for Deadfire | No Recyled Icons | Soul Charged Nautilus

 

Link to comment
Share on other sites

  • 0

^ it should, yes.

"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke | Permanent Per-Rest Bonuses | PoE Items for Deadfire | No Recyled Icons | Soul Charged Nautilus

 

Link to comment
Share on other sites

  • 0

Hi

 

Thought I'd pitch in we my experience of updating/installing the game (with expansion) to 2.02. Running the base game patch first (patch_pillars_of_eternity_2.5.0.11.exe) resulted in a file not found error. I didn't bother with the expansion patch.

Pillars of Eternity patch log
File not found (for patching): E:\games\Pillars of Eternity\PillarsOfEternity_Data\assetbundles\prefabs\objectbundle\draining.unity3d

 

I then uninstalled the game and used the full 2.02 installer (setup_pillars_of_eternity_2.5.0.11). This installed but crashed with an undefined error within a seconds of the intro video playing.

 

Not sure if it matters, but I do have GoG Galaxy installed though I don't use it.
OS Windows 7 Pro 64bit

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...