Jump to content
  • 0

Fix: Screen Solid Black On Launch (Mac)


Branimir

Question

So, launched your game and everything's black but you can hear the music and see your mouse cursor? Its a bug in Fullscreen. I've discovered many ways to fix it. Firstly, what's happening is that it is not in Fullscreen, its windowed, but the game is telling it to black out everything. The intended purpose is blackening unused screen space when running the game at a lower resolution while the monitor is at a higher resolution. Fullscreen fails so it reverts to a window, and the game is programmed so that when it is set to the monitor resolution it goes into Fullscreen even if Fullscreen is unchecked, result is this bug.

 

Q: Why hasn't Obsidian fixed this? The game has been out for months!

 

A: From what I hear they're claiming its a bug in Unity, and Unity isn't their product so they can't alter it. But like all problems that haven't been solved the real reason is lack of imagination. If they removed the feature that makes it go into Fullscreen even if Fullscreen is unchecked when a window is at the monitors Resolution, or disabled the blackening of unused monitor space, that would fix the bug but maybe that's automatic stuff that Unity puts in I'm not sure how much they can do working with an engine they can't manipulate. But one fix Obsidian definitely could do is remove the Unity Fullscreen entirely and utilize the Mac Fullscreen. On a Mac we have a built in Fullscreen which is disabled on PoE, in Yosemite it's the green button, on Mavericks its the arrows icon in the top right. And personally I prefer the built in full screen because I can easily switch to see my desktop without effecting the game, and access the top menu from fullscreen. Not knowing how isn't an issue since the internet was invented, or at least since the invention of search engines. 

 

Fix #1: Playing in Unity Fullscreen

The only way you can play using their buggy Fullscreen is by connecting a second monitor, with mirroring off, so the other monitor goes black instead. However this causes the game at all resolution settings to cut off all 4 edges of the screen for me. If that happens you can fix it by (1) setting it to a lower resolution and (2) windowing it then (3) exit and (4) relaunch then (5) full screen it and it should be fine on launch from then on.

1920x1080 is default for me so I lowered to the next option under 1600x900 and when I went to full screen from launching in window it became 1680x1050. The other issue is that the game still exists in the other monitor you just can't see it; you can click and it will run your people that way; and your mouse goes past the screen making Screen Edge Scrolling annoying (because it still uses the edges of the first monitor). Basically just write off that edge and use the arrow keys. If you have something in Mac Fullscreen on the other monitor it won't go black but you can't interact with it while the game is in Fullscreen because the mouse and keyboard are locked to it.

 

Fix #2: Change it to windowed, in game, while its black. 

There's no way to manually change the resolution. But for a split second when you hit Cmnd+F you can see the windowed (but at your comps resolution so taking up the full screen) game for a second. In that second you can interact with the game. Warning: This is difficult and annoying but doesn't take much time and is a permanent fix if done correctly. Spam Cmnd+F quickly while you do this;

1: Go to Options

2: Go to Graphics 

3: Select a lower resolution from the Resolution drop down.

4: Fullscreen Checkbox is unchecked, make it checked. Checking Fullscreen will make it attempt and fail, causing it to revert to a window of a smaller size, lower res window means it won't be trying to go fullscreen anymore (no more black screen bug). Not checking the box will make the game assume you want to keep the current hybrid/bugged fullscreen setting, which will make the window smaller but the black screen will still be an issue. 

5: Click the X to close the window

6: Save Settings when the in game popup asks.

It should launch in window and be playable from now on. 

WARNING: DO NOT raise the resolution to the same or higher than your monitor resolution, it will recreate the bug. 

Note: Sometimes the software fails to revert to Fullscreen when you change the game resolution to the same as your monitor resolution while windowed, resulting in a window that takes up your full screen, parts of which will be off of the screen. If you want that, be willing to have to repeat the glitch fix process before you do it as you may have to do it several times. Also, even if you do get it to work, on launch the glitch will be back. 

 

Fix #3: Change it to windowed, in game, at 90º

1: Change Display settings to Rotation: 90º

1a: Apple Logo in the top right

1b: System Preferences...

1c: Display(s)

1d: Rotation: 90º

2: Turn mouse+head 90º

3: Launch Game. It won't black out the screen because the default resolution is different from the screen now. Which can only be done with Rotation since the games default resolution is automatically the monitor resolution but has no options for reverse dimensions of screen resolutions, so it won't try to force Fullscreen.

4: Lower the Resolution in game

4a: Go to Options

4b: Go to Graphics 

4c: Select a lower resolution from the Resolution drop down.

4d: Click the X to close the window

4e: Save Settings when the in game popup asks.

5: Change Rotation to Standard and play normally. 

It should launch in window and be playable from now on.

WARNING: DO NOT raise the resolution to the same or higher than your monitor resolution, it will recreate the bug. 

Note: Sometimes the software fails to revert to Fullscreen when you change the game resolution to the same as your monitor resolution while windowed, resulting in a window that takes up your full screen, parts of which will be off of the screen. If you want that, be willing to have to repeat the glitch fix process before you do it as you may have to do it several times. Also, even if you do get it to work, on launch the glitch will be back. 

  • Like 3
Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0

I have not found any of these methods to work. I've spammed command+F and it hasn't done anything. I've heard good rings about the game but you can't tell if they're true of not if you can't play the game. The game launches and I get a black screen. Then I get the multi-colored mouse saying it's loading. Then I do the four finger swipe to get out of it. I right clicked on the PoE icon in the toolbar and it says it's not responding. I have no idea why it is not working. Far as I know OS X 10.9.5 works. I'll attach my computer specs. It also pains me I've and to search about 30 min for even a small lead that bears no fruit. I don't even know if this is going to get read anyway.

post-155236-0-54065600-1435877874_thumb.png

Link to comment
Share on other sites

  • 0

Hello, The Mighty Sutur.  I'm sorry for your inconvenience.  Does your MacBook have the option to switch between video card options?  Turning off the auto-switch between video card option has helped many members of the forum be able to play the game.  We are currently aware of the issues being experienced on OSX and are working towards fixes for them.  Thank you for your support and patience during this issue.  

 

Please update the thread with any new information you have.  If that does not work please include an output log with your next post and we'll go from there.

- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Link to comment
Share on other sites

  • 0

I recently switched to a 4k monitor on my Mac Pro and ran into this same issue afterwards... I used to be able to play full screen at my previous monitor's full resolution...  Nothing I do prevents the black screen on launch...

 

Even when I can get the game to display in window mode and see the menu, it is still at a much higher res and cuts off most of the screen... If I try lowering the resolution, it goes black...

 

Really want to play this at my native 4k resolution...

Link to comment
Share on other sites

  • 0

Hello, SuperSirLink.  Our current fix for 4k and Retina displays is to lock the resolution down, as higher resolutions are not playing nicely with our game and the Unity engine on OSX.  Refer to this thread if you have any other questions regarding the current issues with higher res displays.  Sorry for the inconvenience, and thank you for your support.

- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Link to comment
Share on other sites

  • 0

That's not really a fix as you are basically saying you can't run 4k or "retina", which is fine on a macbook; but I am not on a MacBook Pro, but instead on a Mac Pro with a 980Ti... Performance is fine... Would suggest finding a way to exclude Mac Pro users from this restriction...

 

Having said that, Now that I reverted the version to 1.06 it has not been an issue.  But I imagine once 2.0 is released this would become a problem again unless fixed...

 

Please don't make me boot to Windows to play this game...

Link to comment
Share on other sites

  • 0

Hello celliott,

I just purchased the game a week back and have had a great time playing it. I have now encountered this black screen with only the hand courser problem on startup. It was starting fine for the last week. I play the game through Steam. I might be wrong but it seemed to start happening with the new

2.02 patch. Is there a connection? Why would it work for a week and then start happening? 

What is the update on a fix? 

Thanks for any help.

 

iMac 27"

Processor 3.4 GHz intel core i5

Memory 8 GB

GPU Nvidia Geforce GTX 775M 2048MB  ( Newest Drivers) 

Link to comment
Share on other sites

  • 0

Celliott post:

 

 

Hello, SuperSirLink.  Our current fix for 4k and Retina displays is to lock the resolution down, as higher resolutions are not playing nicely with our game and the Unity engine on OSX.  Refer to this thread if you have any other questions regarding the current issues with higher res displays.  Sorry for the inconvenience, and thank you for your support.

In my case this doesn't fix the fact that mouse clicks no longer interact with the game (in full screen mode).

 

This is getting to be a mess and, certainly in my case, is a direct result of upgrading to El Capitan.

Link to comment
Share on other sites

  • 0

For the record, neither Wasteland 2 or Shadowrun (any of them) display this behavior on my 27" iMac.  So clearly there is something that Obsidian can do to fix this problem.  Whether or not they will . . . 

This is both true and false. I have tested Wasteland 2 on a Mac and the issue still is happening. However testing the game on Wasteland 2 directors cut, the game plays fine, which might be using a different version of Unity. I've also tested Shadowrun Returns and I cant even gain access to the game, even in windowed mode.  

 

Thank you for your feedback.

Link to comment
Share on other sites

  • 0

Hi,

 

I just experienced the same problem, however got it to work. I just changed from an iMac 21' to an 27' and restored my old system via Time Machine. I thought the issue might had been related to the higher resolution of the 27', and it was.

 

I just went into windowed mode (cmd + f) and changed the resolution. And waited to see if it worked. It seems pretty random, and I have to do it every time, but it is no biggie. Also, if one resolution works one time, it will probably not the next time the game is opened. But just changing back and forth seems to get it to work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...