Jump to content
  • 0
msmc7

No longer able to change screen resolution

Question

Description:

At a certain point (I'm not exactly sure when/how), I lost the ability to change the screen resolution in the Graphics tab in the Options menu. The best/only option I'm given is 1200x800 (see screenshot include in Dropbox-linked folder), whereas my Macbook Pro (which has a Retina display) previously has been able to offer/handle/support much higher resolutions.

 

Steps to Reproduce the Issue:

(I'm not sure how to reproduce the issue on someone else's machine.)

 

Important Files:

 

https://www.dropbox.com/sh/9d58neg386l83ep/AAClBzLhmvo9_8gM_rX1wVlPa?dl=0

 

Savegames

Output Log

System Specs

Screenshot

 

 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Just to note, we aren't actively restricting what resolutions are shown. Unity only gives two options to handle how the Mac builds are made using fullscreen. One options disables all external monitors and treats the main game screen as just pure pixels. This mode was causing lots of crashes on various Macs. Thus, we had to ditch it as it is some inherit Unity issue we can't control.

 

The other mode simply just asks the OS what resolutions are available and treats it like a normal OS monitor. However, with the way Macs handle their retina stuff the OS says the top resolution of the screen is only 1440x900 in your guy's cases (since that is what the OS is treating it as as they do some pixel doubling magic in the background for their high resolution stuff). Again, we don't control what values we get back from the OS as valid options as the Mac's abstract this away. Thus, you are seeing just the subset of actual options your monitor is capable of. This is obviously not ideal but, when having to choose between a mode that crashes people's game and one that doesn't, we went with the one that doesn't.

 

This mode is built into Unity's executable so there isn't a way to toggle it on or off during runtime with some checkbox (like "Use high resolution options"). Otherwise we would.

  • Like 1

Twitter: @robyatadero

Share this post


Link to post
Share on other sites
  • 0

Hi I'm also having the same resolution issue with the recent update...unable to customize my resolution settings.

 

Also Songsmith bounty quest is not loading.

 

HHaaallpp! 

Share this post


Link to post
Share on other sites
  • 0

Hello, all.  As Khovarast has mentioned we are aware of this issue and working on a fix.  In the mean time please try the following as it has helped some players with the same issue.

 

Open a terminal window and type:

 

o defaults delete “unity.Obsidian Entertainment.Pillars of Eternity.plist”
o defaults delete com.unity3d.UnityStandalone.plist

 

Thank you for your ongoing support and patience during this issue. 


- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Share this post


Link to post
Share on other sites
  • 0

Was about to post the same issue and thankfully found this thread so will just add to here that I'm also experiencing the same issue. I'm on a 2012 15" Retina MacBook Pro. When I first started the game I could choose up to 2880x1800, then it dropped to a max of 1680x1050 and now it's dropped down to 1440x900. I'm also not able to run the game in windowed mode.

Share this post


Link to post
Share on other sites
  • 0

Tried the above fix, new default resolution became 1920x1080 but selectable options remained 1440x900 and 1200x800. Still unable to get up to native resolution of 2880x1800

Share this post


Link to post
Share on other sites
  • 0

Hello, all.  As it turns out the locked resolution is by design.  This was to prevent other bugs with Retina displays and how they were affecting the overall performance on MacBooks specifically.  We think that a locked down resolution is much better than the game not running at all for a large group of players.  The workaround I posted above will let you play in 1080p, but higher resolutions and other options will not be available.  Sorry for the inconvenience and thank you for understanding.


- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Share this post


Link to post
Share on other sites
  • 0

Agree with above poster. 

 

If it's confirmed, in fact, that there's no fix coming, is Obsidian offering refunds to those who purchased the game to play on a Mac? At this point, it's really unplayable at such low resolutions on a 2800 x 1800 Macbook Pro retina. It's unfortunate because I really loved the game, so ideally there'd be some kind of fix to bump the resolution back up. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hello again.  The bug stems from Unity and affects games such as Wasteland 2 and Hearthstone as well.  We understand that this is not completely ideal and hope that together with Unity we can solve the issue completely.  Thanks for your ongoing support.


- Refer to this thread if you are having trouble finding any information I requested http://forums.obsidi...eport-an-issue/

Share this post


Link to post
Share on other sites
  • 0

I really do appreciate the informative and frank updates, celliott, but I must say--while I don't play many non-console games, I don't think I've ever encountered anything like this "locked resolution" issue/solution, i.e. having something I paid for suddenly downgraded like that. I also rarely post game grievances online, but I do think something like either a partial refund or some kind of credit for The White March is a legitimate ask to Obsidian--as I can say that I am definitely having a different, lesser gaming experience with this lower-locked resolution.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks Celliott for the responses. I agree with msmc7. Paying the same price to have a lesser experience than PC users, when the game was advertised to be Mac compatible, doesn't seem quite fair. Alternatively, maybe we can remove the resolution restriction and simply advise players to play at a lower resolution, but allow those who want to risk the crash play at a higher resolution until a better fix can be implemented.

Share this post


Link to post
Share on other sites
  • 0

I am not able to use the workaround:

 

  -- I can delete com.unity3d.UnityStandalone.plist typing "defaults delete com.unity3d.UnityStandalone" (with the plist extension is not working);

  -- cannot find anywhere the unity.Obsidian Entertainment.Pillars of Eternity.plist file

 

After deleting only one plist, resolution is still locked to 1440x900 and 1200x800

Share this post


Link to post
Share on other sites
  • 0

...Why not showing a warning that full resolution is do demanding for this Macbook? Or like the orginal infinity Engine Games a "enable unsupported resultions" switch?

This is something that should be seriously considered. What graphics settings people use should be their own choice, and while Obsidian should feel free to offer advice ("Your system specification will likely result in a poor experience with this setting") they should not arbitrarily restrict resolution settings - not least since it then fails to account for future developments (i.e. what happens 10+ years later when Mac notebooks are available with GPUs powerful enough for Retina+ displays?).

Share this post


Link to post
Share on other sites
  • 0

 

...Why not showing a warning that full resolution is do demanding for this Macbook? Or like the orginal infinity Engine Games a "enable unsupported resultions" switch?

This is something that should be seriously considered. What graphics settings people use should be their own choice, and while Obsidian should feel free to offer advice ("Your system specification will likely result in a poor experience with this setting") they should not arbitrarily restrict resolution settings - not least since it then fails to account for future developments (i.e. what happens 10+ years later when Mac notebooks are available with GPUs powerful enough for Retina+ displays?).

 

 

I think that the macbook pro 15" with discrete GPU already should handle the high-resolution without problems...

And allowing all possibilities at user's risk seems a reasonable workaround, until the problem can be fully solved.

Share this post


Link to post
Share on other sites
  • 0

Hello, all.  As Khovarast has mentioned we are aware of this issue and working on a fix.  In the mean time please try the following as it has helped some players with the same issue.

 

Open a terminal window and type:

 

o defaults delete “unity.Obsidian Entertainment.Pillars of Eternity.plist”

o defaults delete com.unity3d.UnityStandalone.plist

 

Thank you for your ongoing support and patience during this issue. 

 

Hello, I tried several times to fix a bug resolution, but I failed.

 
Any other ideas?

Share this post


Link to post
Share on other sites
  • 0

Hello, Cizad_cz.  What resolution are you able to play at right now?

 

Hello, Celliott .... now it is possible to play only in 1280 x 800 resolution. In the game it is not possible to switch from full screen mode to windows mode+f ... only key combination cmd+f 

Share this post


Link to post
Share on other sites
  • 0

Just to note, we aren't actively restricting what resolutions are shown. Unity only gives two options to handle how the Mac builds are made using fullscreen. One options disables all external monitors and treats the main game screen as just pure pixels. This mode was causing lots of crashes on various Macs. Thus, we had to ditch it as it is some inherit Unity issue we can't control.

 

The other mode simply just asks the OS what resolutions are available and treats it like a normal OS monitor. However, with the way Macs handle their retina stuff the OS says the top resolution of the screen is only 1440x900 in your guy's cases (since that is what the OS is treating it as as they do some pixel doubling magic in the background for their high resolution stuff). Again, we don't control what values we get back from the OS as valid options as the Mac's abstract this away. Thus, you are seeing just the subset of actual options your monitor is capable of. This is obviously not ideal but, when having to choose between a mode that crashes people's game and one that doesn't, we went with the one that doesn't.

 

This mode is built into Unity's executable so there isn't a way to toggle it on or off during runtime with some checkbox (like "Use high resolution options"). Otherwise we would.

 

But are you planning to solve the problem, either with unity or by yourselves, or do you plan to ignore it?

 

You produce a game on a platform (recent Macs) where it runs only severely tamed, without any warning about that (at least none that I could find, neither in the system requirements nor where you discuss resolutions in the official game wiki). This could be acceptable only if you are actively working on a fix (and hoping to achieve it in a reasonable time), not if you just say is Someone Else's Problem, or fault.

 

At the very least, you should give to the ones who bought the game on the Mac app store a steam/gog code, so they could play the game on another platform, if possible.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Explanations aside, the game still crashes on me all the time, even after this graphics throttling. Again, PoE becomes unique--never have I had a game crash so very much. Sometimes it's not terribly often, other times it's disturbingly frequent. One time the game even crashed my Mac, which I can count on one hand the number of times a program has done this.

 

For what it's worth--to developers who might actually be considering the issue or fellow players who might be encountering the same problems--the game crashes the most when transitioning from place to place on the map. (Might there even be a thread out there that addresses this issue? Any help finding one would be most appreciated, of course...if it exists.)

 

Also again--I really do dislike saying Cranky Gamer things like this, but this situation is so bad I'm thinking it's well past time for me to stop recommending this game to friends, even with (if-you're-playing-on-a-computer-like-mine) qualifications. I'm starting to feel like I need to actually warn those friends I've recommended PoE to...

Share this post


Link to post
Share on other sites
  • 0

Hi all-

 

I just joined so I could share how I solved this myself.

 

1. System Preferences

2. Display

3. Under the Display tab, select "Scaled" and slide it all the way to the right where it says "More Space"

4. Close System Preferences after scaled display has been applied and launch PoE

 

The higher resolutions reappeared for me after the above steps. It's not ideal, as you'll probably have to switch back after unless you want to do some serious squinting. But it worked for me.

 

My setup:

 

MacBook Pro Retina mid 2012

Yosemite 10.10.5

15.4 inch  (2880 x 1800)

NVIDIA GeForce GT 650M 1024 MB

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...