Jump to content
  • Sign Up
  • 0
nPHYN1T3

Save looping (crappy workaround)

Question

So discussing things on the Steam forms I thought I'd play around a bit more despite the prevasive anger I have at how terribly broken this game still is. If you have the looping save problem I've found a crappy work around on Windows. I've haven't tested this in Linux yet though I know the problem also affects the Linux client. I'm sure it's the same BS just a different directory path.

 

The games save system is a freaking mess using two temp folders and the actual save folder. Of the two temp folders one is the culprate breaking saves and causing loops back to the menu on load, or loading to a black screen or the last loaded area and setting the game to PAUSE from which you can't unpause.

 

The following two directories in Win 7 will house temp save data.

*C:\Users\YOURUSERNAME\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity\CurrentGame\TempSaveData

C:\Users\YOURUSERNAME\AppData\Local\Temp\Obsidian Entertainment\Pillars of Eternity

 

The directory with the asterix is the problematic one. Deleteing everything in that folder will stop the looping and all the saves will  work again. Every time you go to load a game you will have to go to this folder and delete its contents.

 

Having said that I've also found with Steam Sync disabled the game still seems to look for saves on the cloud. Given some conjecture about Steam Sync being the culprate behind various save corruption and deletion that is an issue but this game is nothing BUT issues...

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

I have never experienced this issue. My computer does not have the TempSaveData folder in the first directory path you listed, and the second directory path on my computer leads to a TempSaveData folder (along with loadedSave.zip).

Could you try moving the TempSaveData folder from the first directory path to the second? Please let me know if that solves the issue, as it could prove to be a better workaround for everybody experiencing this.

Share this post


Link to post
Share on other sites
  • 0

Well I have both and deleting or moving the game just recreates it.

 

This folder -->C:\Users\YOURUSERNAME\AppData\Local\Temp\Obsidian Entertainment\Pillars of Eternity as you said will have the tempsavedata folder accompanied by a zip however if you delete it and launch the game it recreates it. If you look at the files in the savetempdata folder the screen shot is of the encampment when the game first gives you control.

 

However the C:\Users\YOURUSERNAME\AppData\Local\Temp\Obsidian Entertainment\Pillars of Eternity is not the problem it's the data the game puts in C:\Users\YOURUSERNAME\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity\CurrentGame\TempSaveData that screws everything up. Moving or deleting has no point or purpose as the game will just recreate them both on launch and the data it puts inC:\Users\YOURUSERNAME\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity\CurrentGame\TempSaveData causes the "continue" button to load to nothing and the load save buttons to just loop back to the menu.

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

couldthose be just dteamsve folders?


PIllars of eternty (Hard) 1st playtrough: 155h, 38 m (main Ranger with bear(bow), Eder, Durance(off tank), Hirvais(off tank), Kana(ranged), Aloth/GM)
PIllars of eternty (PtoD) 2nd playtrough: 88h 30 m (main Bleak Walker Paladin, Eder, Barbarian, Monk, Rogue (ranged) Cypher(wand)
(not counting reloads and experimenting)
status i love the game, hate the bugs, and wish for better AI and Pathfinding

http://forums.obsidian.net/topic/78749-needed-qualyty-of-life-improvements-information-and-transparency/

Share this post


Link to post
Share on other sites
  • 0

Well, no wonder Obsidian is having so much trouble. There doesn't seem to be a unified version of the game. And if the systems Obsidian QA is using don't match up to the rest of us.....

 

It would seem that the first step is to figure out why the disparity!

 

This save game issue is very pervasive, from the amount of forum and board traffic I'm seeing.

 

I'm also running Windows 7, and haven't hit this issue. So, why is my system different? Someone needs to figure out why these systems are different. Are there subtle setup differences in the original installs? Did installing the Beta (Original) change things? I'm betting (from experience) that some build made configuration entries that are no longer used and the released game installer didn't not perform effective cleanup. It's time to start some good forensics Obsidian.

 

Hey nPHYN1T3, does your registry settings reference the offending locallow directory? This is a mess.

Share this post


Link to post
Share on other sites
  • 0

In Linux now and finding some fun stuff like...

 

/home/YOURUSERNAME/.cache/unity3d/Obsidian Entertainment/Pillars of Eternity/TempSaveData/TempSaveData/

/home/YOURUSERNAME/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/CurrentGame/TempSaveData/

/home/YOURUSERNAME/.local/share/PillarsOfEternity/SavedGames/

Share this post


Link to post
Share on other sites
  • 0

I couldn't tell you if my registry does atm as I'm on one of my Linux machines, I can check in the AM but it's just as messy under LInux. Seems all platforms reference 3 save locations for me. In linux though of the 3 one has a 4th nested inside the 3rd lol my god...it's like a clown car of screw ups.

Share this post


Link to post
Share on other sites
  • 0

From the sound of that, this doesn't look like a configuration issue anymore. This sounds like an issue with the core save/load codebase. In yours and others cases, its following a different path than some of us. The question now becomes, why?

 

Sounds like the devs need to take a very careful look at the code that touches saves and figure out what is going on.

 

Can Obsidian push a dev version that has debug enabled and can dump info on the whole save/load process?

Share this post


Link to post
Share on other sites
  • 0

Why indeed, I've found tons of issues with the game so far and I've only scratched the surface due to losing my save games. However the bugs aren't the only issues I've found. I gave the game a 2 out of 10 in my review touching on poor UI, inconsistent elements and pointless aspects of the game that serve no purpose but to break consistency for nostalgia's sake. On top of the brutal array of math bugs and file system screw ups it's like they kept all the bad aspects of the Infinity engine games due to the hardware limitations of the past but demand high end modern hardware for that old broken experience. I'm beyond frustrated and disappointed with this game.

Share this post


Link to post
Share on other sites
  • 0

When somebody runs into the issue, can you please post your output_log and system specs? To get that info follow the steps here. It could really help us track down the issue, as there are thousands of configurations of computers and we can only test so many variations. Thank you everyone for your assistance.

Share this post


Link to post
Share on other sites
  • 0

Yay I get to give you guys my system specs again! le sigh...

 

Xubuntu 14.04 x64

3.16 RTK

4gigs RAM

nVidia 540M

 

Windows 7 x64

10gigs RAM

Radeon R9 270x

 

I'm not at the windows machine to get the logs and I'm reinstalling the game on here now so I'll have to post later.

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

I've tried to post the windows log and all the page does it give me a pop up saying my post is empty or it gives me a little progress thing at the top of the page that eventually goes away but doesn't actually post. The Windows log is 149480 lines long!

 

Initialize engine version: 4.6.1p2 (961a19933c56)
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 9.0c [aticfx32.dll 8.17.10.1333]
    Renderer: AMD Radeon R9 200 Series
    Vendor:   ATI
    VRAM:     2027 MB (via DXGI)
    Caps:     Shader=30 DepthRT=1 NativeDepth=1 NativeShadow=1 DF16=1 INTZ=1 RAWZ=0 NULL=1 RESZ=1 SlowINTZ=1
Begin MonoManager ReloadAssembly
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\UnityEngine.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\UnityEngine.UI.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\UnityEngine.UI.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\SteamworksManaged.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\SteamworksManaged.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\MySql.Data.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\MySql.Data.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\OEICommon.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\OEICommon.dll into Unity Child Domain
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\OEIFormats.dll (this message is harmless)
Loading C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\OEIFormats.dll into Unity Child Domain
- Completed reload, in  0.055 seconds
<RI> Initializing input.

<RI> Input initialized.

desktop: 1920x1080 60Hz; virtual: 5760x1080 at -1920,0
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\System.Core.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\System.dll (this message is harmless)
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\System.Xml.dll (this message is harmless)
--->InitializeDisplay()...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Available display resolutions:
    [ 0 ] 1920x1080
    [ 1 ] 1600x900
    [ 2 ] 1366x768
    [ 3 ] 1360x768
    [ 4 ] 1280x720
    [ 5 ] 1280x768
    [ 6 ] 1680x1050
    [ 7 ] 1440x900
    [ 8 ] 1280x800
    [ 9 ] 1360x1024
    [ 10 ] 1280x960
    [ 11 ] 1152x864
    [ 12 ] 1024x768
    [ 13 ] 800x600
    [ 14 ] 640x480
    [ 15 ] 1280x1024
    Largest resolution is [ 0 ] 1920x1080
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->InitializeRoutine(6, Windowed, )...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->GetDesktopResolution() returning 1920x1080
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeResolutionRoutine( 6, False )...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeResolutionRoutine( 6, False ) _currentResolutionIndex is 0
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeResolutionRoutine( 6, False ) calling Screen.SetResolution(1680, 1050, False).
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Checking to instantiate global...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Instantiating global.
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)



 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

---- GAME BUILD VERSION: 530 ----

 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Game is not running Windows 32 Bit

 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Loading table: ClassDefenses
CharacterStats;CharacterClass;,BaseDeflection,BaseFortitude,BaseReflexes,BaseWill,MeleeAccuracyBonus,RangedAccuracyBonus,MaxHealth,MaxStamina,HealthStaminaPerLevel,ClassHealthMultiplier

Undefined,25,20,20,20,40,40,36,36,12,6

Fighter,25,20,20,20,30,30,42,42,14,5

Rogue,15,20,20,20,30,30,36,36,12,4

Priest,15,20,20,20,20,20,36,36,12,3

Wizard,10,20,20,20,20,20,30,30,10,3

Barbarian,15,20,20,20,25,25,48,48,16,6

Ranger,20,20,20,20,30,30,36,36,12,5

Druid,20,20,20,20,20,20,36,36,12,4

Paladin,25,20,20,20,25,25,42,42,14,5

Monk,25,20,20,20,30,30,42,42,14,6

Cipher,20,20,20,20,25,25,30,30,10,4

Chanter,25,20,20,20,25,25,36,36,12,4

Troll,25,20,20,20,30,30,84,84,28,6

Ogre,30,20,20,20,50,50,84,84,28,6

Wolf,25,20,20,20,30,30,42,42,14,6

Spider,25,20,20,20,30,30,36,36,12,6

Ooze,15,20,20,20,25,25,48,48,16,6

Stelgaer,25,20,20,20,30,30,42,42,14,6

Imp,25,20,20,20,30,30,36,36,12,6

DankSpore,10,20,20,20,30,30,72,72,24,6

SwampLurker,10,20,20,20,30,30,72,72,24,6

Eoten,25,20,20,20,30,30,48,48,16,6

Xaurip,25,20,20,20,25,25,36,36,12,6

Vithrack,25,20,20,20,25,25,36,36,12,6

WillOWisp,40,20,20,20,25,25,36,36,12,6

Delemgan,25,20,20,20,25,25,36,36,12,6

Pwgra,25,20,20,20,25,25,36,36,12,6

Wurm,25,20,20,20,35,35,48,48,16,6

Skuldr,25,20,20,20,25,25,42,42,14,6

Drake,45,20,20,20,55,55,72,72,24,6

SkyDragon,55,20,20,20,60,60,72,72,24,6

AdraDragon,65,20,20,20,60,60,72,72,24,6

Blight,25,20,20,20,25,25,36,36,12,6

Animat,25,20,20,20,25,25,30,30,10,6

FleshConstruct,25,20,20,20,25,25,72,72,24,6

Shadow,45,35,35,40,35,35,30,30,10,6

Phantom,45,35,35,40,25,25,30,30,10,6

CeanGwla,45,35,35,40,25,25,30,30,10,6

Skeleton,15,20,20,20,25,25,36,36,12,6

Revenant,15,20,20,20,25,25,72,72,24,6

Gul,25,20,20,20,25,25,72,72,24,6

Dargul,25,20,20,20,25,25,72,72,24,6

Fampyr,35,20,20,20,25,25,72,72,24,6

Wicht,25,20,20,20,25,25,30,30,10,6

Beetle,25,20,20,20,25,25,42,42,14,6

AnimalCompanion,25,20,20,20,30,30,36,36,12,5

WeakEnemy,1,0,0,0,0,0,1,1,1,1

HeraldOfWoedica,15,20,20,20,50,50,84,84,28,6


 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Loading table: Experience
ExperienceTableData;Level;,Experience,StrongholdTurns

1,1500,4

2,3000,10

3,4500,15

4,6000,15

5,7500,15

6,9000,20

7,10500,20

8,12000,20

9,13500,20

10,15000,20

11,16500,20

12,0,0


 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

3 data files parsed!
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->MatchResolutionToIndex(1680x1050) returning 6
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(6, Windowed)...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(6, Windowed) _currentResolutionIndex is 6, _currentDisplayMode is Unknown
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->TryChangeResolutionAndDisplayMode(6, Windowed) returning false.  Not initialized.
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeDisplayModeRoutine( Windowed, True )...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeDisplayModeRoutine( Windowed, True ) _currentDisplayMode is Unknown
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

--->ChangeDisplayModeRoutine( Windowed, True ) calling Screen.fullscreen(false).
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

UnloadTime: 0.409594 ms
Checking to instantiate global...
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Shader warmup: 13 shaders 31 combinations 0.001s
Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\System.Configuration.dll (this message is harmless)
Fallback handler could not load library C:/Program Files (x86)/Steam/steamapps/common/Pillars of Eternity/PillarsOfEternity_Data/Mono/libc
Fallback handler could not load library C:/Program Files (x86)/Steam/steamapps/common/Pillars of Eternity/PillarsOfEternity_Data/Mono/.\libc
Fallback handler could not load library C:/Program Files (x86)/Steam/steamapps/common/Pillars of Eternity/PillarsOfEternity_Data/Mono/libc
System.TypeInitializationException: An exception was thrown by the type initializer for Mono.CSharp.CSharpCodeCompiler ---> System.IO.FileNotFoundException: Windows mono path not found: C:\Program Files (x86)\Steam\steamapps\mono\mono\mini\mono.exe

  at Mono.CSharp.CSharpCodeCompiler..cctor () [0x00000] in <filename unknown>:0

  --- End of inner exception stack trace ---

  at Microsoft.CSharp.CSharpCodeProvider.CreateCompiler () [0x00000] in <filename unknown>:0

  at System.Xml.Serialization.XmlSerializer.GenerateSerializers (System.Xml.Serialization.GenerationBatch batch, System.CodeDom.Compiler.CompilerParameters cp) [0x00000] in <filename unknown>:0

  at System.Xml.Serialization.XmlSerializer.RunSerializerGeneration (System.Object obj) [0x00000] in <filename unknown>:0

Unloading 7 Unused Serialized files (Serialized files now loaded: 4 / Dirty serialized files: 0)

Unloading 26 unused Assets to reduce memory usage. Loaded Objects now: 3013.
Total: 10.053628 ms (FindLiveObjects: 0.127584 ms CreateObjectMapping: 0.237604 ms MarkObjects: 8.994844 ms  DeleteObjects: 0.067603 ms)

Platform assembly: C:\Program Files (x86)\Steam\steamapps\common\Pillars of Eternity\PillarsOfEternity_Data\Managed\Boo.Lang.dll (this message is harmless)
Unloading 2 Unused Serialized files (Serialized files now loaded: 4 / Dirty serialized files: 0)

Unloading 21014 unused Assets to reduce memory usage. Loaded Objects now: 15772.
Total: 39.922230 ms (FindLiveObjects: 2.942387 ms CreateObjectMapping: 4.491623 ms MarkObjects: 19.509102 ms  DeleteObjects: 12.357433 ms)

C:\Users\shed\Documents\My Games\Pillars of Eternity\14c4fd1a7dfc49168f01a5b18bda4b28 8030308 GildedVale.savegame ZIP FILE IS CORRUPT!
 
(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

HandleD3DDeviceLost
  HandleD3DDeviceLost: still lost
Skipped rendering frame because GfxDevice is in invalid state (device lost)
 
(Filename:  Line: 1524)

HandleD3DDeviceLost
  HandleD3DDeviceLost: still lost
Skipped frame because GfxDevice is in invalid state (device lost)
 
(Filename:  Line: 1663)

HandleD3DDeviceLost
  HandleD3DDeviceLost: still lost
Skipped frame because GfxDevice is in invalid state (device lost)

 

(Filename:  Line: 1663)

 

##############################################################

## Repeat this 149000 or so times ##################################

##############################################################

 

HandleD3DDeviceLost
  HandleD3DDeviceLost: still lost
Skipped frame because GfxDevice is in invalid state (device lost)

 

(Filename:  Line: 1663)

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

If you're having problems posting the .txt file you can try posting a link to it in a dropbox instead.

Share this post


Link to post
Share on other sites
  • 0

I truncated it as it literally ends with the following repeated over 28000 times

 

HandleD3DDeviceLost
  HandleD3DDeviceLost: still lost
Skipped frame because GfxDevice is in invalid state (device lost)

 

(Filename:  Line: 1663)

 

As a quick side note I have noted all kinds of errors in my log the few times I've checked it from script behaviors missing or undefined to stuff like...

 

C:\Users\shed\Documents\My Games\Pillars of Eternity\14c4fd1a7dfc49168f01a5b18bda4b28 8030308 GildedVale.savegame ZIP FILE IS CORRUPT!

 

That is bull**** as I've test the zip and it functions fine. More so the zip "magically works" if I delete the folder contents I outlined in my original post.

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

Or not, Linux there is no output log. In fact on top of the nested save directories I found earlier now the game also makes windows paths!

 

/home/YOURUSERNAME/.steam/steam/SteamApps/common/Pillars of Eternity/\home\YOURUSERNAME\.cache\unity3d\Obsidian Entertainment\Pillars of Eternity\TempSaveData\TempSaveData\/

 

Launching the game creates two directories both as you see above where it switches to a windows backslash and recreates the same path inside the pre-existing path swapping from the correct UNIX / to a MSFT \.

 

Now I have

/home/YOURUSERNAME/.cache/unity3d/Obsidian Entertainment/Pillars of Eternity/TempSaveData/TempSaveData/

/home/YOURUSERNAME/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/CurrentGame/TempSaveData/

/home/YOURUSERNAME/.local/share/PillarsOfEternity/SavedGames/

/home/YOURUSERNAME/.steam/steam/SteamApps/common/Pillars of Eternity/\home\YOURUSERNAME\.cache\unity3d\Obsidian Entertainment\Pillars of Eternity\TempSaveData\TempSaveData\/

/home/YOURUSERNAME/.steam/steam/SteamApps/common/Pillars of Eternity/\home\YOURUSERNAME\.config\unity3d\Obsidian Entertainment\Pillars of Eternity\CurrentGame\TempSaveData\/

 

On top of this starting a new game now loads to a black screen where the opening narration starts. If I click the bottom right where the continue button is I finally get the picture and scrolling text to accompany the narration but the buttons do not work. I can not skip/continue, replay or progress, I'm just stuck at that screen. I reiterate my previous statement...this game is like a clown car of bugs and disaster.

 

However as I predicted deleting the contents of the TempSaveData folders the previously "corrupt" save files will once again work fine!

 

rm -r /home/YOURUSERNAME/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/CurrentGame/TempSaveData/*

rm -r /home/YOURUSERNAME/.cache/unity3d/Obsidian Entertainment/Pillars of Eternity/TempSaveData/*

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

@Plazmid there is nothing in my registry about any of these locations.

 

...crickets...

 

So is anything going on with this?

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

Could you by chance post a zipfile of all of your saves? As cRichards said, I am not seeing the folder "C:\Users\YOURUSERNAME\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity\CurrentGame\TempSaveData" that you have mentioned is the culprit. I see a TempSaveData in the folder "C:\Users\YOURUSERNAME\AppData\Local\Temp\Obsidian Entertainment\Pillars of Eternity" folder but everything seems to be working as intended.


Twitter: @robyatadero

Share this post


Link to post
Share on other sites
  • 0

Here is a zip of the offending directory from the Windows client. http://m0dw3rks.com/trans/PillarsOfEternity/TempSaveData.zip

 

Launching the game (in both Windows and Linux) it creates the data in that zip. Then saves no longer load and clicking continue loads to a black screen. Delete the **** in that folder and everything works. However when you load the now working save it repopulates that folder with the same broken garbage and you can't load again until you delete the folders contents again.

 

Whether your machine has these directories or not the games code is making them. Along with the more mangled and nested directories on Linux. Deleting or moving any of them the game just recreates it all on launch.

 

Feel free to fix the bull**** 5 minutes to launch issue too on Windows machines.

Share this post


Link to post
Share on other sites
  • 0

Is anyone else getting this? I've tried multiple Windows PC's, Macs, and several Linux boxes and don't ever see the path duplication, nor do any of our QA machines and a few programmer machines that we checked. None of them have the extra TempSaveData folders, nor the duplicate path with backslashes on Linux, and we haven't had any other reports of save game looping that fits this description.

 

Some questions:

 

1) Did you ever have the backer beta installed on these two computers?

 

2) Do you have any VM software on your computers? If so, the long 5 minute launch is probably due to an issue in Unity with extra network adapters. A workaround is to turn them off temporarily. Once we get a fix from them, we'll integrate it.

 

3) On your Linux machine, have you installed Wine and tried playing the Windows version on it before?

 

4) Is there any software you're using on the two machines in common? Any daemon tools type things or anything that may interfere at the hardware level?

 

5) Are you trying to play the same save games between the two machines using Steam cloud? If you disable Steam cloud on both of them, and try to play a new game and save, do you still get the folder issues?


OBSIDIAN ORDER OF ETERNITY - Officially sponsored most generously by Pierre and SD!

Share this post


Link to post
Share on other sites
  • 0

1) No

 

2) VM software on the Windows machine only, not running while gaming though the network interfaces are always live. I really don't understand why you guys keep blaming UNITY. YOU chose the platform and none of my other UNITY based games have any of these issues!

 

3) Why the hell would I want to play it under WINE?! i.e. no I have not done that and there are no words for the face I'm making right now...

 

4) Almost everything on the two machines is common. Same code editor, browser, graphic design programs (GIMP, Inkscape etc) same IM, nothing that should be at hardware level.

 

5) I was originally trying with Steam but it was broken so Steam sync is disabled. Steam Sync disabled or enabled the folder issues persist.

 

Have you guys looked at the zip I posted? I would also note this is more likely the game client than my machines as two different OS's on very different hardware both present the issue. I'd conjecture this may be an issue to the fact Windows Vista, 7, 8, 10 have a nightmare juction riddled file system for compatability reasons that might cause the dual save folders but the client does it under Linux as well and now more so with the 1.03 patch.

 

I'm installing it on another machine right now to test though I'm guessing it won't run at all as the games spec requirements are fooking ludicrous. Yup won't even launch...

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

Is anyone else getting this?

while I haven't run into the looping save thing so far (only problem I have with saves so far is it takes a minute for the game to load my save files at the menu screen)  I decided to take a look to see if I could find any save files in my temp folder (after learning to find my temp folder thanks to google)

 

I found C:\Users\YOURUSERNAME\AppData\Local\Temp\Obsidian Entertainment\Pillars of Eternity

 

that had Obsidian Entertainment folder/Pillars of Eternity folder that holds TempSaveData folder (all  its contents get erased whenever ccleaner runs) and I also found loadedsave.zip

 

I also found C:\Users\YOURUSERNAME\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity\CurrentGame it was empty until I got into game (it didn't have TempSaveData folder in it)

 

CurrentGame folder after getting into game had a bunch of .fog/.lvl files and one MobileObjects.save file and a xml doc

Share this post


Link to post
Share on other sites
  • 0

Glad to know I'm not the only one with the game creating several save areas. Really wish I could just get a refund rather than spend more time dicking around with this mess. Even if this issue is sorted the insane system requirements alone are a deterant to play. A 2D game with low quality 3D characters and some faked lighting and I can't play it on the machine I used to play Crysis on?! Give me a break!

 

I have't been this angry with a game since I was beta testing for Blizzard. Between the game trying to burn my **** off if played on my laptop and Obsidians horrific and slow support it's time to give up on this pile of garbage. It's been 3 weeks since release and I still can't play on any of my machines. So to prevent any farther angry ranting I'm unsubscribing from this thread.

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

My game is fine, no saves issues. Your data structure is different from mine: 

 

%USERPROFILE%\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity\CurrentGame

%USERPROFILE%\AppData\Local\Temp\Obsidian Entertainment\Pillars of Eternity\TempSaveData

 

There is no TempSaveData under CurrentGame.

 

Any fan fix that could mess with that?


I've come to burn your kingdom down

Share this post


Link to post
Share on other sites
  • 0

Yes, there are multiple save folders being used for save file management (as the post Haze mentions above notes). However, they should look exactly like the directories Haze is reporting. Not with a TempSaveData folder being in the CurrentGame folder. The TempSaveData folder should be in the directory that has "AppData\Local\" in the path, not "AppData\LocalLow".

 

I did look at your zip folder and nothing looks out of the ordinary for a TempSaveData folder. At this point I assume what happened is something messed up with Steam Cloud syncing saves across two OS's with version 1.02. If you delete all the temp folders you are mentioning and backup and delete all of your save files (because I think those are the actual culprits here, messed up save games) then you should be able to get through a New Game session. The reason being is the game loads and caches all of your save games found on start up so if you have something wrong there it might be making bad folders when unpacking them.

 

As mentioned earlier, if we could have a copy of all your save files (not your temp directory contents) then we can look into seeing if those are the actual problem and potentially repair them for you.


Twitter: @robyatadero

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...