Jump to content
  • 0
nPHYN1T3

Save looping (crappy workaround)

Question

So discussing things on the Steam forms I thought I'd play around a bit more despite the prevasive anger I have at how terribly broken this game still is. If you have the looping save problem I've found a crappy work around on Windows. I've haven't tested this in Linux yet though I know the problem also affects the Linux client. I'm sure it's the same BS just a different directory path.

 

The games save system is a freaking mess using two temp folders and the actual save folder. Of the two temp folders one is the culprate breaking saves and causing loops back to the menu on load, or loading to a black screen or the last loaded area and setting the game to PAUSE from which you can't unpause.

 

The following two directories in Win 7 will house temp save data.

*C:\Users\YOURUSERNAME\AppData\LocalLow\Obsidian Entertainment\Pillars of Eternity\CurrentGame\TempSaveData

C:\Users\YOURUSERNAME\AppData\Local\Temp\Obsidian Entertainment\Pillars of Eternity

 

The directory with the asterix is the problematic one. Deleteing everything in that folder will stop the looping and all the saves will  work again. Every time you go to load a game you will have to go to this folder and delete its contents.

 

Having said that I've also found with Steam Sync disabled the game still seems to look for saves on the cloud. Given some conjecture about Steam Sync being the culprate behind various save corruption and deletion that is an issue but this game is nothing BUT issues...

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Dude, get yourself together, you have three developers messaging you back and forth trying to help solve your problem, one of which is the freaking CIO of the company. The very least you can be as cordial as they are with you. They're trying to help you out. The fact that this seems to be a very limited problem (so far only limited to maybe 2-3 people) should really make you "check yourself."

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

3 weeks, no fix, support tickets ignored, not a good impression and if I had more tolerance for this BS I'd still be beta testing and reverse engineering for a living...but I don't. I want to play a game, relax, have fun. Not piss around with files, tweak configs and everything else I do for work i.e. dealing with bull**** software and hardware problems all day every day.

Share this post


Link to post
Share on other sites
  • 0

Yeah, looks like all of your save games dated on the 29th have a TempSaveData folder in it that shouldn't be in there. That is was is corrupting your temp folders and preventing any games from being loaded.

 

I removed the bad folder in those save games and reuploaded them here:

 

https://dl.dropboxusercontent.com/u/1071568/14c4fd1a7dfc49168f01a5b18bda4b28%207967054%20TempleofEothas.savegame

https://dl.dropboxusercontent.com/u/1071568/14c4fd1a7dfc49168f01a5b18bda4b28%208000043%20TheBlackHound.savegame

https://dl.dropboxusercontent.com/u/1071568/14c4fd1a7dfc49168f01a5b18bda4b28%208030308%20GildedVale.savegame

https://dl.dropboxusercontent.com/u/1071568/14c4fd1a-7dfc-4916-8f01-a5b18bda4b28%20autosave.savegame

 

So, overwrite your old save files with these ones above (or just remove your saves dated last edited on the 29th). Delete all temp folders you have found on your machine and everything should load up fine once the game starts.


Twitter: @robyatadero

Share this post


Link to post
Share on other sites
  • 0

Wow!

 

A combination of cloud syncing, a faulty save file, and multiple systems using the same Steam account. That's cool that the problem was investigated and resolved. Nice! 

Share this post


Link to post
Share on other sites
  • 0

3) Why the hell would I want to play it under WINE?! i.e. no I have not done that and there are no words for the face I'm making right now...

 

Some of us played the beta under Wine before the native Linux version came out.

 

Also, the current Linux release has some minor rendering issues (problems with anti-aliasing of characters, black spots on water, no rendering of robes/cloaks) that the Windows version doesn't suffer from, so it's not unimaginable that someone might run it in via Wine (though I personally don't).

 

So Darren's question wasn't as far-fetched as you make it out to be.


"Some ideas are so stupid that only an intellectual could believe them." -- attributed to George Orwell

Share this post


Link to post
Share on other sites
  • 0

Was it resolved? Just because he fixed the saves doesn't mean they fixed the game issues that cause the issue. I found in my short time playing some times saves didn't save at all then when they did they eventually would loop. Either way I'll check back in a year. He's not mentioned if the issues in game that caused this are fixed and there are still an incredible array of game breaking bugs outside this I have no care to experience. Comically my play time shows 14 hours now...that's 6 hours of "debugging" time.

 

@Ineth I didn't have the beta and despite the example you present it's still whack :p I know the Linux version has issues as that is the only platform the game worked for me on in the beginning. However I encountered some of what you mentioned. Capes/cloaks do not show up, Items missing, every area that loads starts with your cursor/camera focus at the bottom left of the map rather than focused on where you are. Tons of obnoxious bugs and this is still better than how it behaves on Windows.

 

Sadly past that I had hoped to play the game under Linux on my laptop but the requirements for the game are a rage point in itself. It's completely unplayable from a battery/thermal standpoint. I have to run cooling pads and always be tethered to a wall. There is no excuse for such wasteful bloated cpu sucking in a 2D game. What little 3D is in the game should still be doable with an Intel HD2000. Only the devs can say why the game is so lacking in optimization but I'm sick of here UNITY as the excuse for everything. If UNITY sucks that bad they shouldn't have chosen it, and it works fine on several other games I play that are full on 3D and physics based games that require much less CPU/GPU to run. Which is to say a table top game a TI calculator should be able to do the core math/stat functions of should not need liquid cooling!

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites
  • 0

Glad to see v2 is out and this still persists. Game still frequently locks up on launch, I have the "hang" reports to prove it. Saves are not cross platform, no steam sync across platforms. Game is even worse performance wise. Save looping still happens in addition to the "game paused" problem with clicking continue after the game has corrupted your save. Looking good guys, will I get to play by v20?

Edited by nPHYN1T3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...