Jump to content
  • 0

[Linux] Ultrawide screen


Question

I have a 21:9 2560x1080 screen.  My highest display option is 1920x1080, which causes essesive stretching.  I tried manually editing the ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/prefs file, but it immediately reverts to 1920x1080.

  • Like 1
Link to post
Share on other sites

Recommended Posts

  • 0

I can report I have the same issue.

 

OS: Debian Jessie 64-bit

GFX: Nvidia Geforce GTX 770

Driver: 346.47

CPU: Intel i5-4670K 3,40 GHz

 

I tried editing the prefs file as well as setting it to read only, altough the game did change to 1980x1080p anyways...

Link to post
Share on other sites
  • 0

I have a 21:9 2560x1080 screen.  My highest display option is 1920x1080, which causes essesive stretching.  I tried manually editing the ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/prefs file, but it immediately reverts to 1920x1080.

 

You already know that this is a new, largely unsupported resolution to date so I won't repeat...;)  My opinion is that it's really meant for people in offices who want to run several spreadsheets and other kinds of business/document pages side by side without having to go the multimonitor route.  What happens if you set your desktop to 2560x1080 and then run the game...?  You could try that --but still, I think you are going to have serious aspect ratio problems...as obviously the game (any game, really) is not done @ 21:9 resolution, but @ 16:9, or 16:10 (1920x1200 is my resolution for the game.)   I think you are going to have to settle for an aspect-ratio *correct* 1920x1080 resolution, which will mean you'll have sizable black borders to either side of the game screen. But I don't think that can be helped.

It's very well known that I don't make mistakes, so if you should stumble across the odd error here and there in what I have written, you may immediately deduce--quite correctly--that I did not write it... :biggrin:

Link to post
Share on other sites
  • 0

Same problem here. Hope that we can find support for this. It shouldn't be that hard to take care of.

 

 

 

I have a 21:9 2560x1080 screen.  My highest display option is 1920x1080, which causes essesive stretching.  I tried manually editing the ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/prefs file, but it immediately reverts to 1920x1080.

 

You already know that this is a new, largely unsupported resolution to date so I won't repeat... ;)  My opinion is that it's really meant for people in offices who want to run several spreadsheets and other kinds of business/document pages side by side without having to go the multimonitor route.  What happens if you set your desktop to 2560x1080 and then run the game...?  You could try that --but still, I think you are going to have serious aspect ratio problems...as obviously the game (any game, really) is not done @ 21:9 resolution, but @ 16:9, or 16:10 (1920x1200 is my resolution for the game.)   I think you are going to have to settle for an aspect-ratio *correct* 1920x1080 resolution, which will mean you'll have sizable black borders to either side of the game screen. But I don't think that can be helped.

 

 

This is probably the least helpful reply I can imagine. It's great that you don't have any issues - I'm very happy to hear that. Telling people that *do* have issues 'it's your fault for using an ultra-wide monitor' is not at all helpful, and doesn't contribute anything worthwhile. For what it's worth, 2560x1080 resolutions were mentioned as being supported in several places before I bought the game.

Link to post
Share on other sites
  • 0

 

I have a 21:9 2560x1080 screen.  My highest display option is 1920x1080, which causes essesive stretching.  I tried manually editing the ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/prefs file, but it immediately reverts to 1920x1080.

 

You already know that this is a new, largely unsupported resolution to date so I won't repeat... ;)  My opinion is that it's really meant for people in offices who want to run several spreadsheets and other kinds of business/document pages side by side without having to go the multimonitor route.  What happens if you set your desktop to 2560x1080 and then run the game...?  You could try that --but still, I think you are going to have serious aspect ratio problems...as obviously the game (any game, really) is not done @ 21:9 resolution, but @ 16:9, or 16:10 (1920x1200 is my resolution for the game.)   I think you are going to have to settle for an aspect-ratio *correct* 1920x1080 resolution, which will mean you'll have sizable black borders to either side of the game screen. But I don't think that can be helped.

 

 

Well, I do understand a lot of games don't support this, altough the engine support this, so it shouldn't be that big of a issue.

And as jawls said, it says it supports this resolution...

 

Sources:

http://pcgamingwiki.com/wiki/Pillars_of_Eternity

 

http://community.pcgamingwiki.com/page/blog/_/features/port-reports/pc-report-pillars-of-eternity-r180

(runs 2560x1600 so my resolution shouldn't be a problem, aspect ratio isn't the issue here as it crops the image, not scales it.).

 

http://steamcommunity.com/app/317120/discussions/0/35221584572096801/

(public beta got it to work in windowed mode).

 

So while you are correct in that a lot of games do not support ultra-widescreen - this game surely does, altough it seems to have some issues on linux. Please don't post stuff like that if you're not helping us out with suggestions.

Link to post
Share on other sites
  • 0

Figured out a work-around that seems to work. To begin with, no widescreen resolution was listed, and the game wouldn't do anything when I unchecked 'full screen' - it would just go back to full screen.

 

So.... what I was able to do:

 

1) Change the resolution to a lower resolution than my screen.

2) Switch to Windowed Mode (Windowed mode would work when I had changed resolution down from 1920x1080 for some reason).

3) Maximize the window. Everything scales fine.

4) Go back to the game, and choose fullscreen mode.

 

That seemed to do it. Convoluted, and shouldn't be that tough, but hopefully that process will work for others while the bug itself is worked on.

  • Like 1
Link to post
Share on other sites
  • 0

Update:

Yay! I found a work around (please note I'm using i3 as WM, so it might not work on other WMs):

1. Launch the game.

2. Go to settings.

3. Set resolution to 1280x720 and untick Fullscreen.

4. Maximize the window.

5. It now scales the windows to my desktop resolution. Please note it still says 1280x720 altough it clearly runs at 21:9 resolution. Work after restart as well.

 

This is also the case when running another unity game; Cities Skyline, so it might have to do with ultra-widescreen and unity.

Link to post
Share on other sites
  • 0

Same problem here. Hope that we can find support for this. It shouldn't be that hard to take care of.

 

 

 

I have a 21:9 2560x1080 screen.  My highest display option is 1920x1080, which causes essesive stretching.  I tried manually editing the ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/prefs file, but it immediately reverts to 1920x1080.

 

You already know that this is a new, largely unsupported resolution to date so I won't repeat... ;)  My opinion is that it's really meant for people in offices who want to run several spreadsheets and other kinds of business/document pages side by side without having to go the multimonitor route.  What happens if you set your desktop to 2560x1080 and then run the game...?  You could try that --but still, I think you are going to have serious aspect ratio problems...as obviously the game (any game, really) is not done @ 21:9 resolution, but @ 16:9, or 16:10 (1920x1200 is my resolution for the game.)   I think you are going to have to settle for an aspect-ratio *correct* 1920x1080 resolution, which will mean you'll have sizable black borders to either side of the game screen. But I don't think that can be helped.

 

 

This is probably the least helpful reply I can imagine. It's great that you don't have any issues - I'm very happy to hear that. Telling people that *do* have issues 'it's your fault for using an ultra-wide monitor' is not at all helpful, and doesn't contribute anything worthwhile. For what it's worth, 2560x1080 resolutions were mentioned as being supported in several places before I bought the game.

 

That's only because you didn't understand my post...it isn't a matter of "supporting 2560x1080"...it's a matter of supporting *the aspect ratio* of 21:9, which I do not think the game supports at all.  If you play @ 1920x1080 *at the correct aspect ratio* (so that your characters appear normal, not stretched) the image will *not* fill your screen.  Again, 21:9 is a non-standard aspect ratio; it's not 16:9 or 16:10 or 4:3.  That's the only comment I wanted to make.  The vast majority of games support one or more of those aspect ratios--few, if any that I am aware of, support an aspect-correct 21:9.   You should be able to view an aspect-correct image on your monitor with this game, just don't expect it to fill the screen, that's all.

 

Sorry this was not what you wanted to hear...:/  Maybe you read correctly and the game does suppport an aspect-correct 21:9, but if so, then you should be able to display it, correct?  Or, perhaps your GPU drivers do not yet support an aspect-correct 21:9.  Main thing to deal with is the aspect ratio.

It's very well known that I don't make mistakes, so if you should stumble across the odd error here and there in what I have written, you may immediately deduce--quite correctly--that I did not write it... :biggrin:

Link to post
Share on other sites
  • 0

Update:

Yay! I found a work around (please note I'm using i3 as WM, so it might not work on other WMs):

1. Launch the game.

2. Go to settings.

3. Set resolution to 1280x720 and untick Fullscreen.

4. Maximize the window.

5. It now scales the windows to my desktop resolution. Please note it still says 1280x720 altough it clearly runs at 21:9 resolution. Work after restart as well.

 

This is also the case when running another unity game; Cities Skyline, so it might have to do with ultra-widescreen and unity.

 

 

Yes, it's similar to scaling from 1920x1200 from 640x480 (which is not aspect-correct)...The image you see @ 2560x1080 is an exact duplicate of 1280x720, only each pixel is multiplied (scaled up) a number of times so that the total pixel output equals your 2560x1080 resolution--but the image quality itself is exactly the same as  1280x720.  IE, you unfortunately cannot get an aspect-correct native res of 2560x1080, and so you do not get the actual benefit of more image detail through the higher resolution.  Hopefully, this makes sense...;)

It's very well known that I don't make mistakes, so if you should stumble across the odd error here and there in what I have written, you may immediately deduce--quite correctly--that I did not write it... :biggrin:

Link to post
Share on other sites
  • 0

 

Same problem here. Hope that we can find support for this. It shouldn't be that hard to take care of.

 

 

 

I have a 21:9 2560x1080 screen.  My highest display option is 1920x1080, which causes essesive stretching.  I tried manually editing the ~/.config/unity3d/Obsidian Entertainment/Pillars of Eternity/prefs file, but it immediately reverts to 1920x1080.

 

You already know that this is a new, largely unsupported resolution to date so I won't repeat... ;)  My opinion is that it's really meant for people in offices who want to run several spreadsheets and other kinds of business/document pages side by side without having to go the multimonitor route.  What happens if you set your desktop to 2560x1080 and then run the game...?  You could try that --but still, I think you are going to have serious aspect ratio problems...as obviously the game (any game, really) is not done @ 21:9 resolution, but @ 16:9, or 16:10 (1920x1200 is my resolution for the game.)   I think you are going to have to settle for an aspect-ratio *correct* 1920x1080 resolution, which will mean you'll have sizable black borders to either side of the game screen. But I don't think that can be helped.

 

 

This is probably the least helpful reply I can imagine. It's great that you don't have any issues - I'm very happy to hear that. Telling people that *do* have issues 'it's your fault for using an ultra-wide monitor' is not at all helpful, and doesn't contribute anything worthwhile. For what it's worth, 2560x1080 resolutions were mentioned as being supported in several places before I bought the game.

 

That's only because you didn't understand my post...it isn't a matter of "supporting 2560x1080"...it's a matter of supporting *the aspect ratio* of 21:9, which I do not think the game supports at all.  If you play @ 1920x1080 *at the correct aspect ratio* (so that your characters appear normal, not stretched) the image will *not* fill your screen.  Again, 21:9 is a non-standard aspect ratio; it's not 16:9 or 16:10 or 4:3.  That's the only comment I wanted to make.  The vast majority of games support one or more of those aspect ratios--few, if any that I am aware of, support an aspect-correct 21:9.   You should be able to view an aspect-correct image on your monitor with this game, just don't expect it to fill the screen, that's all.

 

Sorry this was not what you wanted to hear...:/  Maybe you read correctly and the game does suppport an aspect-correct 21:9, but if so, then you should be able to display it, correct?  Or, perhaps your GPU drivers do not yet support an aspect-correct 21:9.  Main thing to deal with is the aspect ratio.

 

 

Look.... I don't want to get into a debate here. The fact is that the game *does* support different aspect ratios, including 21:9. The fact that you can dynamically scale the size of the window the game plays in while it is in windowed mode essentially proves this. I appreciate that 21:9 is a (somewhat) unusual aspect ratio. For this game (and many others), that is neither here nor there, especially given that the UI elements are 'disconnected' from eachother, and aren't being used to frame anything. When those elements are disconnected, they're drawn relative to a point on the screen.

 

And as tainerballs said, 21:9 is natively supported in Windows, with the option for a 21:9 resolution showing up in the resolution selection menu. It's not there under linux (probably due to some mis-communication between the x-server and the game).

 

So.... I understood your post. And you are incorrect in assuming the game doesn't support 21:9. It does. There's a bit of a bug in the graphics menu under linux systems that it's not showing it as an option.

Link to post
Share on other sites
  • 0

For anyone from Obsidian who may be reading, the relevant log file (player.log) shows the following:

 

--->InitializeDisplay()...


(Filename: /BuildAgent/work/d63dfc6385190b60/artifacts/LinuxStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)


Available display resolutions:
[ 0 ] 1920x1080
[ 1 ] 1600x900
[ 2 ] 1366x768
[ 3 ] 1280x720
[ 4 ] 1024x576
[ 5 ] 960x540
[ 6 ] 854x480
[ 7 ] 1280x768
[ 8 ] 1024x600
[ 9 ] 800x480
[ 10 ] 1680x1050
[ 11 ] 1440x900
[ 12 ] 1280x800
[ 13 ] 1152x720
[ 14 ] 1024x640
[ 15 ] 1440x960
[ 16 ] 1280x864
[ 17 ] 1152x768
[ 18 ] 960x640
[ 19 ] 1400x1050
[ 20 ] 1280x960
[ 21 ] 1152x864
[ 22 ] 1024x768
[ 23 ] 800x600
[ 24 ] 640x480
[ 25 ] 1280x1024
Largest resolution is [ 0 ] 1920x1080


(Filename: /BuildAgent/work/d63dfc6385190b60/artifacts/LinuxStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

If there's some way to add a hard-coded option for 2560x1080, that would take care of it.

  • Like 1
Link to post
Share on other sites
  • 0

Just a bump to remind everyone that this is still an issue. I too would love to see some acknowledgement of it. Playing a stretched-out version of the game isn't all that great.

Link to post
Share on other sites
  • 0

Hi guys, I've forwarded this along both to our IT department to make sure we have one of those monitors and also to QA to make sure it gets tested and tracked. No ETA on a fix yet, but thought at least a confirmation of the issue would be helpful.  ;(

OBSIDIAN ORDER OF ETERNITY - Officially sponsored most generously by Pierre and SD!

Link to post
Share on other sites
  • 0

Thanks Darren! Acknowledgment was what I was looking for, I know you can promise an ETA but at least this way we know it's in a bug list that will be looked at and evaluated for future patches.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...