Jump to content

another interesting ATI gfx problem...CRAZY text!


Recommended Posts

hi all, i'd thought i'd chime in with another problem i've found trying to play the game with an ATI gpu...specifically a laptop ATI gpu.

 

i have a compaq x1000 notebook, 1.3 ghz centrino, 512 mb ram, an ati radeon mobility 9200, which, without going into a long story about shady practices at compaq/hp, is apparently a rebadged radeon mobility 9000 - this pissed a lot of people off when it was found out a while ago. anyways.

 

i've been able to run the game fine, start playing the prologue, etc, but i haven't really gotten that far - not because it doesn't run, which it does, although it doesn't really look that great (which i'm fine with), but mostly because of one issue which is really, really irritating.

 

basically, all the text on any menus, when you are starting the game or adjusting the config or whatever, and ingame with labels and stuff, acts really weird. its flickery and the letters seem to drag across the screen intermittently, its generally just 'corrupted', i guess you would say, and it's annoying to the point where the game is basically unplayable because there is so much text involved.. the rest of the game seems to play ok, i've just looked around the ebon hawk a little bit so far with the astromech droid dude, and all the other graphics look ok, the graphics corruption seems to stem from any display of any sort of text. this text problem - which i can't really describe any better, it just looks really messed up, hasn't been fixed by me turning ALL the graphical options to low or off, replacing my drivers to omega catalyst 4.11s, etc, etc. nothing seems to help it.

 

the KOTOR config program shows a little yellow dot next to the graphics card - which i think means it passes the required graphics if not the reccomended. i am not sure whether this laptop graphics card supports opengl 1.4, as ati's website isn't really specific on the matter. however, i think if it wasnt, the config program would have said so, right? this gpu is basically equivalent to the radeon 8500 which is supported, i believe.

 

so...has anybody else had this problem, or have any ideas on how to fix it? i haven't seen any of this crashing or really slow gameplay which other people have mentioned, then again i haven't really gotten that far. oh, one more thing. i played prince of persia: the warrior within a while ago on this laptop, and the background graphics in that game did something similar to the text in this one - weird chunking and artifacts, although it was more playable than KOTOR II seems to be so far. it appears that my laptop is having some problems playing newer games.

Link to comment
Share on other sites

well, i was running the original ati radeon mobility catalyst drivers, which were quite old, due to ati not supporting their mobility gpus and compaq never updating, even once, these said drivers.

 

now i am running the latest omega radeon drivers with the catalyst 4.11 atioglxx.dll in my KOTOR II folder. thought this might help, it didn't, oh well.

 

...uh, upon closer inspection it looks like i've answered my own question. the SWINFO stuff is below, but the most pertinent line is probably this one:

 

OpenGL Version=1.3.4707 WinXP Release

 

whoops. looks like i'm just screwed. if my card doesn't support opengl 1.4, which from what i've read NONE of the radeon mobility 7x00 or 9x00 do, is there any hope to run this game on my laptop short of obsidian having pity on me and completely rewriting their gfx engine in a patch....

 

...that's a good idea, actually. OBSIDIAN ENTERTAINMENT KOTORII SCRIPTER/NWN2 ENGINE PROGRAMMER ADAM "JABBY" BRENNECKE, DO YOU HEAR ME???? WHAT ARE WE PAYING YOU SLOBS FOR? GET ON THAT, BOY! jesus christ...

 

adam, i really hope you're reading this message board instead of working hard on the next obsidian product.

 

SWINFO:

 

[sWKotOR]

ReportDateTime=2/27/2005 3:14:05 AM

SysInfoVersion=v1.00.60

GameExists=1

GameVersion=v2.00.424

GameInstallLocation=D:\SWKotOR2\

 

[OS]

Name=WinXP

Version=Windows XP v5.1 build 2600 Service Pack 2

Service Pack=Service Pack 2

Status=Pass

 

[swapFiles]

C:\pagefile.sys=768

 

[CPU]

CPUCount=1

CPUSpeed=1295

CPUFamily=6

CPUModel=9

CPUStepping=5

CPUVendor=Intel

CPUName= Intel® Pentium® M processor 1300MHz

Status=Warning

 

[Memory]

RAM=512

Status=Pass

 

[Disk Free Space]

C: (NTFS), UNICODE=3.34GB

D: (NTFS), UNICODE=1.16GB

E: (NTFS), UNICODE=580MB

Status=Pass

 

[CD-ROMs]

DriveLetters=F:\,H:\

Drives=TOSHIBA DVD-ROM SD-R2312

 

[Video]

Video Card Name=ATI MOBILITY RADEON 9000 (Omega 2.6.05a)

Video Memory=64

Desktop Resolution=1680x1050x32 @ 60Hz

DirectX=DirectX 9.0c (4.09.00.0904)

OpenGL Version=1.3.4707 WinXP Release

OpenGL Vendor=ATI Technologies Inc.

OpenGL Renderer=MOBILITY RADEON 9200 DDR x86/SSE2

Vid Card Status=Warning

Vid Card Driver Status=Pass

GL Status=Pass

DX Status=Pass

 

[Audio]

Sound Card Name=SoundMAX Integrated Digital Audio

Status=Pass

 

 

;Game Options from swkotor2.ini

 

[Display Options]

FullScreen=1

Disable Movies=0

Disable Intro Movies=0

Sort Modules=1

Width=640

Height=480

BitsPerPixels=32

RefreshRate=60

 

[sound Options]

Music Volume=85

Voiceover Volume=85

Sound Effects Volume=85

Movie Volume=85

Number 3D Voices=29

Number 2D Voices=64

2D3D Bias=1.50

EAX=2

Sound Init=0

Disable Sound=0

Force Software=0

 

[Graphics Options]

Grass=0

Shadows=0

EnableHardwareMouse=1

FullScreen=1

AllowSoftShadows=1

RefreshRate=60

Width=800

Height=600

Emitters=1

Anisotropy=1

Frame Buffer=0

Soft Shadows=0

Brightness=57

V-Sync=0

Texture Quality=0

Anti Aliasing=0

Link to comment
Share on other sites

Actually, I believe swconfig tests for your software OpenGL support, not the hardware level.

 

Note that it says '1.3.4707 WinXP Release'. I'm pretty certain that means you did not successfully update your video driver, and it is still using the ancient, terrible OpenGL that shipped with Windows XP.

 

Go to http://www.drivercleaner.net and download/install Driver Cleaner. Uninstall your current video driver. Delete the C:\ATI directory. Reboot into Windows Safe mode by hitting F8 while booting and pick 'Safe Mode' from the menu that appears. Then run Driver Cleaner to remove all traces of your old video driver. Also use the Cab Cleaner that is part of Driver Cleaner to clean the old ATI driver out of the Windows .CAB files. Go to C:\Windows\System32 and delete any DLL files you see starting with the letters ATI. If you're comfortable with it, open regedit and delete the keys with the name 'ATI Technologies'. Reboot into normal Windows and install the Omega drivers.

 

You should then have a proper driver install, and I bet you that swconfig will produce a different test result in your swinfo.txt.

Link to comment
Share on other sites

well, kiwegapa, i took all of your advice - uninstalled my card, booted in safe mode, ran driver cleaner and cab cleaner, got rid of any even remotely-ATI looking file, dll, or reg entry on my computer, reinstalled the latest omega drivers....and...

 

i've still got this weird text corruption problem.

 

interestingly enough the opengl entry in my swinfo.txt has changed from:

 

OpenGL Version=1.3.4707 WinXP Release to

 

OpenGL Version=1.3.4830 WinXP Release

 

so the software opengl version has updated (a little bit?) but apparently not to the magic opengl 1.4 standard.

 

this problem is obviously a driver/hardware problem (i think)..having to do with what i think are 'overlays', though i could be wrong. any menus/text look messed up. key point being menus as well.

 

i think i've messed with some option in the config for overlays too, but i'm not sure.

 

ack. this is frustrating.

Link to comment
Share on other sites

ok, i've actually played through the game a bit. corrupt graphics/massive artifcating isn't just confined to menus and text, though it is most obvious there. some of the other graphics are affected as well. this was pretty obvious, for example, in the prologue when you take the droid outside the ebon hawk- the problem here was that the textures on the ship's hull just looked a little messed up, would flicker in and out a lot. i think the problem, which i'm now pretty sure is an ATI driver/opengl issue, relates to textures/2d displays in general - i don't know what the proper name for this would be. the basic structure of the graphics in the game, polygon display, look fine.

 

has anybody had weird texture/text/menu corruption with an ati graphics card? specifically a radeon mobility 9000/9200? i now KNOW that this card should be able to run the game without any problems. i've tried a huge number of driver options, but i can't seem to find anything to help. compaq, my computer manufacturer, has nothing on this, nor does hp seem to care about this subsidiary anymore. i can't find anything in the limited selection of faqs on ati.com. help!

Link to comment
Share on other sites

  • 2 weeks later...

I have this problem with my ATI Radeon 9800 XT ultra. In various 2D screens I have text fragmenting. There are localized boxes of checkered patterns at interfaces between contrasting colors. I do not see this in games until a recent MMOG I downloaded.

 

It seems like some sort of anti-aliasing problem. I turned off anti-aliasing but the problem remained.

 

I went through deleting all ATI related files, ran Driver Cleaner while in safe mode and then installed Catalyst 5.3. No improvement.

 

I am not sure what to try next. I found your post via searching. It is the first I have found which describes a problem which is so similar to mine.

Link to comment
Share on other sites

  • 3 weeks later...

I have a asus 9800xt with 256 ram and I've just started experienceing the checkered lacall curruption too. Tried different drivers and it seemed to happen after I installled the latest ati drivers but since that I have tried omega and other ati drivers with no luck. Are there any programs out there that check your graficss ram for errors? And can anyone help with this problem. I have to OS on same HD and have for some years now with no problems before and on the OS with half life 2 it works fine most of the time although now and again I get a different type of curuption like images wipeing the screen when looking around that bad that u have no visibility but I don't get the local checkered curruption but on this OS its the oppisite. GPU temps range from 45 to 55 so do u think it could be heat rellated? but I just gave it a good clean and didn't have the problems before. Sorry about my english as I'm a boiler maker with limited IT experiance.

Any help would be much appreciated as I payed $850 Aussie for this card and wouldn't mind getting a bit more good use out of it. Problem started ever since I put asus drivers on which were spose to give it a boost from standard ati drivers.

 

Cheers Chuck

Link to comment
Share on other sites

Wow, just did a defrag that windows said it didn't need and the checkered coruption has gone. For now anyway, and if it happens again I'll be back. Sorry for waisting anyones time. I'm using the omega drivers as I find better rusults than others for now anyway.

Link to comment
Share on other sites

  • 3 weeks later...
the KOTOR config program shows a little yellow dot next to the graphics card - which i think means it passes the required graphics if not the reccomended.
That means it doesn't pass the recommended specs. and did you try adding disable vertex buffer objects=1 under the graphics options in your swkotor2.ini?
Link to comment
Share on other sites

  • 1 month later...
those screenshots are of a dead card or dying. I had that problem with a 9700 pro and ended up having to scrap it

 

I agree. or looks like the card is overclocked to high. the card may be overclocked if your FSB is to high, makeing the AGP run higher then spec.

try underclocking the card see if it helps.

 

Save up for a new card. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...