Jump to content
  • 1
sam_ihsan

Neketaka Guards turn hostile when starting a fight in Queen's Berth

Question

As per title, I was going to attack Cotta to resolve the quest The Shipwright's Plight but when combat started, hostile guards rushed into the scene and there were quite a few terrified civilians (yellow circles at feet) suddenly appearing at the north exit nearby. This was on Steam, latest patch and on turn-based mode.

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 1
Posted (edited)

I'm having this issue as well with Lord Imp in turn-based mode.  This bug makes the bounty undoable.

 

EDIT:
 
OK just found out that if you confront him at night you won't trigger the guards.
 
EDIT 2:
 
Nope, near the end of the fight the guards decided to jump in.  :(
Edited by Berkyjay

Share this post


Link to post
Share on other sites
  • 0

The same thing happened to me. I can sort of understand the guard attacking my party on account of me initiating the fight, but the scarred civilians appearing out of nowhere were definitely a bug.

Share this post


Link to post
Share on other sites
  • 0

Hello sam_ihsan,

 

Thank you for posting this issue, Ill get it examined by QA to reproduce. If you could provide us with a save file to support.obsidian.net it would help in this endeavor.

 

Best,

 

-Caleb


I like big bugs and I cannot lie...

Share this post


Link to post
Share on other sites
  • 0

Same bug here. Seems to be Tiela and some others that appear in the corner out of nowhere and with yellow circles. The guards didn't show when I just shot the gunpowder barrel and killed all but the priest--I attacked and killed the priest after, no guards but Tiela and others still magically appeared in the corner.

Share this post


Link to post
Share on other sites
  • 0

I have the same problem with Lord Admiral Imp in Queen's Berth, Steam, latest patch, turn-based.

 

Fight goes OK for a few rounds, until suddenly guards join in from all over city. I am avoiding AOE spells, but this has happened with six attempts.

Share this post


Link to post
Share on other sites
  • 0

Same again for lord admiral. I finally managed to do it after 10+attempts with the guards attacking me for no reason. Katrenn is even worse--haven't been able to work around it yet there. It seems to be all fighting in Neketaka.

Share this post


Link to post
Share on other sites
  • 0

Same issue for me. Tried different things like imitating combat with my main (who is a Paladin, doh!) standing far away. Sometimes I can do half the battle before the guards aggro and sometimes the aggro at combat start.

 

I also run in turn based mode.

 

This is a serious bug and should be addressed by developers.

Share this post


Link to post
Share on other sites
  • 0

It still isn't fixed. I've just ran into this too, with the Lord Admiral Imp bounty in turn-based mode.

Share this post


Link to post
Share on other sites
  • 0

I also encounter this problem with Lord Admiral's Imp. For some reason Katrenna did not gave me any issues, some of the devouts actually helped with healing :p

This was in TB mode and i tried starting on the bridge, the pier and further away to no avail. Then I changed the time to midnight, because I thought less commoners to trick guards into the fight. There were less or it was just luck. I started next to the Wild Mare again and had my Main character run back to the inn. I killed the Champions and the imp there, the skirmisher just didn't want to follow. I only used melee/ranged attacks and no Circle of Protection from my Priest. Only used Gaze of the Adragan once with my Wizard and Breath of Flames from the Dragon Pendant on my Fighter/tank. I had Serafen equiped with an Arquebus and didn't had him use any Barb skills neither. I just did not wanted to risk any AoE. After I killed teh 3 melee characters I moved Eder up with Escape(Fighter/Rogue build) and kill the skirmisher on his own in 2 or 3 rounds. That did it for me. I'll Include some pictures if possible. This is my first post as it looked some people needed help with it and this did it for me :) GL peepz

 

https://imgur.com/a/s1ITX38

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...