Jump to content
  • 0
markod

[3.0] "Missing DLC" after patch 3.0

Question

I have GOG version of the game and yesterday before patch 3.0 all was well.

 

Today the game was patched and now I cannot load any saves, because it says "Missing DLC" (See attached image). Makes me a bit frustrated as my last save is at the beginning of the end game. I do not have the Beast of Winter and Slayer, seeker, survivor DLCs, but I do have the free ones and the backer one.

 

Also main screen loading now takes considerably longer and clicking on any option in the menu (like load or options) also takes a lot of time.

 

Help?

 

edit: added missing attachment and output_log.txt

post-55160-0-29659300-1537989339_thumb.jpg

output_log.txt

Edited by markod

Share this post


Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0

I'm also experiencing this bug.  When I hover over the saves it says that I don't have "Beast of Winter" (which is true, but I never had that dlc for any of the saves) and that I don't have "LAXF" (not sure what dlc that is).

Share this post


Link to post
Share on other sites
  • 0

I have the same issue after updating to the latest version on the GOG client.

I cant load my save and it says Missing DLC (Beast of Winter and LAXF).

The reason might be a bug in the older version of the game, because I remember that it said "Beast of Winter - Installed" in the main menu, even though I never bought it. But this is not my fault and I would really like to continue with this save.

Share this post


Link to post
Share on other sites
  • 0

Hi markod,

 

I'm sorry to hear that you are experiencing issues loading your saves. The first thing I'd like to suggest is that you verify the integrity of your game files. If your issue still persists, could you please provide us with your save files so that we may further investigate your issue? You can either provide them in your post via a Dropbox link or you can email us at support@obsidian.com. If you do email us, please link this forum post and provide your forum username so that we may identify you easily.

 

Also, could you provide us with a screenshot or let us know what DLCs the tooltip says is missing? You can see this by hovering over the "Missing DLC" button on your save. This information will help us greatly in our investigation.

 

As for the slow menu interactions, this could be attributed to having a very large number of save files. If this is the case, then I'd suggest deleting a number of saves. Alternatively, you may also copy those saves in another location on your computer before deleting them should you wish to keep them for later use.

Share this post


Link to post
Share on other sites
  • 0

Thank you for your response.

 

Unfortunately, verification of integrity did not help.

 

Here is the link to a few of my saves: https://www.dropbox.com/s/0rih6ua86ad61l1/saves.zip?dl=0

 

and I attached couple of screenshots of the tooltip and which DLCs are installed.

 

On a positive note, moving most of my saves from the save folder did speed up menu interaction (I had over 200 saves).

post-55160-0-99715000-1538162477_thumb.jpg

post-55160-0-69162500-1538162525_thumb.jpg

Share this post


Link to post
Share on other sites
  • 0

In the meantime i tried downpatching the game in the GOG Client to version 2.1.0.0034 and it worked again.

This is obviously not the solution we are looking for, but atleast it is possible to keep playing the game.

Share this post


Link to post
Share on other sites
  • 0

As mentioned, the downgrade works, but apparently 2.1 has an ending slide bug, causing it to be stuck at one slide. Apparently it's a bug connected with BoW DLC (https://forums.obsidian.net/topic/105175-stuck-on-epilogue-page-cant-continue/). It happened to me at the same page as described in the linked topic.

 

The 2.1 version also shows I have BoW installed at the main menu (when I really don't), so could that be the reason for the ending slide bug and the "missing dlc" bug in 3.0?

Share this post


Link to post
Share on other sites
  • 0

Yeah, your save was created when the game thought it had BoW installed due to a bug in v2.1.  This bug is GOG-exclusive.

 

The LAXF part of the warning is incorrect - a UI bug that I've fixed.  You automatically have LAXF if you have v3.0 or later.

 

We're working on a fix for this. You can temporarily work around the issue on v3.0.0 by creating the directory /PillarsOfEternityII_Data/lax2_exported, which will continue fooling the game into thinking it has the BoW DLC (though none of the content will actually be present).  This will cause the end-game slides to break.

Share this post


Link to post
Share on other sites
  • 0

Is this valid for Mac version as well?

 

You can temporarily work around the issue on v3.0.0 by creating the directory <game>/PillarsOfEternityII_Data/lax2_exported, which will continue fooling the game into thinking it has the BoW DLC (though none of the content will actually be present). 

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

The fix for affected GOG users is in the 3.1.0 patch.  The patch is currently on the Beta Patch branch if you wanted to get back to the updated content.  Otherwise, the patch will be going onto the Default branch later this week.  If you update to the 3.1.0 build and this is still giving you an issue, please let us know and send the save to support@obsidian.net so we can look into your specific issues further.

 

Thank you for your patience with this issue and sorry for the inconvenience it has caused.

Share this post


Link to post
Share on other sites
  • 0

Hey everyone,

The fix for affected GOG users is in the 3.1.0 patch.  The patch is currently on the Beta Patch branch if you wanted to get back to the updated content.  Otherwise, the patch will be going onto the Default branch later this week.  If you update to the 3.1.0 build and this is still giving you an issue, please let us know and send the save to support@obsidian.net so we can look into your specific issues further.

 

Thank you for your patience with this issue and sorry for the inconvenience it has caused.

 

Hello SChin,

 

i have a similar problem. i have none of the payment DLCs, only the free ones. I used a translation correction mod which seems to have make the game "think" i have both DLCs installed (but i don't) and now, after the latest patch, the game no more acts like i have them. Unfortunately, i can not use my savegames anymore because it says i'm missing a DLC. But i never had it. Anything i can do? I use the Steam version of the game.

Share this post


Link to post
Share on other sites
  • 0

 

Hey everyone,

The fix for affected GOG users is in the 3.1.0 patch.  The patch is currently on the Beta Patch branch if you wanted to get back to the updated content.  Otherwise, the patch will be going onto the Default branch later this week.  If you update to the 3.1.0 build and this is still giving you an issue, please let us know and send the save to support@obsidian.net so we can look into your specific issues further.

 

Thank you for your patience with this issue and sorry for the inconvenience it has caused.

 

Hello SChin,

 

i have a similar problem. i have none of the payment DLCs, only the free ones. I used a translation correction mod which seems to have make the game "think" i have both DLCs installed (but i don't) and now, after the latest patch, the game no more acts like i have them. Unfortunately, i can not use my savegames anymore because it says i'm missing a DLC. But i never had it. Anything i can do? I use the Steam version of the game.

 

 

Additional Information: The german translation correction installs the text file from all expansions as an addition language set. This worked fine in the past.

Share this post


Link to post
Share on other sites
  • 0

Ok, we found a workaround. You need to add a manifest.json file, if you dont have the expansions and can not load a save game, with the following content.

 

E. g. :

{
    "ProductPackage": "LAX1"
}

 

or:

{
    "ProductPackage": "LAX2"
}

 

The files need to be placed in:

...Pillars of Eternity II\PillarsOfEternityII_Data\lax1_exported

...Pillars of Eternity II\PillarsOfEternityII_Data\lax2_exported

Share this post


Link to post
Share on other sites
  • 0

This issue should be fixed without any changes needed for LAX1 and LAX2 in v3.1.1 (upcoming).

Share this post


Link to post
Share on other sites
  • 0

To be clear, you shouldn't work around this problem by manually creating manifest.json files for large (numbered) expansions.  This will cause the game to think that expansion is installed, which may cause certain things to break if you don't actually have that expansion.

Share this post


Link to post
Share on other sites
  • 0

Any idea how soon "upcoming" is? I have all the dlc installed and prior to the latest patch everything was fine. After 3.1 says missing dlc.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...