Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

[2.1] & [3.0] Companion Relationships Bugged

- - - - - companions bug beta

  • Please log in to reply
7 replies to this topic

#1
nostalchic

nostalchic

    (1) Prestidigitator

  • Members
  • 32 posts
  • Deadfire Backer
Have made a thread for this as it's now confirmed to occur for more than just myself - it appears as though companion relationships are bugged in the beta patch.
 
More specifically my PCs no longer get hit on automatically by either Tekehu or Maia Rua upon reaching level 1 or 2 - including Maia acknowledging any other relationships. I can however follow the Aloth track (oddly even if I just state we were only friends in his initial friendship talk). I'm not sure if the game is locking my PC into the Aloth track automatically, or the initial dialogues for others aren't firing for some reason, though it appears to be the former.
 
I noticed when I was testing my Aloth disposition mod, but it still occurs on a clean new playthrough.

Edited by nostalchic, 20 September 2018 - 03:36 AM.


#2
Absolutvoll

Absolutvoll

    (0) Nub

  • Initiates
  • 4 posts
  • Deadfire Silver Backer
  • Fig Backer
I noticed the same thing. The dialogue after reaching positive disposition with Maia doenst trigger.
  • Aramintai likes this

#3
ChaosPT

ChaosPT

    (1) Prestidigitator

  • Members
  • 15 posts

same thing here.



#4
RuralBuddha

RuralBuddha

    (1) Prestidigitator

  • Members
  • 15 posts
  • Deadfire Backer
  • Fig Backer

Can also confirm, conversation with maia doesn't trigger at reputation level 2. The line in the repututation UI from the watcher to maia is grey like it is with companions at reputation level 0. I added reputation points with maia via console and it didn't change anything (line stayed grey, dialogue didn't happen). Initiating the conversation via

 

StartConversation Companion_Maia(Clone) companion_maia_relationship_player 1

 

started the dialogue and the line in the reputation UI turned blue.



#5
uuuhhii

uuuhhii

    (4) Theurgist

  • Members
  • 385 posts

same thing happened with maia

didn't notice other companion have the same problem or not



#6
nostalchic

nostalchic

    (1) Prestidigitator

  • Members
  • 32 posts
  • Deadfire Backer

This appears to still be occurring in the 3.0 Beta Patch.



#7
L4wlight

L4wlight

    (4) Theurgist

  • Members
  • 286 posts
  • Location:Germany
  • Deadfire Silver Backer
  • Fig Backer
  • Black Isle Bastard!

Same for me.



#8
SChin

SChin

    Product Services Manager

  • Developers
  • 887 posts
  • Location:Irvine, CA

Hey everyone,

 

Would you be able to provide us with some saves where this has occurred and for which companion(s) this happened to?  If needed you can find instructions on where to find your save files here.  You can either provide a link to your files via Dropbox or you may attach them to an email for us at support@obsidian.net. If you do email us, please link this post and mention your forum username so that we may identify you easily.

 

Thank you for letting us know about this and sorry for the in convenience this is causing.







Also tagged with one or more of these keywords: companions, bug, beta

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users