Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Graphical Artifacts and freezing

graphics graphical artifacts freezing

  • Please log in to reply
3 replies to this topic

#1
mishraile

mishraile

    (0) Nub

  • Initiates
  • 1 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

I have been having an issue with the graphics completely wigging out on me with pillars 2. It used to be only once in a while and didn't render the game unusable, but recently has been now happening immediately upon booting up the game every time. Basically it initially looks like pretty little artifacts on the screen that flicker and change, multicolored, then after a few minutes the screen freaks out and starts jumping all over the place and then eventually completely freezes.

 

My Specs:
Intel i5-6600 3.30 GHZ CPU

32 GB Ram

NVidia GeForce 970

Win 10 Home

 

I updated my NVidia video card drivers to the most recent

I updated Windows

I set that MSSA (or... MSAA or whatever) to 1 like people suggested.

I lowered graphics level down to medium

I have rebooted the game and my computer multiple  times.

 

Any Help would be appreciated.



#2
kilay

kilay

    (5) Thaumaturgist

  • Members
  • 524 posts

I have been having an issue with the graphics completely wigging out on me with pillars 2. It used to be only once in a while and didn't render the game unusable, but recently has been now happening immediately upon booting up the game every time. Basically it initially looks like pretty little artifacts on the screen that flicker and change, multicolored, then after a few minutes the screen freaks out and starts jumping all over the place and then eventually completely freezes.

 

My Specs:
Intel i5-6600 3.30 GHZ CPU

32 GB Ram

NVidia GeForce 970

Win 10 Home

 

I updated my NVidia video card drivers to the most recent

I updated Windows

I set that MSSA (or... MSAA or whatever) to 1 like people suggested.

I lowered graphics level down to medium

I have rebooted the game and my computer multiple  times.

 

Any Help would be appreciated.

Try this

https://forums.obsid...te-and-stutter/



#3
wagmainis

wagmainis

    (1) Prestidigitator

  • Members
  • 6 posts

Hi,

 

I am also having these issues to the point where I'd have to hard reset my computer. I have tried what kilay (that word means 'eyebrow' in my native tongue) suggested but it seems to still happen. I noticed it happens mostly when I or when enemies cast light intensive magic (fan of fire, fireball, wall of fire, wall of many colors, etc.) OR if 'Lights' is ticked on. My specs are below if it's any help.

Core i5-6600 3.0Ghz

R9 390 8gb

16gb RAM

 

My graphics settings are in the attached image.

Attached Files


  • kilay likes this

#4
wagmainis

wagmainis

    (1) Prestidigitator

  • Members
  • 6 posts

restricting the framerate to 45 helped a little. i could cast pull of eora like 3 times in the middle of queen's berth while casting fireballs and fans of flames left and right and the game does not graphically glitch out. tried it in the hanging sepulchers in the room with 6 flames are burning and graphical glitches returned. i recommend keeping the lights and glow effects ticked off, jacking the VFX opacity aaaaaaaaaaaaaaaaaaaall the way to the left, keeping MSAA to 1, and keeping VSync on all the time.







Also tagged with one or more of these keywords: graphics, graphical artifacts, freezing

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users