Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

I've finally found a way to stabilize framerate and stutter.


  • Please log in to reply
18 replies to this topic

#1
Postenago

Postenago

    (0) Nub

  • Initiates
  • 2 posts
After much trial and tests i've finally stabilize my framerate and massively toned down the unity engine stutters. I've read so many complaints in this forum and steam regarding the horrendous framerate and also stutters i've decided to share my tweak and hopefully yours will work as smooth as mine. No guarantees.

Here if you have a powerful card you'll want to limit your frame to 60 or if you have a budget card i suggest 30 via Rivatuner.

Here's the step by step.

1. Go to your Nvidia control panel, under manage 3D, choose POE 2.
2. Look for AA: FXAA and turn it on. ( You can leave this to off if you need higher fps )
3. Move to Anti Aliasing - Mode and select override.
4. Then AA - Transparency to 2x.

Step 2 to 4 will ensure subtle eye candy while keeping performance in check.

5. Move to Triple Buffering and choose ON.
6. Below it, V-Sync, set it to ON as well. Do not use Adaptive or Fast.
7. Open RivaTuner, add POE2 to the list and limit your frame to either 30 or 60.
8. Launch the game, go to option and graphic, Enable Fullscreen, AA set to 1 and Uncheck V-sync. You can tweak the rest of the option to your likings depends on how powerful your GPU is.

FYI im using GTX 1070 i have those settings up plus Shadow, Misc, and the 2 Ambients ticked and my game now runs at a stable 60 fps and minimal stutters. Note that Neketaka will still give your framerates hell so that cant be avoided. Oh btw im using the newest nvidia driver 397.93.

I apologize to AMD gpu owners as i have no clue how to set those in the Crimson Control panel you'll have to search for those options yourself.

Hopefully you guys can get the performance that i've gotten as well. Ac?
  • kierun, Zares, Andronidas and 2 others like this

#2
Postenago

Postenago

    (0) Nub

  • Initiates
  • 2 posts
Btw installing the game to an SSD will help improve stutter by a huge margin abd also remember to turn off Telemetry ( uncheck the box ) under Options too.
  • kierun likes this

#3
dambros

dambros

    (2) Evoker

  • Members
  • 59 posts
  • Steam:dambros
Thanks for this. I will definitely give this a try lter when Im home because fps has been my doom in this game so far woth a Gtx1070 as well.

#4
adragojlovic

adragojlovic

    Obsidian Alumni

  • Members
  • 828 posts
Greetings,
 
And thank you all for taking the time to post your questions and answers on our forums :) Should you have any additional questions or concerns let us know.
 
Cheers.


#5
kilay

kilay

    (5) Thaumaturgist

  • Members
  • 524 posts

After much trial and tests i've finally stabilize my framerate and massively toned down the unity engine stutters. I've read so many complaints in this forum and steam regarding the horrendous framerate and also stutters i've decided to share my tweak and hopefully yours will work as smooth as mine. No guarantees.

Here if you have a powerful card you'll want to limit your frame to 60 or if you have a budget card i suggest 30 via Rivatuner.

Here's the step by step.

1. Go to your Nvidia control panel, under manage 3D, choose POE 2.
2. Look for AA: FXAA and turn it on. ( You can leave this to off if you need higher fps )
3. Move to Anti Aliasing - Mode and select override.
4. Then AA - Transparency to 2x.

Step 2 to 4 will ensure subtle eye candy while keeping performance in check.

5. Move to Triple Buffering and choose ON.
6. Below it, V-Sync, set it to ON as well. Do not use Adaptive or Fast.
7. Open RivaTuner, add POE2 to the list and limit your frame to either 30 or 60.
8. Launch the game, go to option and graphic, Enable Fullscreen, AA set to 1 and Uncheck V-sync. You can tweak the rest of the option to your likings depends on how powerful your GPU is.

FYI im using GTX 1070 i have those settings up plus Shadow, Misc, and the 2 Ambients ticked and my game now runs at a stable 60 fps and minimal stutters. Note that Neketaka will still give your framerates hell so that cant be avoided. Oh btw im using the newest nvidia driver 397.93.

I apologize to AMD gpu owners as i have no clue how to set those in the Crimson Control panel you'll have to search for those options yourself.

Hopefully you guys can get the performance that i've gotten as well. Ac?

 

Many many many Thnks, your setting really improved my performance with 1.1. 

I'm using A GTX 960M



#6
Wormerine

Wormerine

    Arch-Mage

  • Members
  • 3104 posts
  • Location:Belfast
  • Deadfire Backer
  • Fig Backer

What kind of sorcery is this? It actually made the game look and run much better. 



#7
AeonsLegend

AeonsLegend

    (6) Magician

  • Members
  • 740 posts

Stutter started for me on patch 1.1 although it might have something to do with Unity console. I will test these settings. I have an M2 960 EVO SSD with 10x the performance of a normal ssd and the game still has a lot of stutter. Something I didn't have before 1.1.

 

Edit: tried settings and although it did help with performance it also broke my visuals. Got screen tearing, artifacts and screen flickering. Makes the game unplayable.

 

Edit 2: removing Unity console fixed my frame stutter. :D


Edited by AeonsLegend, 17 June 2018 - 05:07 AM.

  • Suen likes this

#8
kilay

kilay

    (5) Thaumaturgist

  • Members
  • 524 posts


 

Edit: tried settings and although it did help with performance it also broke my visuals. Got screen tearing, artifacts and screen flickering. Makes the game unplayable.

 

 

i'm usingf this setting in game with the other suggested in the OP and all is smooth and fine

 

Pillars_of_Eternity_II_Deadfire_Screensh



#9
AeonsLegend

AeonsLegend

    (6) Magician

  • Members
  • 740 posts

 



 

Edit: tried settings and although it did help with performance it also broke my visuals. Got screen tearing, artifacts and screen flickering. Makes the game unplayable.

 

 

i'm usingf this setting in game with the other suggested in the OP and all is smooth and fine

 

Pillars_of_Eternity_II_Deadfire_Screensh

It may have something to do with the differences in hardware. No matter, I have the default settings without the tweaks in this topic and the game runs smooth as well and that is all I wanted.


Edited by AeonsLegend, 17 June 2018 - 06:35 AM.


#10
Andronidas

Andronidas

    (1) Prestidigitator

  • Members
  • 17 posts
  • Deadfire Backer
  • Fig Backer

Thank you, this is great! You fixed my problems in cities (no stutter at all now!) and i experience much less stutter in fights. Any ideas to bring the fight-stutter down as well?

 

I have a GTX 960M running on a laptop.

 

Cheers!



#11
Insolentius

Insolentius

    (5) Thaumaturgist

  • Members
  • 487 posts
  • Location:Tuzla, Bosnia & Herzegovina
  • Deadfire Backer
  • Fig Backer

Thank you, this is great! You fixed my problems in cities (no stutter at all now!) and i experience much less stutter in fights. Any ideas to bring the fight-stutter down as well?

 

I have a GTX 960M running on a laptop.

 

Cheers!

No stuttering in Queen's Berth on a GTX 960M?

 

giphy.gif



#12
manveru1986

manveru1986

    (1) Prestidigitator

  • Members
  • 12 posts
  • Steam:manveru1986
  • PSN Portable ID:manveru1986
  • Deadfire Backer
  • Fig Backer

Anyone has similar workaround for a Mac Version?



#13
deadreak

deadreak

    (1) Prestidigitator

  • Members
  • 31 posts
  • Deadfire Backer
  • Fig Backer

Same, worked fine on MAC, but after last patch game is unplayable. Frame rate is like at 10 with turning everything off. How do you guys keep making your game worse with time... frustrating as hell. 



#14
Wiseude

Wiseude

    (1) Prestidigitator

  • Members
  • 20 posts

Game is choppy and has lower fps if I don't use "-window-mode exclusive"



#15
Wiseude

Wiseude

    (1) Prestidigitator

  • Members
  • 20 posts

After much trial and tests i've finally stabilize my framerate and massively toned down the unity engine stutters. I've read so many complaints in this forum and steam regarding the horrendous framerate and also stutters i've decided to share my tweak and hopefully yours will work as smooth as mine. No guarantees.

Here if you have a powerful card you'll want to limit your frame to 60 or if you have a budget card i suggest 30 via Rivatuner.

Here's the step by step.

1. Go to your Nvidia control panel, under manage 3D, choose POE 2.
2. Look for AA: FXAA and turn it on. ( You can leave this to off if you need higher fps )
3. Move to Anti Aliasing - Mode and select override.
4. Then AA - Transparency to 2x.

Step 2 to 4 will ensure subtle eye candy while keeping performance in check.

5. Move to Triple Buffering and choose ON.
6. Below it, V-Sync, set it to ON as well. Do not use Adaptive or Fast.
7. Open RivaTuner, add POE2 to the list and limit your frame to either 30 or 60.
8. Launch the game, go to option and graphic, Enable Fullscreen, AA set to 1 and Uncheck V-sync. You can tweak the rest of the option to your likings depends on how powerful your GPU is.

FYI im using GTX 1070 i have those settings up plus Shadow, Misc, and the 2 Ambients ticked and my game now runs at a stable 60 fps and minimal stutters. Note that Neketaka will still give your framerates hell so that cant be avoided. Oh btw im using the newest nvidia driver 397.93.

I apologize to AMD gpu owners as i have no clue how to set those in the Crimson Control panel you'll have to search for those options yourself.

Hopefully you guys can get the performance that i've gotten as well. Ac?

What if you have g-sync?tripple buffering still ON?



#16
Drabble

Drabble

    (1) Prestidigitator

  • Members
  • 19 posts
  • Location:Paris
  • Pillars of Eternity Silver Backer
  • Deadfire Silver Backer
  • Fig Backer

Good question for G-Sync.

Any news of an nvidia optimised driver for POE2 ?



#17
screen

screen

    (0) Nub

  • Initiates
  • 3 posts

Cannot say for windows, but the last Nvidia beta driver 396.54 for Linux (that apparently fixed a memory leak issue present since 39x version) improved my framerate.

FPS was droping to 10fps during the majority of the fights.

It is now quite smooth, except on water (i7 + GTX660).



#18
kierun

kierun

    (2) Evoker

  • Members
  • 80 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Backer
  • Fig Backer

I'd add my voice to say thank you!



#19
JFutral

JFutral

    (4) Theurgist

  • Members
  • 375 posts
  • Deadfire Silver Backer
  • Fig Backer

Crazy. All these posts with Nvidia issues and it is the Radeon card letting me down. The Nvidia ran POE smooth as butter. The AMD card is crap. But I can put my Macbook Pro to sleep and use clamshell mode with the AMD. The Nvidia would crashed my Mac. Ah, Apple. Yet another reason I hate thee.

 

Joe






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users