Jump to content

OS X: Black screen. resolution switching, and external display issues

Darren Monahan

12,214 views

A number of users have reported they are seeing black screens when playing the game, usually when switching resolutions, or toggling between windowed mode and full screen. We've also had reports of similar behavior when trying to use external displays.

 

We've looked into this issue extensively on our end, and we've found a reproducible case within the engine and have sent it off to the folks at Unity to investigate further.

 

In the meantime as a workaround, you can generally press Command-F to get yourself into a state where you can save your game, quit, and restart. Pressing Command-F toggles between windowed mode and fullscreen (and back if you press it again).

 

Pending fix in version: Unknown

  • Like 4


30 Comments


Recommended Comments



Jepp, It´s a famous Unity-engine problem under OSX. I got this bug in actual 3 games based on Unity.

  • Like 1

Share this comment


Link to comment

I get this error also, running Pillars on a Macbook Pro with an external LG 4K monitor connected via display port.  Also selecting or un-selecting "run in full screen" does nothing for me in options, when I am just running on the laptop and not the external display.

 

Something unique to my situation you may be able to fix - I run the monitor in portrait mode (taller than it is wide).  Whatever automatically scales the game to fill the screen ALWAYS expands to full the full height of the screen - as a result a ton of the game screen is cut off on the left and right.

 

This is important as even if the screen were not blank on the external monitor, I could not play because I cannot see the sides of the game area.

  • Like 1

Share this comment


Link to comment

Hey just came here to thank you for addressing the problem officially. Also 7/10 on the pun left on the other thread. Look forward to hearing from you soon.

Share this comment


Link to comment

Same problem here.

 

and with caged cursor not working either, this game is unplayable as shipped.

Share this comment


Link to comment

Same issue there, only one monitor hooked to my mac pro via HDMI.

Got the same issue on both Endless Legend & Dungeon of the Endless, was fixed on Dungeon of the endless a while ago. 

Share this comment


Link to comment

The last patch seemed to have made things worse : I can no longer disable fullscreen (either with the cmd+F trick or via removing the preferences pist), so I can no longer play the game at all - even in a crappy windowed mode... Let's hope the unity team gets back to you soon, I really want to play :)

  • Like 1

Share this comment


Link to comment

Had this problem on an iMac, no external displays connected. Veryfying game data in Steam and starting the App manually by locating the game files solved it for me

Share this comment


Link to comment

Same issue there, only one monitor hooked to my mac pro via HDMI.

Got the same issue on both Endless Legend & Dungeon of the Endless, was fixed on Dungeon of the endless a while ago. 

Got the same problem (PoE, Endless Legend) with my 27er LG connected via HDMI. Then I used my older 24er LG with DVI. Everything is fine there... so strange.

Share this comment


Link to comment

I was getting a black screen, no music or gauntlet pointer and nothing would happen when hitting command+F.  I didn't have an external monitor connected either.  However I found I can get the game to launch if I manually locate the steam game files an launched from there.  Weird because I already had the steam overlay turned off. Some sort of issue with Unity and Steam?

 

2010 Macbook Pro

2.66 GHz, Geforce GT 330M 512mb, 8GB

OSX 10.10.2

Share this comment


Link to comment

I had this happen to me on start-up last night on OSX Yosemite. App launches then hangs w/ a beachball on a black screen before even getting to any of the splash art. It happened the first time I started the game fresh AFTER I'd changed from full screen to windowed mode in a previous gaming session (specifically to be able to use my external monitor for monitoring email and other work-related things). My game is currently unplayable, which is sad after waiting so long. 

  • Like 1

Share this comment


Link to comment

I have a Mac Pro with the same flickering issue when I use the cmd+F trick. Through some magic I got it to run in a windowed mode. I changed my screen resolution to 1600x900 before starting the game. After starting the game I keep hitting cmd+f until I can navigate and change the resolution in game to 1600x900 as well and uncheck full screen. Then I quit the game. When I set my screen back to 1080p and start the game normally it stops flickering and works in a windowed view. No other resolution works for me.

 

Likely a lot of voodoo and the trick is actually simpler but it worked for me.

Share this comment


Link to comment

Fullscreen not working for me on Mac with latest patch either.  Cmd + F just makes the screen flicker, doesn't switch to windowed mode.  Late 2013 MacBook Pro using a Dell external monitor connected via DisplayPort, but it's my primary monitor (macbook lid is closed).

Share this comment


Link to comment

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...