Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!




Photo
* * * * * 4 votes

OS X: Black screen. resolution switching, and external display issues

Posted by Darren Monahan , in Macintosh OS X 02 April 2015 · 11797 views

os x black screen resolution external display pillars of eternity
A number of users have reported they are seeing black screens when playing the game, usually when switching resolutions, or toggling between windowed mode and full screen. We've also had reports of similar behavior when trying to use external displays.

We've looked into this issue extensively on our end, and we've found a reproducible case within the engine and have sent it off to the folks at Unity to investigate further.

In the meantime as a workaround, you can generally press Command-F to get yourself into a state where you can save your game, quit, and restart. Pressing Command-F toggles between windowed mode and fullscreen (and back if you press it again).

Pending fix in version: Unknown

  • None, mouton.rebelle, Valkyrieca and 1 other like this



Jepp, It´s a famous Unity-engine problem under OSX. I got this bug in actual 3 games based on Unity.

    • corobinson likes this
Thanks, please pursue a fix ASAP!

I get this error also, running Pillars on a Macbook Pro with an external LG 4K monitor connected via display port.  Also selecting or un-selecting "run in full screen" does nothing for me in options, when I am just running on the laptop and not the external display.

 

Something unique to my situation you may be able to fix - I run the monitor in portrait mode (taller than it is wide).  Whatever automatically scales the game to fill the screen ALWAYS expands to full the full height of the screen - as a result a ton of the game screen is cut off on the left and right.

 

This is important as even if the screen were not blank on the external monitor, I could not play because I cannot see the sides of the game area.

    • corobinson likes this

Hey just came here to thank you for addressing the problem officially. Also 7/10 on the pun left on the other thread. Look forward to hearing from you soon.

Same problem here.

 

and with caged cursor not working either, this game is unplayable as shipped.

cmd+f does not work for me at all. it just flickers. i'm on an early 2009 Mac Pro.

Photo
mouton.rebelle
Apr 06 2015 01:52 PM

Same issue there, only one monitor hooked to my mac pro via HDMI.

Got the same issue on both Endless Legend & Dungeon of the Endless, was fixed on Dungeon of the endless a while ago. 

Photo
mouton.rebelle
Apr 06 2015 02:20 PM

The last patch seemed to have made things worse : I can no longer disable fullscreen (either with the cmd+F trick or via removing the preferences pist), so I can no longer play the game at all - even in a crappy windowed mode... Let's hope the unity team gets back to you soon, I really want to play :)

    • MoebiusDreams likes this
Unplayable for me - how can I get a refund?
    • MoebiusDreams, warpandwoof and corobinson like this

Late-2013 15" Retina MacBook Pro here running 10.10.2, no issues at all.

Had this problem on an iMac, no external displays connected. Veryfying game data in Steam and starting the App manually by locating the game files solved it for me

Same issue there, only one monitor hooked to my mac pro via HDMI.

Got the same issue on both Endless Legend & Dungeon of the Endless, was fixed on Dungeon of the endless a while ago. 

Got the same problem (PoE, Endless Legend) with my 27er LG connected via HDMI. Then I used my older 24er LG with DVI. Everything is fine there... so strange.

I was getting a black screen, no music or gauntlet pointer and nothing would happen when hitting command+F.  I didn't have an external monitor connected either.  However I found I can get the game to launch if I manually locate the steam game files an launched from there.  Weird because I already had the steam overlay turned off. Some sort of issue with Unity and Steam?

 

2010 Macbook Pro

2.66 GHz, Geforce GT 330M 512mb, 8GB

OSX 10.10.2

I had this happen to me on start-up last night on OSX Yosemite. App launches then hangs w/ a beachball on a black screen before even getting to any of the splash art. It happened the first time I started the game fresh AFTER I'd changed from full screen to windowed mode in a previous gaming session (specifically to be able to use my external monitor for monitoring email and other work-related things). My game is currently unplayable, which is sad after waiting so long. 

    • Spost likes this

Can we get an update on maybe when this be resolved. I'd like to, you know, play the game

    • MoebiusDreams, warpandwoof and Valkyrieca like this
Photo
NexusEclipse
Apr 16 2015 07:22 PM
I have a Mac Pro with the same flickering issue when I use the cmd+F trick. Through some magic I got it to run in a windowed mode. I changed my screen resolution to 1600x900 before starting the game. After starting the game I keep hitting cmd+f until I can navigate and change the resolution in game to 1600x900 as well and uncheck full screen. Then I quit the game. When I set my screen back to 1080p and start the game normally it stops flickering and works in a windowed view. No other resolution works for me. Likely a lot of voodoo and the trick is actually simpler but it worked for me.
Photo
mouton.rebelle
Apr 17 2015 01:14 PM

Any update from the Unity team regarding this issue ? Thanks !

Photo
mouton.rebelle
Apr 30 2015 12:38 PM

Any option to get a refund ? It's been a month and I still can"t play... 

    • Houdini7 likes this

Still broken in newest patch.

    • mouton.rebelle likes this
Photo
mouton.rebelle
May 21 2015 01:24 PM

Can we get an update on this ? 

February 2019

S M T W T F S
     12
3456789
10111213141516
171819 20 212223
2425262728  

Recent Entries

Recent Comments